Fuze bricked?


My son’s 4gb Fuze has a problem booting. It worked fine for a year. He tried to use a new Samsung microSD card, and started to have the following problem:

At power on, white ‘sansa’ appears on black screen, then dissolves to ‘fireworks’, but ‘flower’ is not rebuilt from the colored specks. There is then a solid white screen for about 1/4 second, then ‘sansa’ appears again, dissolves into ‘fireworks’ and freezes right there. Our only solution to do anything at this point is to power off by holding the power switch to ‘on’ for 10 secs.

I’ve tried to reset using the method in this forum, (hold switch, hold down << while plugging in the connector already in the computer). I tried doing this many times, following the directions from many different posts, all no help. Tried holding down ‘home’ while powering on, tried ‘play’ while powering on, no go. My computers will not recognize it at all, I think because it has not gotten to the point in the boot sequence where it CAN be recognized.

I just now noticed it will no longer power on, maybe because of a dead battery(?).

Anyone have any thoughts on what I can do next?