Fuze behaviour change after format

Hi,

When I first got the Sansa Fuze it was recongnized and mounted under Linux as “Sansa Fuze 2GB”.  However, after using the format command under system settings, it is now mounts as disk.  Basically the format changed the behaviour somewhat under Linux.  I’m also on .22 version of firmware.  Banshee will now not communicate with the device, although other programs can such as rhythmbox.  I would just like to know what could have caused this, i.e., what changes are made when a format command is run and has the .22 version of the software changes how the device communicates?

Thanks,

Byte

Message Edited by ByteEnable on 01-13-2009 11:50 PM

Searching for “linux format change” reveals my post about the same issue.

Banshee might be like Rhythmbox and require that the device is recognised as a “Media player” have a look the first post on this page. Your 2G Fuze may not be in the list.

Yeah, I read that post.  Someone suggested that it doesn’t have a volume label.  However, mine does have volume label as shown:

 mlabel -i /dev/sdd -s ::
 Volume label is SANSA FUZE

Even though mlabel reports that the device has a label.  I went ahead and overwrote with a new label.  That worked.  The device now mounts with the volume label as the name.

Example:

sudo mlabel -i /dev/sdx ::sansa-fuze

Thanks for that, I will try it tonight.

@hazza wrote:
Thanks for that, I will try it tonight.

I tried that and it worked, so I did a little experimenting. First I formatted the Fuze using the internal format, it mounted as 4.0G drive so I ran the command:

mlabel -i /dev/sdd -s ::

I got a response:

 Volume label is SANSA FUZE

So I labeled it using the command:

mlabel -i /dev/sda ::Sansa Fuze

I removed and re-inserted it, the icon on my desktop now said “Sansa Fuze”, the reponse I get now is:

 Volume label is Sansa Fuze (abbr=SANSA FUZE )

Obviously the internal format command is slightly off… now I have to reload all my music…