Fuze and older SDMicro Cards Transfer issues

I am not sure if this is a bug or not, but I found a pretty big problem using my old Transcend 2GB SDMicro card with my new Fuze.

When in MSC mode, no matter what, I would consistantly get CRC (Cyclic Redunancy Check) errors when dragging and dropping into the card.  Using MTP mode would fix the problem, but resulted in much slower transfers.

I thought my Fuze was defective at first, since I could drag and drop at will into the same SDMicro card from an external reader, and the Fuze would read it, but just couldn’t drag and drop.  I got my new 8GB HC SDmicro card in the mail today, and lo and behold it works like a champ dragging and dropping in MSC mode and is much faster.

I am guessing that the old SDMicro card just could not keep up with the transfer rate and eventually bombed out.  This was further illustrated when I tried using the Sansa Media Converter (SMC) to try and transfer videos to the SDMicro card.

So, in my opinion, if any of you have issues dragging and dropping to older non-HC SDMicro cards, I suggest that you use MTP mode when possible, if you can’t do that, perhaps you need to use an external reader, or replace your card.  It seems some of the older non-HC cards just can’t keep up with the data rate. 

Just a thought.  Anyone else out there with similar issues on older SDMicro Cards?

I used to have problems with a 2gb µSD card in MSC mode using my e200 series player.  I never thought about trying MTP mode.  That might have saved me a lot of grief.  I eventually ended up getting a card reader, which solved the problem I was having.  Since then I’ve replaced the old 2gb card (ran over it with one of the casters on my chair one day) with a 4gb Transcend class 6 model.  It works like a champ.  You might be right about the older cards being too slow to keep up with the data transfer rates, or else the Sansas have a firmware bug – probably something to do with buffer overflow or some such thing.