Frozen Clip Plus

Sometimes when I plug the Plus into the USB port, it opens, but when I disconnect, it is frozen. I then have to old the power key down for 30 seconds to turn it oof, but then it will not turn on.

Sometimes when I power it on, it shows the “refreshing media” screen and freezes in the middle.

Most times I it will not power on when the USB cable is connected to my laptop.

Any help appreciated, thanks

Lots of possibilities.

If you’re not charging, the cord may be broken. Try a different one.

Make sure you disconnect the Sansa from the connector in the unit–don’t unplug the USB from the computer first.

The stalled Refreshing Media could mean that there is a file it can’t digest. Look at the tags of your most recent added files with

free software mp3tag.

Go to Tools/Options/Tags/Mpeg and make the Write option ID3v2.3 and  ISO-8859-1, the Sansa’s favorite. Highlight the tags of the troublesome files.Are there Comments? Find the <blank> on the menu and Save to blank them out.

Does the album cover appear when you highlight a tag? Then the art is imbedded in the tag which makes reading it (Refreshing) much slower.  Go to View/Extended Tags and delete the embedded art with the big red X, then Save.

First off, thanks for the reply. That said…

Disconnecting via the plus either way, same thing happens disconnecting from the clip or the USB in the conputer. I have tried a few different USB cord so it is not that.

What I forgot to mention, this Clip Plus has been working faultlessly for quite a while with the files in it, so it is not a tag problem. I cannot basically access the drive, even with the unit opening, and showing directories, when I try to access any of the files in those directories, Windows File Explorer locks up and will not play any music file.

Sometimes when it DOES connect and it shows the USB conntection on the Plus screen, when disconnecting, the unitl is locked up with the screen continuing to show the “connected” screen and I have to hold the power button down for 30 seconds for the unit to shut down.

I want to believe the unti is still salvagable, because it DOES connect sometimes (although it always locks up after a connection, or a power up).

When it does USB connect, it will show the contents of a directory, but soon locks up when I try to open any of them.

I had Rockbox installed on it for a while, then uninstalled it. Also I tried to format it and the format option (from within Windows 7) will not complete. At one point I replaced the firmware manually and it rebooted as it was supposed to.

Hoping someone will help here with a good solution.

Is it possible you switched modes when you redid the firmware?

Settings/System Settings/USB mode. Try MSC.

Also, there’s the nuclear option. If you can get it to turn on, disconnected, you can go to Settings/System Settings/Format and format it from the firmware.

Hold down the << while connecting. That is supposed to force the MSC connection. If that doesn’t work, you can also try holding the center button.

Could it be some weird Windows 7 security thing? If Windows 7 can see the files you should be able to get your hands on them. How about, instead of trying to play it, try to copy a file from the unit onto your desktop or something.

If you can make a connection, take a look at its properties in Windows Explorer. Could it have been flipped to read-only or locked or something like that?

Also, I would still suspect the cord if connecting is inconsistent. Computers usually do the same thing every time unless there is a mechanical problem. Use a cord you are sure about.

And if you can somehow reload firmware…try that again.

Recent news::

You said, “Hold down the << while connecting.” I did this while turning the power on without being connected. No reaction. Then a few hours later, I tried powering the Plus, and voila, it booted all the way into the entire contents…“Music” “Settings” etc, I then charged it via a wall plug, it took the charge completely, was responsive etc. Unplugged it, went into all the directories, BUT when I tried to play any song (files that played before), it would not, but I was able to go back to the “Home” page (“Music”). Then I turned it off to see if it would reboot with a power up, unfortunately the screen frose on the flower opening page and stayed there, necessitating a 30 second hold to shut 'er down.

Trying to connect to the laptop either gives me a “UNDEF Device Connection” and Win 7 asks me if I want to format it, and it will not take a format at all. I think I will try (if I can get it to boot again), I will try to format it from within the unit. Just now it booted and I told it to restore factory settings, which it did after a short delay, then I picked English and it took me to the NorthAmerica page, at which time, it froze. Next time I can get it to boot I will try formatting it. If I can manage to put a different firmware, I will try to place a firmware package older than 01.02.18.

So what I know is that #1 the battery will charge; #2 SOMETIMES it will boot up; it will not play any files even though I can get into the directories; #3 it freezes at various points #4 it seems that any access to the directories seems to freeze it.

Again, any more insights, I think there IS a way to figure this out, and I believe the device CAN be brought back to normal life (fingers crossed)

By the wqy, what is the difference between firmware Version 2. and Firmware Version 1, are there different CLips they pertain to??

Thanks again for help here.

There are two different hardware versions of the Clip+, yes. If you can boot up again go to Settings/System Settings/Info and see whether yours is a 1.x.x version or 2.x.x to see which firmware to download.

And yes, then Format it.

Factory Settings is just things like language, backlighting, etc. It’s not a format. Format is under Settings/System Settings.

With luck you can connect after formatting and send over the firmware (don’t forget to unzip the downloaded file first). Just use the manual method–don’t go through the rigamarole of installing the Updater. Download the All Regions link for your firmware (1 or 2), unzip it, drag it over to the Sansa and disconnect. (If you put on the wrong version, it simply won’t run, so if you couldn’t find the version, just try both firmwares.)

Since << helped you boot up,  I’m wondering if there’s some bit of Rockbox left on your unit. Format should get rid of it.

Now having a hard time getting it to boot, almost never. Whewn I can, it freezes on the opening flower petal screen.


Well, your battery may be running down. Try connecting to USB  to charge for a while.

Have you tried holding the << or center buttons while connecting? Cord in computer, open Windows Explorer, connect to Sansa while holding the button. 

All I can suggest is keep trying and Format if you can get it to boot up. 

You might also ask at the and forums. 

Ok, if I connect it to the USB holding the <<key down, Windows says I have loaded an UNDEF device to the USB port, the ClipPlus window never lights up, so can it charge even if the lower doesn’t come on connected either to a wall socket or the USB post??

As an aside, if I can get it to connect (without the ClipPlus screen being activated), and the computer tells me it is an UNDEF storage device ebing connected, when I click the Remove Hardware in the Toolbar, it says "Eject M200Plus’

Too weird

I wonder if you could find that M200 in Windows’ Device Manager (via Control Panel/System)  while it’s connected and uninstall it.

Also, could you try another computer?

Also, noticed this at…OF Is Original Firmware

Formatting a Player that cannot get past the Database Refresh in the OF

If you damage the filesystem on the internal SD you can find yourself in a situation where the database refresh in the OF hangs up and you will be unable to boot into the OF and also unable to connect via usb to correct the problem. If you find yourself in this situation you can bypass the OF database refresh by connecting your player via usb and disconnecting it just after the Sandisk logo appears on the screen. This will bring you into the normal top menu in the OF and you can then format your player through the settings menu.

First off, thank you so much for your consistent help on this.

Just before I powered it on, got to a message that said “Battery Low” and turned itself off, I then quickly plugged it in to the wall socket to try to charge the battery, the flower screen came on, and froze there. Not sure if it charged or not, but when unplugged, I had to hold the power button down for 30 seconds, and now again it is unable to boot. I THINK waht may be going on is if I leave it alone for a long while, the battery MAy be restoring itself a little and then it can boot but then doesn’t have enough power to stay on. In a very low battery condition, I would assume I could simply plug it in and have the battery recharge, but that doesn’t seem to be happening. Tried with a different computer

I will try your last suffestion regarding the note from Rockbox and get back to you if I am successful…otherwise, I am disheartened, but not hopeless.

:slight_smile: I WILL keep at it.

If you have any other kind of miniUSB charger, like for a camera or phone, try plugging that in and letting it sit for a day.

Sometimes it will take a slow trickle charge, and a plain old battery charger will not get involved with the data connection that’s giving you so much trouble.

Been doing that with my USB charger for my Kindle, left it overnight last nite, and no luck this Am for a Clip boot.

Maybe I will simply leave it trickle charging for a few days, see what happens then, thanks

Trickle-charging for a few days indeed sometimes can help.

Hi Bbildman, update us after few days on how this would work for you. Would be nice to see if that would make a difference. So other users could be informed as well.

Absolutely, right now I am traveling here in the States, I normally live in Spain (I am American), so I have not forgotten. Will do an update as it allows me.

Well, so far after a few days hooked up to the wall socket, the Clip reufes to boot, it may be “dead as a doornail” – not sure if there anything I can do at this point other than buy another ZipClip that I use with Rockbox.