You might try the SD Association’s Formatter.


TL;DR - skip to the last line.

How stupid of me. I bought two SanDisk Mobile Ultra 64GB USH-I cards. I find SanDisk to be a very reputable brand - I haven’t had any problems before with USB flash drives and other MicroSD cards. In fact, I’ve only ever used SanDisk MicroSDs. I have a 64MB (yes, megabytes), two 2GB, a 4GB, 8GB, 16GB and a 32GB MicroSD card, all of which perform very reliably.

This streak was broken when I intended to purchase one for my phone and one for my tablet.

Initially all was fine with the cards; they both mounted properly, were formatted using exFAT by default and showed a 59.46GB capacity. Misleadingly enough, SanDisk’s 64GB “Mobile Ultra” MicroSDs don’t actually work on any Android device. They only work on a select few, namely those with unlicensed exFAT support such as the Samsung Galaxy S3, Note 2, Note 10.1 and various others. Knowing exFAT doesn’t work on either of my mobile devices, I then proceeded to format one of my cards to FAT32 so it would actually mount in my devices. 

The first card died immediately when I inserted it into my Samsung Galaxy S2. My phone would say “Preparing SD Card…”, then it would disappear very soon after. The card still showed up on my computer, so I tried to format again. Windows said that it was unable to complete the format. The card disconnects itself whenever I try to format it or copy files onto it. I have tried multiple readers, multiple computers and multiple OSes, all of them yielded the same “Automatic Unmount Syndrome”. So, I sent this one for replacement.

The second card I didn’t risk formatting to FAT32. To my surprise, my second device, the ASUS Eee Pad Slider, could mount and read the 64GB exFAT card. I then copied about 30GB of data to it, all seems well. The card didn’t disconnect itself, so I tried to copy more data onto it.

But the second time I connected it to my computer, it suddenly switched to read-only mode. I couldn’t rename, delete, move or copy any files on the card. So I had no choice but to format it again, but this time to NTFS. I could copy data to it, but it wasn’t detected by my ASUS Slider. This is unexpected, because the Slider can mount 2.5" portable external hard drives formatted to NTFS. So I format it to FAT32, and copy the data once again. Luckily for me, the card didn’t disconnect itself. My luck soon ran out when the card wasn’t detected by my Slider (again), but this time it was much worse than my two previous attempts.

I formatted the card to its default filesystem exFAT, but this time when I started copying my data, it disconnected itself in the same way my first card did. Formatting it will show the error “Windows was unable to complete the format”. No third party formatting software could format it. That’s the end of the road for both cards.

So from personal experience:

The SanDisk Mobile Ultra 64GB UHS-I MicroSD cards have a 100% failure rate within the first 5 file operations. Do not buy.

1 Like

I try SD Formatter v3.1,error message is (The memory card is write-protected.please release the write-protect switch),

I check memory card switch is unlock.

There is no lock switch on the micro-sized SD cards as there is on the full-size ones.

If it is still showing as write-protected, it is most likely defective and should be exhanged/eplaced under warranty by SanDisk.

1 Like

 I use 64Gb micro sdxc to adaptor have lock/unlock switch,

checking  always is unlock and use another micro sdxc adaptor to test ,same problem,

try another card reader and use another pc test,same problem.

I have e-mail sandisk technical supports to claim warranty.

sandisk is good product,i purchase sandisk many model 8,16,32gb usb flash drives , 64gb micro sdxc x 2pcs  ,64,128GB sdxc  card and 128gb ssd 

only i pcs 64gb micro sdxc problems,i need sent for warranty,already have RMA,sandisk support call me just wait …until 3 month ,but respond too slow.

i hope give me give me reply.

1 Like

I have received warranty claim sandisk 64Gb micro sdxc,I testing Read/Write ok ,

deliver very fast & service very good,Thank you all sandisk supports .

I purchased a Sandisk Ultra micro SDXC 64GB card with adapter a number of months ago to go with my Samsung Note 2.

I didn’t havew a reason to use until just this week. So I went ahead and put it into my phone but it wouldn’t recognise it. I got a message saying that the disk was blank or had the wrong filesystem.

So I put it into my laptop and I was asked to format it.

This I tried as NTFS, FAT and exFAT both through a Quick Format and a non-Quick Format. Nothing. The Quick Format stopped straight away while the longer format went approx 80% of the way before saying that “Windows was unable to complete the format.” It gave the usual check if read-only etc but all was in order.

When I went into Disk Management the microSD Card was only showing Capacity as 31MB (that is MEGA not GIGA), with the File System as RAW and Status as Healthy.

Upon checking Properties the information shows 0 (Zero) bytes for Used and Free Space. 

Is there something that I am missing here or is the card a dud?

Don’t know why but it seems to me the SanDisk product reliability has taken a sharp nosedive.  I install decentralised digital video surveillance with micro sd cards as storage.  Previous 16, 32gb were much more reliable.  Currently 50% of my recent micro sd cards won’t even format complete out of the box .  Another 25% fail within 30 days.  That leaves on 25% that really work.  Things that make you go hmmmmmm.

You Need This File From Microsoft Web Site

Go To     

And Get                                          Update for Windows XP (KB955704)

The File Should Be Called           WindowsXP-KB955704-x86-ENU.exe


I have 8 of these cards (64Gb and 32Gb) which cost us over £300, and after a few months of service, none of them work. We are asked to reformat, but only 30.6Mb is shown as memory, and then neither Windows nor Mac can format any of them. They are within warranty, and I hope that SanDisk will honour the warranty. So far, they have sent me a reply asking for a lot of information about each card, much of which is hardly visible. Let’s see what happens, but they do seem to have a quality problem with their cards.

Just to be clear, this thread is concerned with the 64GB SDXC cards. Only the 64GB size is the newer SDXC format. the 32GB ones are still SDHC.

I had similar problems with my Sandisk 64GB micro sdxc when I attempted to mount the card in my Samsung I9300 International version. After formatting the card with my Windows 7 operating system my phone displayed the following message: 

“SD card is damaged. Try reformatting it.”

The solution to my problem was to format my SD card in FAT32 instead of exFAT. 

I did this using the following method devised by user lynkdead

CONSEQUENCES OF METHOD: 1.) this process will erase all data on the card.

                                                             2.) you will no longer be able to transfer files larger than 4gb to the card 

  1. Place the card in your PC’s card reader and determine the drive designation (i.e., G:, H:, etc.)

  2. Download the fat32format utility in GUI version from here: Click on the picture to retrieve the file.

  3. Launch the guiformat.exe.

  4. Choose the drive that corresponds to your SD card.

  5. Choose the size of the SD Card you are formatting.

  6. Check the Quick Format box.

  7. Press Start.

Enjoy your usable SD card 

You problem same with me!

The quick format did not work, just FYI ( : )

64GB Sandisk SDXC

Mine was running perfectly for about 3 months, no issues then all of a sudden last week it stopped saving files (any files) in my Samsung Note 3…I’ve tried formatting in the phone, now with SanDisk Adapter on my PC…this sucks!  Luckily I was able to copy all my files over to my PC prior…so once (hopefully) I do get the SD fixed I can reload the files

1 Like

I am also a victim… I never believed SanDisk can fail so when my first 64gb micro sd card failed on my galaxy note 2 last year I blamed it on samsung but a 2nd one just failed 2 days ago…

Apparently,  when they fail u neither can copy to it or delete files already in it nor format it… I hv tried formatting it with all possible procedures n it cannot be formatted. …This is a huge let down on SanDisk. … I hv three 16gb SanDisk I bought like 3 to 4 years back n also a 32gb version n they have never failed me but in less than a year, two 64gb ultra SanDisk hv failed me…I am so much heartbroken and like u rightly said please no one should buy an ultra 64gb SanDisk cos it fails more when u get to the 40gb limit…I am presently using a third 64gb ultra SanDisk micro sd card on my galaxy note 10.1 n hv already accepted my faith that it may fail someday. … its time to move on to a new brand… am done with SanDisk for now…This is very very bad from u SanDisk. …


Same issue - I purchased the 64GB Micro-sd card in Feb-2014, then found that I could not save any more files in July-2014.

I have tried everythng, including low level format, the card is still write protected. It becomes useless.

I will surely not buy SanDisk memory card again.

:smiley:   Hi CharlesLeung888,

Dear member of SanDisk Community, welcome.

Please friend, do not grieve more, return it, is defective.

See link, and you might have a pleasant surprise:

To obtain, the internal data card, you can use the utility (free): USB Flash ChipGenius 4.00,

To find out more on this, see here:


Regards, Alfred.                                                                                (Google translated)

I would like to add my voice to the list of defective Sandisk 64gb micro sdxc card. Hardly use it and now I can’t reformat or delete the contents. I have tried every tools and tricks on both Windows and Linux and Android OS. The card is defective and it is a worry!

Can Sandisk replace my faulty card?


Contact with SanDisk Technical Support: