I’ve been there. there is no problem with the operating system you are using. it is because the SD card gets problem. 

there are quite a few solutions I found online and I believe there must be at least one that can fix the problem, such as format it at Disk Management, using command line or check and repair bad sectors.

For me I prefer buying a new SD card, as SD card can’t be completely repaired. (One of my friends whose work is repairing computer told me).

Same problem done with my card also i have 64Gb microSDXC UHS-I, Whne i removed the card when i submitted to my my HTC Desire 820 phone to at Gallery, after service of i put the memeory cards and its showing no data and also not detectin the card. I also connected to my  laptop its showing that formate the card to use. please help i want an replace ment i just but the card in march 2015. 

The article windows was unable to complete the format may help you!

I had a Sandisk micro SD to SD adapter that would move the slider to the locked position as it was inserted into the card reader. The same Sandisk card used in an old adapter I had of a different brand worked just fine.

If you have a GoPro, you can use it to reformat the card. (settings>erase>erase all/format)  This worked for me after failed attempts to reformat using diskpart.exe and other reformatting tools. 

I had 64GB SanDisk Extreme Card that was working fine until I had my son first Birthday. my heart is broken I lost all of it hundreds of photos and videos with a DSLR camera. this is crazy SanDisk where is your QA?!?!!

My card is asking me to format everytime I insert it in many machines including Mac. it used to show 64GB now only 30.6MB please help me to recover my son photos I tried everything possible :frowning:

Same here so what I did I broke it into pieces because it’s useless! Lesson learned not to buy Sandusky products next time!

It appears that I am having the same problem with my new sandisk 64 gb card as many other people are having.  I guess I’ll just have to return it to Amazon and try a different brand.

If you purchased a card on eBay they’re more than likely counterfeit and that’s probably what’s going on!

I was able to format my card eventually…

I had searched and tried many ways including formatting via command prompt, formatting through my android and formatting through windows.

When trying to format with windows it would only give me the option to format it at 27gig.

In my android device it said that it successfully formatted and appeared to 64gig. however when connecting to USB in window it was still only 27gig. 

I finally got it to format using the DJI OSMO UHD camera whilst connected to a USB port with Windows 7. upon connecting to windows through the camera, windows prompted me to format it and it allowed the full 64gig to be formatted… That’s it!

I hope it helps someone out as I was almost going to try and get sandisk to replace it.

Good luck!

I’m sadly also a victim of the formatting.

My problem is how to _un_format my SD card. Yesterday, I was messing with my camera, and one of the options was to format. I did it, but my 64gb micro-sd somehow formatted to 30gb. All of my files were wiped off or at least hidden, and I need help of how to unformat my micro-sd card.

My san disk ultra 64gb memory card also stuck as “blank or unsupported file” . Now what i do, don’t understand, plz help me

Yup. My 64gb Ultra micro SD card is dead as well. Write only. Old content can be read but deleting/formatting does nothing. Really disappointed to have 2 Sandisk products fail on me this year.

Also, trying to RMA a storage product with personal files on it is a no-go for me. Ridiculous situation that I will avoid by not purchasing a Sandisk card for a replacement.

 contact sandisk support. they have a process for returning cards with sensitive data on them. they will be happy to work it out for you. 

The article windows was unable to complete the format may help you! 

Just purchased SanDisk Ultra PLUS micro SDXC UHS-1card with adapter 200Gb up to 100MB/s for $79 from WalMart. It worked great for awhile, while trying it in several laptops in micro and with adpapter modes. Then I put it in a cheap $10 USB Made in China adabter/read/writer in both micro and Adapter mode. It worked in everything i put it in except at some point it started reading 31.8Gb instead of the 183Gb that it originally started out with. I tried formating on several machines using every format I could and even using “restore defaults” with no luck. Then I googled the problem and ended up on this thread. One of the suggestions was to download the SD formatter from the SD Card Association. I didnt even know there was an SD Association. I down loaded the free formatter, popped the card in and it immediately recognized it as a 200Gb xFAT 128Kb Byte size card. Formated just fine. Im  using a $210 HP laptop with AMD A6 9220 processor/Windows10 Home build 1709, which will apparently read and write to the card fine but comes up short if at some  point you decide to wipe it clean and reformat. Get the free format software from the SD Card Association!

I find it is now 5 years since this card type (micro sdxc 64GB) is causing problems.

I bought 3 in the last 2 years, without really informing / documenting the problems of Sandisk cards very seriously before. Two of them died. Same symptoms: it can not be written on either (neither move, nor delete, nor format, nor low-level formatting, no change to the partition type …). I’ve tried many softwares (including SD Card Formater from SD org recommended here). I even tried the diskpart command to change the card attributes … The card has exactly the same behavior in Windows, in Android phone, or in Canon camera. Any changes to the card content are blocked, but reading can be done.
Under these conditions, I can say that there is a lack of respect for customers from SANDISK. 5 years is too much. Obviously, it is a physical defect that requires redesigning this type of card and withdrawing existing ones from the market. Anyway, I will not buy Sandisk anymore.
On the card packaging it is written “not intended for sale in the U.S.” And “No warranty” for this market! So … probably Sandisk thinks it’s good for the REST of the world.

I have tried everything including the SD Card Formatter and nothing works. No matter which “solution” I try either it fails outright or in the case of copying or deleting files it appears to work but if I remove the SD and reinstert it everything is as it was before. The part that is weird is that I have two of the 64Gb SDXCs and both have exactly the same problem. I even put the thing against a super magnet I have is nothing happened. Apparently magnetism is not used for storing data anymore. It seems my soluting is to run the things through my paper shredder and buy a different brand of SD card, unless there is something I haven’t tried yet.

Ah, after all these years I find that the problem is with this actual product. Normally I recommend  Sandisk and I still do, but not the 64GB SDXC anymore. I’ve mostly used these in phones where they end up failing but I also design embedded control systems and integrate various SD and microSD cards into the product as well as write the file system software to acces them including the low-level drivers and SD commands. I was implementing format utilies to force 64GB cards to format to FAT32 but the one and only 64GB card I had that seemed to work fine in that I could read all the files off it that I had in my phone, just would not format.

Investigating this right down at the low level (in SPI vs SD mode) I see that the card responds to the write command CMD24 and follows through as if everything wrote to the 512 byte sector (SD cards are actually accessed as 512 byte “sectors” or blocks), and the response from the card says everything is fine, but a check reveals that nothing was written. Of course I also tested these with the SD Card Associations’s formatter including one from Paanasonic and other utlities as well, but no luck, either now, or with other cards in the past.

Just in case there has been a silent revision from Sandisk this is part of the internal information that I read in my system - for reference this is a SU64G revision 128 or $80 and rather an old one from 2013 it seems. My guess is that from my electronics engineering background that an internal “charge-pump” that boosts the voltage needed to erase Flash has failed and would result in these symptoms.

CARD: SANDISK   SD SU64G REV$80 #2920609953 DATE:2013/5

    VALUE… $C0FF_8000
    RANGE… 2.7V to 3.6V

    LATENCY… 1ms+1400 clocks
    SPEED… 50Mbps
    CLASSES… 010110110101
    BLKLEN… 512
    SIZE… 62,367MB

    CHS START… 2,10,9
    CHS END… 1023,254,63
    FIRST SECTOR… $0000_8000
    TOTAL SECTORS… 124,702,720 = 63,847MB

1 Like

Does anyone have the default heads & cylinders numbers from a HEALTHY Ultra 64 micro SDXC? Am getting complaints from Linux that things don’t match. Hoping this isn’t yet another such failure.