Follow this procedure when the Sansa Connect Recovery Tool won't work!

It’s still Yahoo Launchcast:

http://new.music.yahoo.com/launchcast/

PromisedPlanet wrote: 

Regarding viruses etc., they are targeted towards operating systems, like Windows.  The Connect does not run an operating system.  Also, it isn’t a general networking device, it only downloads audio streams and Flickr photos (with the necessary uploaded information only for authentication and to receive the streams/photos).

Nit pick: the Sansa Connect firmware is Linux + busybox LUA and more.  So it does run an OS.  But your point is well-taken.

(I’m here because I’m thinking about buying a Sansa Connect and I am trying to figure out the lay of the land.  Too bad that the SC won’t load firmware that isn’t cryptographically signed by Zing.  As was pointed out (by you, I think) this is a great resource for understanding the guts of the SC.)

I just registered to say Thanks PromisedPlanet for the process to get the wifi radio working on my refurbed connect!!

@coryconklin wrote:
I just registered to say Thanks PromisedPlanet for the process to get the wifi radio working on my refurbed connect!!

You may have done that work for nothing, sadly. Many users (myself included) have been unable to connect for a couple of weeks now, and it’s feared that Yahoo may have pulled the plug on Connect support.

to coryconklin - since you recently posted that you had found the process to get wifi working on your connect, I thought I’d ask if you’d gotten it to work with wifi. I’m assuming not, since most others are not. Just curious whether a “start over” from scratch of loading the older OS and re-entering Yahoo info (password) might get these things functional again. I haven’t gone that route yet and so far am experiencing the “Can’t find station…” message on my connect that I setup for wifi months ago. Maybe someone will figure out a work around. The connect is still a pretty nice player for cheap. Good luck to you.

Just curious whether a “start over” from scratch of loading the older OS and re-entering Yahoo info (password) might get these things functional again. I haven’t gone that route yet and so far am experiencing the “Can’t find station…” message on my connect that I setup for wifi months ago. Maybe someone will figure out a work around. The connect is still a pretty nice player for cheap. Good luck to you.

You could try this, but I doubt it would work.  More likely, music streaming has been cut off to the Sansa Connect.  Sandisk would have no reason to continue paying Yahoo to provide music streaming to a discontinued player.  I’m actually surprised it lasted as long as it did … probably some contract expired, or something like that.

The Flickr photo stream no longer works as well.

Darn!

CASansa wrote:

The Flickr photo stream no longer works as well.

 

Darn!

Access to Flickr “Your Photos” still works, I just tested it.

“Today’s Most Interesting” isn’t working, though I don’t know if that’s temporary.

That’s what I meant. I don’t have any personal photos on Flickr.

The daily photos are working for me.

I’ve been trying mutiple times to apply these procedures to recover my sisters sansa connect and am now quite stuck. As soon as I connect the device (showing “recovery needed”) to my laptop, the screen changes to “recovering…please wait” and never changes no matter how long I wait. The command line reports “device failed to open” and “Failed to getusbdevicefilename err - 0”.  turning the device off and redoing the 3 button device reset doesn’t help. Any suggestions would be very appreciated. Thanks.

dedward2 wrote:
I’ve been trying mutiple times to apply these procedures to recover my sisters sansa connect and am now quite stuck. As soon as I connect the device (showing “recovery needed”) to my laptop, the screen changes to “recovering…please wait” and never changes no matter how long I wait. The command line reports “device failed to open” and “Failed to getusbdevicefilename err - 0”.  turning the device off and redoing the 3 button device reset doesn’t help. Any suggestions would be very appreciated. Thanks.

It sounds like you might just be having some basic USB problems.  Have you tried different USB ports on your laptop?  I believe the Sansa Connect requires a “high power” USB port, and most computers, especially laptops, have a mix of high power and low power USB ports.  If you haven’t already, try a USB port on the back of your laptop.

Also, there is now a working version of the Recovery Tool.  It installs the no-WiFi version of the firmware.  The only WiFi feature that will now work with the Connect is Flickr photos (Launchcast audio streams no longer work), so if you don’t care about that feature, you might as well use this version of the Recovery Tool:

http://kb.sandisk.com/app/answers/detail/a_id/863

I’m getting the same error! Can anyone help?

Queen2010 wrote:
I’m getting the same error! Can anyone help?

Which error?  Are you trying to use the manual process for installing the WiFi-enabled version of the firmware?  If so, don’t bother unless you really want Flickr photo support on your Connect, that’s all it will give you.  Instead, use the “official” version of the Recovery Tool:

http://kb.sandisk.com/app/answers/detail/a_id/863

Hi PromisedPlanet

I hope you still around here.

I need the Sansa Connect Firmware pack.

Megaupload is not working. Please send me or upload Rapidshare etc.

Thanks

FARUK

@fktanik wrote:

Hi @promisedplanet

I hope you still around here.

 

I need the Sansa Connect Firmware pack.

Megaupload is not working. Please send me or upload Rapidshare etc.

Thanks

 

FARUK

Did you read, or follow the link in PromisedPlanet’s post directly above yours? :confounded:

Yes, I read it.

But I don’t download this files:

  • everest_initrd_ext_prod_1.1.1.50239.srr.e
  • everest_vmlinux_ext_prod_1.1.1.50239.srr.e
  • yeverest_zap_ota_rel_1.1.2.65799.tar.gz.e
  • yeverest_zap_ota_rel_ext_prod_1.1.2.65799.sig

I need this files.

Thanks

I’m getting the same erroR.

Can anyone help, Please?

F:\Documents and Settings\My Documents\Sansa Connect Recovery>zsi_fw.exe -w everest_vmlinux_ext_prod_1.1.1.50239.srr.e everest_initrd_ext_prod_1.1.1.50239.srr.e

ZSI FW load starting.

Found encrypted file: everest_vmlinux_ext_prod_1.1.1.50239.srr.e

Found encrypted file: everest_initrd_ext_prod_1.1.1.50239.srr.e

Open USB Device start

found a device!

Attempting to open \?\usb#vid_0781&pid_7481#5&3aeb49d2&0&5#{184954e0-9128-11db-b606-0800200c9a66}

opened device!

completeDeviceName = (\?\usb#vid_0781&pid_7481#5&3aeb49d2&0&5#{184954e0-9128-11db-b606-0800200c9a66})

Opened successfully.

data completeDeviceName = (\?\usb#vid_0781&pid_7481#5&3aeb49d2&0&5#{184954e0-9128-11db-b606-0800200c9a66}\PIPE00)

Opened successfully.

Loading: 1008000 16809984 1754944

Done!

Loading: 4400020 4294967295 1783808

Done!

 

F:\Documents and Settings\My Documents\Sansa Connect Recovery>zaprecover.exe -t 600000 -f yeverest_zap_ota_rel_1.1.2.65799.tar.gz.e yeverest_zap_ota_rel_ext_prod_1.1.2.65799.sig

ZSI FW load starting.

Found encrypted file: yeverest_zap_ota_rel_1.1.2.65799.tar.gz.e

Found unencrypted file: yeverest_zap_ota_rel_ext_prod_1.1.2.65799.sig

Timeout device not found

sd card not suport any mobile and computor

Please, the firmware’s files are not are not available on Megaupload as indicated. Users who have available can tell me where I can find them or send me the files ? thanks