Fixing an Unresponsive Clip with System Files from a Clip+...

A very strange Sansa Clip problem has prompted me to share this odd work-a-round and hopefully save others some time and trouble if they encounter similar problems.

One of our older Sansa Clip’s stopped working after it had been unused for some time. Several of the Clip’s folders including, “Podcasts”, “Audiobooks”, and “Audible” would appear on a computer display when the 'Clip" was sync’ed and the file storage opened, but the folders would not appear when using the Clip. The audio files that were loaded in those invisible folders were taking up disc space on the Clip but were also invisible. The only folder that remained visible when the Clip was turned on was the “Music” folder but opening the “Music” folder would not show the existing audio files in that folder either.

Perhaps the flash memory was failing or a disc controller had fried, but hopefully the Clip could be resuscitated and put back in some kind of working order. We erased and reformatted the Clip’s flash drive to 16 bit FAT format, and then erased and recreated the folders on the device. We also tried installing a firmware upgrade, all to no avail. We even tried to load Rockbox on the Clip to override potential software problems, but nothing worked.

Finally, as a last resort, I copied all of the folders and binary files from a Clip+ running Rockbox to a computer folder. We then connected the Clip and replaced all of the visible folders and binary files found on the Clip with the files from the Clip+. To our amazement the Clip now works fine with audio files loaded in the “Music” folder. The Clip is still short a few discrete folders for audiobooks and podcasts, but once again it plays audio files.

If nothing else revives your Sansa player try copying the folders and binaries from another Sansa device to the root drive of your player and see if that works. You can always erase and copy the files back if there’s no improvement. We copied files from a newer “Clip+” to an early “Clip” and it brought the Sansa Clip back to working operation.

This is just something else to add to your bag of troubleshooting tricks, and we hope it works for you.

1 Like

Maybe SanDisk should prepare and upload a ZIP file with the critical folders and binary files for Clip and Clip+ owners to restore their devices.

1 Like