First track in m3u playlist not shown


I have a SanDisk Clip Sport, 8 GB, with the latest firmware (1.17). I tried using MediaMonkey and/or MusicBee to put music on my device. It works but my problem is that the first track in each playlist is never shown by the music player. It is not the problem of the software I use, MM or MB, because I can open the generated m3u playlist textfiles on the device in Windows Explorer and they are complete. Also, all tracks referenced by the playlist are on the player, including the track on the first line.

It must be something very stupid I am overlooking. Can anybody explain me what is going on here and how to solve this?

Note: a playlist looks like this:

\Playlists\Lorde - Pure Heroine\001-Lorde-Tennis Court.mp3    -----> first track is not shown (in any playlist)
\Playlists\Lorde - Pure Heroine\002-Lorde-400 Lux.mp3
\Playlists\Lorde - Pure Heroine\003-Lorde-Royals.mp3
\Playlists\Lorde - Pure Heroine\004-Lorde-Ribs.mp3
\Playlists\Lorde - Pure Heroine\005-Lorde-Buzzcut Season.mp3
\Playlists\Lorde - Pure Heroine\006-Lorde-Team.mp3
\Playlists\Lorde - Pure Heroine\007-Lorde-Glory And Gore.mp3
\Playlists\Lorde - Pure Heroine\008-Lorde-Still Sane.mp3
\Playlists\Lorde - Pure Heroine\009-Lorde-White Teeth Teens.mp3
\Playlists\Lorde - Pure Heroine\010-Lorde-A World Alone.mp3

Thanks a bunch,


I found a solution for my problem: explicitely add a comment or header line, as is required by the extended M3U file formats:

Probably, my software (MediaMonkey and MusicBee) do not generate any header line (as is not required by the plain old M3U file format), but the SanDisk Clip Sport requires it for some reason. Luckily, I can configure MusicBee for instance to always generate one of the more extended M3U file formats, having the comment/header line added automatically.

If anyone has a more satisfying explanation, please share.



Great, I can have MusicBee produce the playlist format M3U(#EXT), with plenty of those comment lines (preceded by #) and they are still recognized by the SanDisk player with no omissions. With this problem solved, I now need to find a solution for the player not showing playlists with unusual characters, such as this:

#EXTINF:270,Alt-J (∆) - Fitzpleasure (The Internet of Odd Future Remix)
\Playlists\Alt-J (∆) - Summer Remix EP\001-Alt-J (∆)-Fitzpleasure (The Internet of Odd Future Remix).mp3
#EXTINF:260,Alt-J (∆) - Fitzpleasure (Jim James ‘Apple C’ Remix)
\Playlists\Alt-J (∆) - Summer Remix EP\002-Alt-J (∆)-Fitzpleasure (Jim James ‘Apple C’ Remix).mp3
#EXTINF:198,Alt-J (∆) - Fitzpleasure (Dave Sitek Remix)
\Playlists\Alt-J (∆) - Summer Remix EP\003-Alt-J (∆)-Fitzpleasure (Dave Sitek Remix).mp3
#EXTINF:217,Alt-J (∆) - Dissolve Me (Ben Lovett Remix)
\Playlists\Alt-J (∆) - Summer Remix EP\004-Alt-J (∆)-Dissolve Me (Ben Lovett Remix).mp3
#EXTINF:246,Alt-J (∆) - Tessellate (Ben De Vries Remix)
\Playlists\Alt-J (∆) - Summer Remix EP\005-Alt-J (∆)-Tessellate (Ben De Vries Remix).mp3
#EXTINF:272,Alt-J (∆) - Ms (Hanz Remix)
\Playlists\Alt-J (∆) - Summer Remix EP\006-Alt-J (∆)-Ms (Hanz Remix).mp3

This playlist is empty, probably because of the ∆ character.

It seems that the firmware on the SanDisk is not very robust.


Thanks for the information.  And your final statement is an understatement.   :wink: