Firmware Updater states that it "Failed to download the required firmware files.

I followed the video instructions on how to update the firmware on my Sansa C250 (firmware version 1.00.03). The updater installed properly, but when I tried to update the firmware i get “Failed to download the required firmware files.” for firmware version 1.01.00

I have the C250 in MSC mode, it is plugged into my USB port (I’ve tried several ports). It recognizes that I have the device attached, and even opens an explorer window as if it were a flash drive.

I have also uninstalled, rebooted, reinstalled the Sansa Updater program, in case it was a faulty download of the install file - Same errors.

I am running windows XP SP2, if that is needed for this troubleshooting.


i would contact sandisk tech support they can email the new firmware to you.

DrLucky - Thanks for the quick response. That was going to be my next move if there was no other action I could take as an end-user…

grr i have the sam problem they should just post the firmware installer on the main site >…>