Firmware update X21200RL released for SanDisk Extreme Pro SSD

Hi Dr. Lucky,

I already proceed the sanitize and the se with bootable USB drive and ISO DVD. The processes were done successfully but I still have my SSD frozen and still can’t update FW.

I contacted support and get back to the forum to tell what to do exactly.

Notice that my motherboad is an old ASUS P5N E SLI.

I’d like to provide you a screenshot but did’nt find yet how to post image in the forum, some help ?

Thanks for reply.


sanitize does not reset the security frozen state IIRC. In the FAQ i linked in my last post you will notice the secure erase tool asks for the drive to be unplugged and plugged back in to clear the security frozen state. You may want to give that a try and see if the FW can be updated after. 


even your ssd is frozen, you will still able to update the firmware.

I have been browsing this thread here many times and google everywhere to find out how to get the firmware update and unable to do so, every time reach 52%, error code 10 appear. Tried the usb drive and burn iso into cd-rom to try update firmware, also failed…

Lastly, i get to read one of the thread here that ssd has to be in ahci mode because i am connecting sata cable, so i just give a try and change my bios default ide to sata mode…then use ssd dashboard to update firmware…and voila…it just pass through smoothly…

So, do give it a try and report back…thanks.


I just downloaded the ISO firmwre update image. Is it hybrid? I tried writing it on USB on Linux (using simple dd method), but it’s not booting up. Do I need to dig up a CD for it, or it’s supposed to make a bootable USB?


OK, I ended up getting a blank CD, and writing the image on it. Then it booted (in legacy but not in UEFI mode for some reason), and I found out that SSD firmware was already up to date.

Can you please try making future images hybrid ISOs, so simply using dd would make a bootable USB from them? Using CDs is so obsolete…

I get “This operation failed with error code: 10” when I try to update.

What should I do?

1 Like

ฉันได้รับ “การดำเนินการนี้ล้มเหลวด้วยรหัสข้อผิดพลาด: 10” เมื่อฉันพยายามอัปเดต


same here.


Have you tried doing a full system shut down then turn the computer back on? could you tell me?

it’s really?

I feel there are many people interested in  Blu Ray Player and how to play Blu Ray on PC. But here is a question, they don’t how to do it. just go through the following passage, you’ll find the answer.

Hello! And what changes in X21100RL?:neutral_face:

The original firmware for SanDisk Extreme Pro SSD is x21000RL. And I want to know what has changed in the firmware x21100RL.:smileyvery-happy:

Best app to root your android phone kingoroot app

Buy SanDisk Pen Drive Online

a great website to learn and study.

X21100RL was the original shipping FW. SanDisk does not have release notes for the original shipping FW. 

source :

are you using the in windows update or are you creating a bootable USB or CD? If you are getting the error in windows update click more options below the FW update message and create a bootable USB drive and see if you can use that to update the FW



I have this drive with firmware x21000RL. The original firmware for SanDisk Extreme Pro SSD is x21000RL.

And I want to know what has changed in the firmware x21100RL.

I also encounter many problems with FW updater.

I’ve just purchased an SSD and before cloning my HDD on it I noticed a new FW available on dashboard utility. So I tried to apply it on my new SDD. 

auto clicker wordunscramble  jumblesolver

Nice attempt at spamming, but no thank you! :angry: