firmware update 293

I down loaded it several times and error message says image file corrupted .

1 Like

First of all, thanks for the “heads up” that this update is out.  According to the documentation, it fixes a very big bug for me.

But, back to your issue, are you on a Mac or a PC?  At what point are you getting the corrupt file message?  Is it on your computer, or on the Media Drive.

There was an earlier post regarding an issue which may be the same as yours.  You might want to look for it – I will too.

Here it is:

My PC is telling me this  when I drag and drop to the sandisk drive image

I’m afraid I don’t have anything more to help…maybe try downloading with a different browser?

tried chrome and IE… says corrupt

I’m still having this problem. windows 8.1. says i can’t mount image …itis corrupted

seems like you are the only one having this problem. maybe a security setting issue. It works fine for me under Win 8.1 so it is not solely related to Win 8.1. Maybe try try it from another computer and you will have better luck. 


ok I tried to get the wmd ito upgrade …it says 2.91 and says that I am running the current and theimg fil is on the drive