[Firmware] Sansa Express 01.01.12 firmware released

Hello everyone! I am a new here. I bought Sansa Express 2 Gb.

I have a problem with my player, I decided to update the firmware, but it completely went wrong.

So step-by-step…

  1. Sansa Firmware Updater did not work after few tries  (Windows XP), the installation didn’t start.

  2. I downloaded the zip file with 01.01.12 firmware for Europe, unzipped it to my Desktop, moved the mentioned file to windows 32/…, then I started the SansaExpressUpdater and after a few seconds I got the message:

    "SCSI Sense code: Device reported an undefined sense code

    0xf0, 0x0, 0x9, 0x0, 0x0, 0x0, 0x0, 0xa, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0"

Then the update quickly finished, with text “Your device is updated” but no text no name of the firmware version. Player shut off, then connected again to computer. I tried this many times, but no progress. When I disconnect the player and turn it on only San Disk logo appears and then nothing (black screen).

Please, help me to make my Sansa Express live again!!!

No solution here, but I do have the exact same problem.  Does it feel better to know you’re not alone? 

Dammit…

Anyone have any ideas?

> Anyone have any ideas?

I ordered a Coby 4G mp3 player, has not arrived yet.  It is the same “all in one” format as the Sansa.  It does not have expandable flash and takes a AAA battery, I forget if it can record.  I do not know if it is any better, it hardly seems like it could be worse.   I used to think SanDisk stuff was great, but based on my experiences with the Sansa player that is downgraded to “junk”: takes forever to turn on when loaded with 3GB of music, hard to use (poor user interface), cannot play while charging, bad random play, easy to corrupt and make unusable.  It could be a lot worse, but it could also be a lot better and my guess the competition is better.

Hi i tried to update my sansa express. connect it with the pressing - volume and everything. I didn’t back up just music, and then I formated the sansa.

does anyone can help me with a back up you can share? a copy of your files or something? I cannot update and now it does not even turn on.

I used to have version 01.01.05A, i think any version will help.

I have the same exact problem, but I have the 1GB version and I’m using Windows Vista.  Same exact error message and all.  When I try to connect to the computer it shows a graphic of the mp3 player and the computer connected by some weird blob (looks like static and it’s in the shape of a square).  When the device isn’t connected to the computer and I try to turn it on, I get the SanDisk logo and then nothing.  I hope someone can help.

Nevermind.  I just got mine fixed.  I looked at the “How I debricked my Sansa”, or whatever that forum was called, and here’s how I fixed it:  I held down the (-) key while plugging it in and kept it held down (it may take a few tries); there should be a pop-up asking to install the software, let it automatically find the correct software (should be the top option); once that’s installed, do the usual firmware install, saying yes to formating the player; this time, it works and doesn’t give that annoying error message.  I hope it works for you like it did for me.  :smiley:

See my recent reply.  I finally fixed mine.  It’s all thanks to the debricking forum that’s on Sansa Express’ main page of forums.

I have a SanDisk Express 1G, I am running MS Windows XP professional on my work computer so need a driver that it can use on this computer. Where can I get it and what is the name of it?

I managed to update firmware to 1.01.15 with the Sansa Updater. First, I plugged the device as a MTP device. After the Sansa updater recognized my Sansa Express, before downloading the firmware file, I setted up driver as USB Mass Storage Device. After this, the update went well.

For people who doesn’t know how to switch between MTP and Mass Storage(in win XP at least, I don’t use vista):

Right click My Computer->Properties->Hardware tab->Device Manager

Down you will find MTP device

Right click on it - properties-update driver-install from a speciffic location(advanced) - don’t search -

Make sure that compatible is checked and then you will have a list to choose between MTP device andUSB Mass Storage Device.

I’m not sure why, but it didn’t work on any computer. On the work I didn’t manage to find Mass storage driver

Hope this will help.:manwink:

BTW, if you make the upgrade manually, choose american version, european does not have FM radio menu

got a serious problem.followed all update intructions but when it comes to pressing of the volume button nothing happens.well it did ask if i wanted to format,which i did.but the update process is stagnant,plus my player is blank and is only read as a usb disc.

plz help

Wich method have you tried? The sansa update application or the one with the .sys file? I recommend the software. It works for me.

I moved the file StMp3Rec.sys o “C:\windows\system32\drivers” then I connected the device holding the (-) button and the installation window appeared but it failed to install the device, it says something like (i’m translating from spanish) “the device couldn’t be installed because it couldn’t find the appropriate software”, I also tried to install it from a specific location but didn’t work, please help me, what can I do?

Hello, I just want to know,how long does the Sansa Updater take to upgrade the firmware to 01.01.12…I hard time about this right now. Thanks a lot.

estoy desesesperado necesito Sansa Express Update.exe version 1.01.12A y los enlaces que dan el sitio no funcionan y tengo un problema con mi mp3 express sansa, y sin esto no le puedo hacer nada necesito su ayuda por favor. 

saludos cristobal  

i am attempting to update the firmware of  a sansa express

i was unable to use the regular updater because of the windows x64 limitation.  so i tried the zip file method.  i was able to put the unit into sansa recovery mode and the updater ran through the format portion and sat there.  now, nothing can be done with the unit at all.  it is registering as a 1GB storage device and nothing more.  I subsequently found a “new” updater, not mentioned here, but it won’t recognize the unit, since it has been wiped clean.  What can i do now? Isn’t there a file I can load onto the unit manually? any help you could provide would be appreciated, since the only method everyone seems to be referencing depends on this zipfile’s updater which does nothing on my machine.

win7

asusK50

2.2 GHz 3GB

sansa express 1gb with no expansion card

I have the same problem, I don’t know what to do… nothing happens…

Hello…Am new here…i just wanna ask coz my Sandisk Sansa Express is not working properly. My computer don’t even read it…but when am checking it on the device manager i can see my Sansa Express…but its not in my computer. Hope you can help me fix it…thanx a lot…

Reconnecting with others is definitely a favourite overdue of people who use theURL=[http://www.phoenixescortasian.com/]Phoenix Escort[/URL]  internet here. Might choose to see a classicbuddy or perhaps a colliege URL=[http://www.phoenixescortasian.com/]Phoenix Escorts[/URL] with a previous employment. Certainly relatives went out and aboutand youare clearly looking to find these products. Doing search email can assist you uncoverfamiliesyoumight have damaged or lost feel utilizing.  URL=[http://www.phoenixescortasian.com/]Phoenix Asian Escort [/URL]  This is the identical principle simply because researchingindividuals"up"inyouronlinedirectories URL=[http://www.phoenixescortasian.com/]Phoenix Asian Escorts[/URL] from a telephone directory, nevertheless it really kjoji ontheinternepreferablyinstead

Hello, 

I recently find this update, This new version of the Sansa Updater has several new enhancements, including an improved look and feel and user experience. The original Sansa Updater will inform the user that the new version of the Sansa Updater is available and it will install the new version if selected.

Tissot Sea Touch Watch

Trying to update firmware on my Express 2Gb, but the Firmware Updater won’t find any updates available (even though I have 01.01.05A onboard) and if I try the other method, Windows won’t find the driver and therefore won’t recognize the Express (it will show a STMP3600 device, but will not load any drivers for it).

I’m running Windows 7 64 bit, but tried on a 32 bit version too without success.

Anyone knows where to find the correct driver? Pointing to the StMp3Rec.sys file won’t work.

Thanks.