Finalizing update m260

I have a system that seems to be hung up.  I turn the system on normally and after the sansa screen comes up I get a screen that show Finalizing update.  The system then just hangs there.  It either shuts down at this point or the screen goes black and then it shuts down.  This all occurs over a period of about 5 minutes.  I connect it to my PC and it just hangs at the beginning initializating screen and my PC does not recognize it as a device.  I have removed the battery and get the same issues.   I hope that someone can give me a fix as I REALLY love this product as I have had it for a couple of years and would like to have it for a lot longer. Thanks in advance.

Lathien@bigfoot.com 

That’s exactly the same problem I’m having with my m260! Any word yet on what might be the problem? Or how to fix it?

i had a similar issue, i found that putting the hold switch on, and connecting to PC, it was showing in MSC mode… i reformatted the flashdrive, and then disconnected it and it.


mreps1 wrote:

My m260 stopped playing. Replacing the battery restored power, but the display reads “Finalizing Update” and nothing else happens…ever!  The computer won’t synchronize (or even recognize) the device at all.  Circuit City customer service was useless.  Any idea what’s wrong? Or how I might reset the device?

I ran into the same issue, like Bleach_fan said, the only way I was able to get any response was by turning on the hold switch.  With the hold switch on it got detected in my computer as a removable disk I was able to format my player reload my music and all was OK.  I think what’s happening is corrupted data cause the player not to be able to finalized updating it’s library and the only thing to do is to format player to remove the files  Good luck.

So far I have tried that without any success.  Thanks for the info though and any help is appreciated.

BiggT said:

> With the hold switch on it got detected in my computer as a removable disk I was able to format my player reload my music and

> all was OK.

When you reformatted, did you select FAT or FAT32?

Lord Derigan

i have also the same problem with my sansa m250. by on the hold switch can i detect it to the computer as a removable disk. i try my level best

I ran into the same issue also. What I found is one of the music folders apparently was corrupted. I tried to delete all my music, but it wouldn’t allow me to delete one folder saying the folder was not empty. However, there was nothing in the folder. My PC was able to recognize the SanDisk player, so I formatted the player, updated the firmware, reloaded my music, and that seemed to resolve the problem.

I have the same problem with a twist, mine was working perfectly until I updated to the latest firmware, it only displays “finalizing update” then the display goes “black”, I tried every possible solution described in this and other forums to no avail, including the taking the unit apart and remove-reinstall memory card in a particular sequence.

To add insult to injury Sandisk basically told me “too bad, your player is out of warranty and up yours”…well people in Sandisk: THIS IS THE LAST PRODUCT I OR ANY OF MY FAMILY AND FRIENDS WILL EVER BUY FROM YOUR DISGRACEFUL  COMPANY (FOR NOT SAYING THIEFS), QODPEC Hs de P !!!:angry: