Files not recognised

I have a Clip Zip with USB mode set to MSC. I (mostly!) have no problem at all dragging files across and listening to them.

But some mp3 files are not recognised by the player. I don’t think this is a DRM problem, as the problem occurs on free content.

Once (just once) the problem was solved by dumping the file into Audacity and then exporting it again. But every other time I’ve tried this trick it hasn’t worked.

I once found that a voice memo I’d recorded on the Zip, when converted in Audacity from WAV to MP3, then failed to be recognised.

Here are two examples of files that aren’t recognised by my Clip Zip. Podcasts, the most recent as I type this is #44, of Empire (the movie magazine)

also this free Big Finish drama called “The Coup”

It’s as it they aren’t on the player at all. But, when USB connected, the files are clearly listed and can be played through the computer’s speakers.

Am I missing something obvious?!

all best regards


Most likely an ID3 tag issue. Podcasts aren’t necessarily known for consistent and accurate tags.

Same issue with your Audacity-exported .mp3 file. No tag. You have to manually fill it in with a program like MP3Tag and make sure it is in ID3v2.3 ISO-8859-1 format.

Thanks for the reply. It’s not tags - files that are recognised and those that are not have the same tag (according to the mp3tag software, thanks for that recommendation!).

Looking across all the columns in the mp3tag display, there is no “common denominator” that distinguishes the files that are ignored by the clip zip.

all best regards, Peter

Do any of them (particularly the ones with problems) have embedded album art over 500 x 500 or 100kb in size? This is a known issue; click on extended tags in MP3Tag to check. Or anything in the Comments field of the tags?

It could also be the ripping program the source used to make the .mp3 files in the 1st place.

Thanks for all that.

Changing the Genre field to “podcast” fixed everything on the two problem files I’ve been looking at. I still don’t really understand as other files with an empty genre field or with other genres still appear ok as podcasts on the clip zip.

But the two examples I mentioned above are now sorted!