Files can’t be viewed

Hi. I have saved files in my sandisk ixpand using my iphone6 plus. I didn’t have a problem viewing my files when my otg is attached to my phone. However, after i used the same usb to view files in my personal computer, when i attached it again to my phone, i couldn’t view my saved files anymore. It‘S like it’s hidden in a separate folder that i can’t open when using my phone. How can i few my saved files again using my phone?

Holy crap, this actually worked! One segmented file on a DVD wouldn’t copy past 40% no matter what I tried. As a last resort I tried youtube in case someone had some special gel or some silly way to get a DVD disc to work again. Came across this vid and sure enough the free app worked (file was 650mb in size, so the free version was enough). I had no idea an app could retrieve files from a damaged DVD but this did it. Thanks for posting this, you saved me a great deal of headache. Now that I have all 10 segments, file is expanding as I type this. Cheers. telegram vidmate