Files appearing out of order

I pasted MP3 files into my new SanDisk external card, but when I play them on the Fuze, lots of them are out of order.  The MP3 tags for the track numbers are correct, but the Fuze has them in the wrong order anyway.  For instance, the third movement of a symphony appears and plays first.

This never happened when I pasted the files into the internal memory.  Is there something special I need to know about the external memory?  If not, does anyone have any idea why it’s doing this?  It only does it for some files, not all of them.


How are you sending the files over? MSC mode? MTP mode? I never trust MTP. 

But check the track numbers again. The internal and external should work the same.

If you have 1, 2, 03, it will play 03 first because it reads the first digit.

Install  mp3tag and have it add itself to context menus. (checkbox during install)

Change the  default under Tools/Options/Tags/Mpeg to  Write ID2v2.3 ISO-8859-1 .

Highlight them all  (in correct order, top to bottom) and under Tools, use the Auto-Numbering Wizard to Add leading zeros.  Leading zeros will give you 01, 02, 03. 

Then see if they play in order. Make sure you are changing the tags on the Fuze, not the copy on your computer.

Message Edited by Black-Rectangle on 02-02-2010 12:38 AM

Maybe the (lack of) leading zeros was the problem.  Thanks.