file name corrupt since 1.02.26F

Hi,

Actually I have a 8GO fuze in which I plug a sandisk mSD card of 8 GO. Most of my music (about 6GO for 1000 singles) is on the SD card. For information, my system is XP.

Since I uprade my sansa with the last firmware version, when I chosse music by the album tag, the name of some files appeared as a unique symbol like a greek one and they were gathered in an album with the same symbol. 

These are the tests and results I made  about this trouble :

  • reinstal the firmware, format, re-insert the SD card => no change

  • delete the music and copy it again from the PC => no change

  • delete all the music and add a few music (2 albums) => NO TROUBLE

  • add again  lot of songs (800) => TROUBLE again with different songs and album (nb : I could have more than one album under the same “false” album with the greek symbol)

  • when I look for music with the folder way : the names are OK

  • when I listen to the corrupt music : the title, album … are OK

It seems to occured when I cap a certain amount and I think (for I all know) that the program which create the index is bugged since the new upgrade firmware.

Could someone give me the way to get back the sources of to the precedent version of firmware until they fix that please ? (can’t find on the forum old version neither on the official website)

Thanks for your help 

Message Edited by schaffha on 06-07-2009 02:50 AM

Message Edited by schaffha on 06-07-2009 02:52 AM

It could be a bug. But it could also be fixable with different tags. 

Try retagging one of your trouble albums with mp3tag.

When you start mp3tag, go to Tools/Options/Tags/Mpegs and set Write to ID3v2.3 ISO-8859-1.  Then open the folder full of tracks, highlight them and Save–it will re-encode them in that version.

It’s possible that the tags that are giving you trouble were encoded in Unicode, which could make it display wrong.

And then again…it could be a bug.  

Hi

thanks for the reply

It was my first idea too but the thing is the same album had seen is name and songs corrupt and alright depending on the global music copied on the player.

And for the idea of corrupt memory card, the same album had been corrupt whether it was on the data of the player or the mSD card.

I use Tag&rename and I made some tests - I still will try with mp3tag with the recommended settings.

still strange it occured only after the 1.02.26 patch …

so else to help me ? :slight_smile:

do I need to contact sansa support ?

thks

Message Edited by schaffha on 06-13-2009 07:54 AM

Try support. The new firmware attempts to work with ID3v2.4 tags, and there seem to be bugs introduced. Or go back to the previous firmware.