File / Folder Browsing Problem?

I just looked through the music folder menu. The problem is actually worse the second time!

I have 22 folders under music and 18 of them have those annoying numbers in front of them when viewed using the player’s folder browsing menu.  When I plug in the player and look at them using Windows Explorer, the folder names all read fine.

Could you guys talk to to you software engineers and see if they can get to the bottom of this?  I’d expect that if it happening to me, it is happening to others and it negates much of the benefit of having the file/folder mode, which is why I bought the unit to begin with.

The affected folders have varying different content (some mp3, some FLAC) from differing sources. Also, I pruned out all non-music files this time first. So I’m pretty confident that this is a problem with the Clip+ hardware and software and not due to any issues with the data that might make it unique.

I will try adding different folders from a different computer tomorrow, to confirm if this is correct.

To provide more detail, the problem affects folder names in both the folder view of music and audio books. It impacts folder names in the root directory as well as subdirectories. Only folder names are affected;  all song names appear correctly. Also, all folders and songs that were loaded appear in the player, and the songs play properly. It’s just that with the long number strings apparently added by the Clip+ user interface, the folders appear out of order and it is very difficult and tedious to read them. 

Did you telephone SanDisk Customer Service about this to alert them to the issue, and to see if they had a fix?

@miikerman wrote:
Did you telephone SanDisk Customer Service about this to alert them to the issue, and to see if they had a fix?

Not yet. I guess I was hoping that I could accomplish that through this forum. But I’ll see what they have to offer.

>So for example, a folder that is named “Beatles” will show up as “14030000_Beatles.” (This does not happen to all the folders, but is an issue with most of them.)

I have the same problem, but there is more. Some of the folder names are prefixed with a leading string of digits (as described by stridr in his post), and some folder names are “New Folder”. When the Clip+ is connected to a PC (WinXP), the folder names displayed by Windows Explorer are just fine. The leading digits are missing, and the “New Folder” folders have their proper names. But when I disconnect the Clip+ and view the folder names on the tiny built-in screen, they are back to “14030000_Beatles” or “New Folder”. Most of my music folders, in fact, display the name “New Folder”, while most of my podcast folders are prefixed with that long number.

As a programmer, I recognize what I believe is the “name mangling” technique, which is often used to internally distinguish folders that might display the same names externally but need to be kept separately identifiable internally. If you have two folders named “Beatles”, the OS will use different names for them, such as “123_Beatles” and “456_Beatles”. I’m guessing that’s what these digits are (but I can’t know for sure, of course.)

And since I can repeatably plug into the PC and see the proper names of all these folders, then unplug and they display as “New Folder” or with the leading digits, we clearly have two folder names maintained: one that displays in Windows Explorer when the Clip+ is plugged in to the PC, and one that displays in the device display when unplugged from the PC. Somehow the device is displaying the wrong one (I believe.)

I’m going to try various approaches to try to find a workaround, such as creating a new folder on my hard drive & dragging it over vs. creating a new folder on the device and dragging the contents into it, experimenting with different names (maybe some characters such as underscores or kanji freak it out) and so on, but I’m not even sure they’ll work, and I shouldn’t have to do this.

I hope I’ll see a firmware upgrade that fixes this. I’d rather use this than an iPod, but as long as 2/3rds of my folders display the name “New Folder” or “13400344_…”, I can’t very well recommend buying this instead of an iPod.

@stridr wrote:
I just spent about an hour reloading the player. I didn’t want to just copy the folders back to my hard drive and then copy them back to eliminate any chance that any data that had gotten corrupted would be transferred back on.

Here’s what I did:

  1. Reformat the player using the command in the player’s settings.
  2. Reset to default factory settings.
  3. Reformat again, just for good measure :slight_smile:
  4. Reload everything from scratch.

_ Sadly, it did NOT work _. Almost every folder has that annoying number in front of it.

I am beginning to think that either there is something wrong with my hardware, or there is a serious bug in the software.

I am open to all suggestions as to how to proceed, but I’m reluctantly reaching the conclusion that I will likely need to RMA it…

You didn’t mention if you set the USB mode to MSC after step 2 above.  Going back to factory defaults will set the USB mode to Auto, which will try to use MTP if your OS supports it.

This issue almost has to be some quirk of MTP.  Either that or some kind of serious defect in your unit (seems unlikely, but I guess it’s possible).  If you didn’t switch to MSC mode, you might want to give your process above one more shot, but make sure to switch to MSC after step 2 and before you reload your content.

I tried reloading everything last night and the problem is fixed. It sounds like Tuanglen is having the exact same problem I had, and so he should try this also (details below). Basically, Skinjob hit the nail no the head… In resetting to factory default settings, I’d reset the player to “autodetect mode.”

Here is what worked for me:

  1. Reformat the player using the command in the player’s settings.

  2. Reset to default factory settings.

  3. Turn player off and on again. (I don’t know if this is necessary, but that’s what I did.)

  4. Switch player to MSC mode. -< IMPORTANT

  5. Plug player into computer with USB cable.

  6. Copy and paste the folders containing music on my hard frive into “Music” folder using Windows Explorerer.

It now works perfectly, with no numbers in front of the file names.

Thanks to you, stridr (and Skinjob), my problem is now solved, too. What a relief! I think the key really was to start from scratch with a hard-selected (not autodetected but fixed-setting) MSC mode. I think having used the factory-default settings (autoselect) initially was what messed up my device in a way that could not be repaired without a full reformat. (You think there might be a design lesson in that?) 

For others who may have the same problem in the future, but aren’t quite sure how to follow stridr’s instructions because of unfamiliarity with some of these menus or terms, all of these settings are done under the “System Settings” menu. To get there, you press the Home button, then press the Up (or Down) button until it says “Settings”, then press the right button, then Up (or Down) again until you see “System Settings”, then right again.

In System Settings, you find the options to reformat the player (Step 1), reset to default factory settings (Step 2), and change “USB Mode” to MSC (Step 4).

It seems to work now that it is a pure MSC system, which turns it into a USB drive that isn’t too smart for its own good.

BTW, DOES ANYONE KNOW: Since MSC mode is for non-DRM’ed content, will this now pure MSC device support Audible’s DRM’ed audio books?

For DRM content, the license data needs to be transferred.  The DRM system can only access the device properly for this in MTP mode for secure content.

µsansa

@tuanglen wrote:

Thanks to you, stridr (and Skinjob), my problem is now solved, too. What a relief! I think the key really was to start from scratch with a hard-selected (not autodetected but fixed-setting) MSC mode. I think having used the factory-default settings (autoselect) initially was what messed up my device in a way that could not be repaired without a full reformat. (You think there might be a design lesson in that?) 

For others who may have the same problem in the future, but aren’t quite sure how to follow stridr’s instructions because of unfamiliarity with some of these menus or terms, all of these settings are done under the “System Settings” menu. To get there, you press the Home button, then press the Up (or Down) button until it says “Settings”, then press the right button, then Up (or Down) again until you see “System Settings”, then right again.

 

In System Settings, you find the options to reformat the player (Step 1), reset to default factory settings (Step 2), and change “USB Mode” to MSC (Step 4).

 

It seems to work now that it is a pure MSC system, which turns it into a USB drive that isn’t too smart for its own good.

 

BTW, DOES ANYONE KNOW: Since MSC mode is for non-DRM’ed content, will this now pure MSC device support Audible’s DRM’ed audio books?

Just to make it easy on yourself:  simply set the USB mode to MSC as soon as you get your Clip+.

>For DRM content, the license data needs to be transferred.  The DRM system can only access the device properly for this in MTP mode for secure content.

>µsansa

So, since the Clip+ doesn’t work properly in autodetect mode, and the approved solution is to reformat and start from scratch with a pure MSC device, and you say that DRM content requires MTP mode:

Are you saying that we have to choose between proper folder names and Audible support, or that the solution is to make it a pure MSC device for loading everything else, then to temporarily switch to MTP mode just long enough to load Audible content (will that mess it up again?), then to switch it back to MSC mode and Audible (and everything else) will play, or what?

The Clip+ is working fine, now, after unloading everything, reformatting, switching to MSC, then reloading. I’d rather not go through that again if I don’t have to, so I don’t want to mess it up (I like it a lot now), but I have some Audible content. As moderator, what do you suggest?

fwiw, I’m reluctant to force MSC because I don’t want to interfere with the option to also upload DRM’d files.

I did notice that one of my re-named folders contained a semicolon – and when I deleted the mis-named folder, and changed the original folder name to not have a semicolon, and re uploaded that – then it had the correct name.

So perhaps some of the trouble in MSC mode might have to do with certain characters in the folder (and/or perhaps contained file) names? 

Switching to MTP for the Audible .aa format, transferring the files, then using MSC mode for all else will work just fine.  The Sansa will navigate to all files regardless of USB transfer mode.

The only quirk is that the PC cannot see the Sansa’s files that were transferred in the alternate mode.  (While in MSC you will not see the MTP transfers, and vice versa.)

Auto Detect has a peek at the host computer upon connect, then will use MTP if available; if not, the device will connect in MSC.

If MTP mode is not working properly, manually select MTP Mode via Settings > USB Mode > MTP.  Connect, then have a look at the Sansa using the Device Manager.  Uninstall the Sansa, then unplug.  After a brief wait, or preferably a reboot of the PC, plug the Sansa in again.  The device drivers will be reinstalled.

MTP mode is an integral part of Windows Media Player 10 and above.  Note that you do not need to use Windows Media Player specifically to manage the Sansa, you only need the drivers.

µsansa

I was having the same problems as other people on the forum, i.e., munged folder names. I followed the instructions above. After switching over to MSC mode, I notice that the folders listed (as browsed from my PC) are different in each mode.

In MTP mode I see:

  • Audiobooks

  • Music

  • Playlists

  • Podcasts

  • Record

  • Sevice

DecIcon.fil

In MSC mode I see:

  • AUDIBLE

  • AUDIOBOOKS

  • MUSIC

  • PODCASTS

  • RECORD

RES_INFO.SYS

SYS_CONF.SYS

MTABLE.SYS

version.sdk

The main thing missing from the MSC view is a playlists folder. What would happen if I add this manually? The reason I ask is that I have a collection of books with pre-built .m3u playlists. Under the MTP mode, I just copied these over into the Playlists folder, but I’m wondering what I can do with these files without swtiching back and forth between the two modes.  Any suggestions?

Media Monkey does playlists in MSC mode, and supports .m3u. 

If you plan to use it as a ripper, get lame_enc.dll from LAME and substitute it for the one in C:\Program Files\Media Monkey. The original MM version times out. 

Message Edited by Crescendo on 12-28-2009 06:17 AM

This workaround solution is really quite ridiculous.  Do you know how many hours I have put in now trying to set this Clip+ 8Gb up so that it would display the music folders correctly on the external card, run playlists, AND run Audible content on the internal memory?  I’ve tried about a hundred things and every time I disconnect the player it refreshes the media for 10 minutes.  It takes 3 hours to transfer my music to the 16 Gb external card. 

I miss my iPod, sorry.  I didn’t have to do any of this stuff to make my iPod work.  I’m still trying to get this Clip+ to work 3 days after I got it for Christmas.  I haven’t succeeded yet…

SanDisk Customer Service:

In the U.S.:  1-866-SANDISK (726-3475).  Other SanDisk contact information:  http://www.sandisk.com/sandisk-support/contact-us.

Catfish_man wrote:

It takes 3 hours to transfer my music to the 16 Gb external card. 

 

It shouldn’t take near that long unless you’ve got a really slow computer. I just loaded up a 16GB card and it took exactly 36 minutes.

Tapeworm wrote:


Catfish_man wrote:

It takes 3 hours to transfer my music to the 16 Gb external card. 

 


It shouldn’t take near that long unless you’ve got a really slow computer. I just loaded up a 16GB card and it took exactly 36 minutes.

I wonder how many songs Catfish_man transferred compared to you…we know it makes a difference with refresh time, maybe load time too?

I had this same problem on whatever the factory setting is. I formatted, and switched it to the one you all recommended, and I’ll post back with how it works.