Faulty 16GB Micro SD Card

Same exact problem here with my 16gb MicroSD HC card. Called : 866-726-3475 and 45 minutes later they are replacing my card. There is a lifetime warranty on the card. The call center is in India so be prepared to be very frustrated and repeat yourself numours times! The technician I spoke to treated me like I was quite computer illiterate. I had to use the phonetic alphabet (alpha, bravo, charlie…) so he could understand me… Overall this will be my last Sandisk purchase for lack of customer service!

edit : looks like I am going to have to call them back as the guy setting up my RMA hung up on me. JOY…JOy…joy! 

I have also the same issue I can’t format , delete files.I’ve tried everything.I need help.

SanDisk Tech Support

@doughlas789 wrote:

I have also the same issue I can’t format , delete files.I’ve tried everything.I need help.

SanDisk Tech Support

 My 16GB Sandisk SDHC has been replaced 3 times over the past 1 1/2 years. Every time the sector fails, Sandisk only offers a replacement.  But by then the damage is done and who wants to use an unreliable card for your priceless photos or important document?

My trust in this product/brand has deterioated enough so say that I’d NEVER buy another SANDISK product. Their support is unhelpful and provide no suggestions on how to remedy the problem or give alternatives what so ever.

@ejepsen wrote:


<not worth repeating again> 

3 separate posts saying exactly the same thing?

Your contractor called. He said your bridge is almost done and you can move back in under it tommorrow.

Hei everybody!
My problem was that I bought sandisk 16 gb micro sdhc class4 memory card and from the first day I couldn’t format it on my computer. Windows cmd didn’t help and format through my computer said that windows was unable to format.
When I connected my sdhc card with my galaxy ace what’s running on android 2.3.6 it offered me to format it straight away and nothing happend. On the notification bar it said that sdhc card is blank or in different file system.
So the situation was same like with everybody else in here…
I MANAGED TO FIX IT!!! / at least so far its still working!

  1. I put the micro sdhc card into my phone and connected my phone to my windows 7 pc.
  2. in my phone I went to settings - sd card and storage - mount (in some point it didn’t mount but after trying few times it did)
  3. then I took down my notification bar and clicked “use sd card as storage” / “use sd card in storage mode” or something like that.
  4. then took my pc by using that https://www.sdcard.org/consumers/formatter/
    it found my sd card. Only setting what I changed was… Full overwrite erase format( NOT QUICK FORMAT )
    Format took about 30-45 min.
    After that I took my phone and safely removed from computer, took the sd card out put it back in and the phone said it is damaged sd card. I went back to settings - sd card and storage and mounted again and it started working… Phone said that I have 14.8gb or something like that free space and I was able to store stuff through usb to phones sd and everything seems to be working so far!
    I hope that will help everybody!!!
1 Like

Don’t know as it will help everybody, but it should at least help somebody. :stuck_out_tongue:

Thanks for posting!

1 Like

Hi there , I bought a microSDHC Card  32gb to use with the car camera , it worked fine for 3 days then it started to have problems . ( I bought the card from an online retailer in Australia)

I can access the card with the camera connected to the pc (Windows 7) , I can open the folders and see the files but can’t open anyone of them , the pc just hang.

I have tried to format it with the camera and pc in every possible way available , nothing work , messages I get are : media is write protected , volume could be corrupted,can’t be formatted etc…

Program use : SD Formatter, HP Storage formatter , disk management , etc…

Hp Formatter doesn’t even work if the card (in the adapter, unlocked) is insert in the pc. Some of them just hang until I remove the card.

I wanted to check if the card is original but nothing work.

I’ll send it back to the sender and see what he has to say . Communication was very poor , he just told me to send it back . (Maybe this is not the first time). Bought it from ‘crazyshopping.com.au’  (That was cleaver of me :flushed:

hi just bought 16gb class 4 micro sd sandisk  card from amazon.


put into a cheap card reader  from amazon (which supposed to read up to 32gb) http://www.amazon.co.uk/MICRO-SD-MICRO-SDHC-MEMORY-READER/dp/B002WKD0CQ/ref=sr_1_7?s=computers&ie=UTF8&qid=1344328099&sr=1-7 

and connected to my usb2 port on my pc tower with xp sp3

some files copy, others crash/close the window with error/fail message  .   i re-open the  window and try again and sometimes it works , sometimes i repeat this process a few times until file copies over completely (and window does not crash or close).   but usually crashes again when trying to copy another file.  completely random. crashes on files as small as 10mb.

never crashes when reading the files.    have almost filled the card with fully working files trying to understand it and see if the capacity was there.  is is.    so i’m assuming it’s not a fake card as it is 15/16gb tested.

was 7 uk pounds so not overly bothered about returning unless fully sure card is faulty.    at themoment not sure if it is reader or card.

It would be inexpensive enough to try another card reader.

Edit: I see 4 others have complained (in reviews) that they too had problems with this reader. 3 didn’t work off the bat and 1 failed after a couple of weeks.

This describes my scenario exactly - right down to not wanting to do the exchange.  I have tried the SD formatter listed in the replies and I chose the options full erase and full overwrite.  This is when the micro SD is in a USB stick with no write protect switch.  I also put it in the SanDisk full SD sized adapter and made sure the switch was set to write.  I tried the switch in the other direction - multiple times and nothing works.  The SD formatter says it is write protected and Windows simply tries formatting for a while and eventually fails.  I tried a low-level formatting program and it just gave error after error.  Any ideas?

My suggestion if you want to protect the data but take advantage of the 1 time exchange option. Copy the data from the disk, to 2 different sources (so you are sure to have it) then get a big magnet and rub it all over the disk, on both sides. The data will be gone and you can send the disk in. Of course I do not know what anyone else woulod saay about that. When I used to have 3.5" disks, before I tossed them in the trash I used to mag wipe them, same for video tapes, etc.

I have a micro SD Sandisk 16GB and why does it show on windows MY Computer 14.8GB instead of16GB?

@gram20122022 wrote:

I have a micro SD Sandisk 16GB and why does it show on windows MY Computer 14.8GB instead of16GB?

Because that’s the actual usuable space on a 16GB card.

1% failure rate may not sound like much but it sure leaves a lot of people extremely dissapointed

when you are a part of that 1% it is a 100% failure for you!

I have a 16GB Micro SD card for my phone and i had the similar problem. My phone randomly decided not to read the card… i tried to format it and it was write-protected, so i got a Micro SD Adapter and Unlocked it then put it in my pc and formated it like that,  works fine now :slight_smile:

I purchased my SanDisk 16GB microSDHC from Amazon nearly a year ago and exactly the same reader as frag-frog and everything worked fine. I could see it in Windows, Linux, and on my Rikomagic MK802 II but today I tried to use it to load up a new image for my MK802 and it won’t read. It’s not recognised in Linux or the MK802 at all and Windows 7 seeems to see it and then doesn’t and then it does so on and so on but never long enough to be able to do anything with it.

I also have the SD Adapter for the MicroSD card and this doesn’t help anything on the Windows 7 PC

It does seem to make the card recognisable on my Linux Laptop with builtin SD reader but cannot read any files, delete or create pratitions and cannot format the card.

P.S. With regards the RMA I am expected to pay the postage to  Czech Republic

Postage = £3.00

Cost of new SD card = £8.54

No brainer!

After 2 or 3 years (I’m not sure which one is exactly because I’ve purchased two identical cards from amazon.fr, one in 2011 and one in 2012) and the card failed on me with the exact same symptomps as the ones described in the original post. So you people say that SanDisk replaces such faulty cards? How should I proceed? Thanks!

Well, thanks to the astounding Amazon Customer Service representative, I’ve got my money back and I can purchase a new card. Thank you SanDisk, I really though your products would last, it’s the first time one of my SanDisk cards fails on me.