FAQ: Using Your Sansa Clip with Your Mac, Including a Script for Exporting iTunes Playlists

Stahlin -

Sorry you are having problems with my script.

I have not tested it on iTunes 9.0.2, but it has been tested on 9.0.1. I have not tested it under Snow Leopard.

Also, I am running the clip firmware v10.10.20, not “v2” as you are.

However, with all those differences, I still wonder about the format of the files in your playlist. Currently the firmware v2 supports MP3, WAV, OGG-Vorbis, FLAC, and possibly others of which I’m not aware; I have not exhaustively researched what formats the latest firmware supports. 

To cause my script to prompt you with the 'format not supported" message, it should be detecting a format not supported by the Clip.

So, two things:

  1. I recently (dec 16) uploaded a new version of my script. If you don’t have that version, you should probably start there.
  2. How are you determining the format of the files in your playlist? Just by the extension you see in the actual folders of song files? If so, double-check the format by using iTunes Get Info on the songs. Under the Summary tab, look at Kind. Are they a “Kind” the Clip supports?

It’s unlikely my new version will make a difference, because I have changed the format detection code minimally since the previous versions.

So, I apologize for questioning what exactly is going on with your case, but we need to start with my suggestions 1 and 2 above. I recently emailed previous users (donaters whose email I know) about the latest version, and no complaints.

If I do have a problem, I want to know about it so that I can correct it, so hopefully you will get back to me. It’s best at this point to move off the forum and email me directly at the email I provide in my download Readme file.

I’ll wait to hear from you. 

knownothing -

Kind of a tough one given the device is refurbished.

First, are you definitely dragging your music files into the MUSIC folder on the Clip drive? They must be in the MUSIC folder.

If so, I would definitely do two things (in this order) and resign yourself to likely losing all music currently loaded.

Update/reload the firmware, and be certain you have the firmware for the 4GB version (might be the same as for the 2GB version; that’s something I don’t know, but you should be certain). Try the drag and drop again with just a few songs. After you Eject the Clip, and remove from the USB port the screen should indicate, “refreshing database”. If so, likely all is good, and you’re done.

If the first idea does not fix your problem, Go to the Clip Settings menu, then to Format, and choose, Yes. Repeat the simple test from idea one.

Now, important qualifiers here. I am not using a 4GB Clip. I am not running firmware version 2. I have personally used the Format idea to fix a memory available error with my Clip, so I know it can be useful, with no unwanted consequences. However, that was on a 2GB Clip, with v1 firmware.

Finally, if your results are unsuccessful, and you want to keep trying, you can find the variety of firmware versions here.

Let us know how it goes. Good luck.

Hello, I havent had a chance to go through all the replies on the post so maybe this has been covered already, but i just got a sansa clip and am trying to use it with my iBook G4 thats running 10.3.9. when i connect the clip to my computer it says connected on the clip ( can’t do anything on it while its connected it just keeps going between saying its connected and then showing the sandisk logo) but it never shows up on my computer so i cant do anything with it. is my OS too old for this or should this not be happening. thanks for any information

thedreamscene -

I cannot say for certain that your 10.3.9 OSX version is an issue, but it seems unlikely.

As a start, read carefully post number 1 in this thread. You will find complete how-to instructions there (a full page).

Report back if you are still having trouble, but I think you are simply not doing some basic things discussed in those instructions.

Hope it goes well.

For those using my iTunes Playlist to Clip script (the main post is here), I’ve made a single but important (and overdue) change, and uploaded the new version to my download site.

I have not kept my script current with the updates to the Clip firmware regarding supported digital audio formats. The previous version would prompt you that certain formats that are now supported, would not be processed by my script if they were in your playlist. This has been fixed.

Because the Clip now supports most commonly available digital audio formats, I am now only prompting the user of an unsupported format if the format is one of Apple’s propriety formats. This new format checking also allows me to eliminate the need for an “international version”.

This new version has been tested on iTunes version 9.0.3.

Thanks for the great program.  But, is there ANYTHING out there that will allow me to convert my iTunes MP4 files to the Clip MP3 format, or am I dreaming?  It totally sucks that I can’t put my iTunes purchases on my Clip.

Gorynel wrote:
Thanks for the great program.  But, is there ANYTHING out there that will allow me to convert my iTunes MP4 files to the Clip MP3 format, or am I dreaming?  It totally sucks that I can’t put my iTunes purchases on my Clip.

Dont use it myself, but from what I’ve read here, there’s a setting within iTunes itself that may do that. Otherwise, other programs like Media Monkey, Winamp, dbPoweramp, etc. may be able to.

Gorynel -

This is a touchy subject for any public forum. Here is what I can suggest, where you might find something useful. 

In your favorite search engine, use these keywords:  mp4 apple protected

You might want to carefully read the Wiki entry on this subject. Bottomline, Apple is very protective of their technology, whether it be software or hardware.

Regarding specific suggestions, I personally do not have experience since I rarely have songs in MP4 format, but from my result of my 'net search with the keywords above, it does appear there may be some solutions.

Good luck. 

THanks very much for the thoughtful reply, I appreciate it and will have a quiet look around.  Cheers!

Thanks for the script and many updates! 

To your knowledge, is there any way to run the script without having the copy window steal the foreground? I’ve searched system prefs, but to no avail. It’d be great to run this script in the background while still using my computer, but typing is almost impossible for me while it’s running. And with 16gb, it runs for a little while :slight_smile:

hotdamn -

First the qualifiers (of the software developer, me). There are 100’s of things a person will try to do with my script and I have tried to anticipate them all and provide the most satisfying and useful result. However… It’s users like you that help me catch things that can be improved.

I ran a quick test scenario (after looking at my suspicious coding), and yes, you are correct, my script Copy action will assume the foreground each time, taking it away from whatever the user has moved to the foreground, requiring the annoying re-touch to get your app/process back to the foreground. Not good.

I’ve fixed that. Now only the first copy will be in the foreground (I want the user to know where the copy window is on the screen, just in case they want to bring it back to the foreground later on).

But wait. The packaging and getting the new version up on my download site always is a bit time consuming. So I will post here and let you know personally (via the forum private message) when the revision is ready.

Thanks for bringing this to my attention. A much needed fix. 

For those using my iTunes to Clip script (the main post is here), I have made a minor revision based on the previous post here by hotdamn.

Hotdamn brought to my attention the
fact that the Copy window of my script will assume the foreground
during execution and will repeat this for every track copied from a
playlist. Even though the user might regain the foreground by working
with another application or process during the execution of my script,
the Copy will then take it back, requiring the user to constantly
re-touch their app. Very annoying if you want to interact with another
app or process while my script is executing/running.

Fortunately, an easy fix. I now show the Copy window only on the first
copied track, just so the user will know where it is should they want
to return to it for any reason. The new revision is at the usual download site.

Message Edited by kwanzan on 05-18-2010 03:52 PM

I’m using the updated script right now, and I love it! Thanks again for all your work; it’s really appreciated. 

I have one other experience with your script that I’m wondering about:

If I run the script on a playlist a single time, everything works as expected. Then if I run the script on the same playlist a second time, the script runs very quickly, recognizing that all the tracks are already on the clip. However, the playlist on my clip created by this second running of the script turns up empty. 

So, I did a little experimenting. I found that if I run the script, add one item to the itunes playlist, then run the script again on the same itunes playlist, the playlist on the clip then contains only the one new item. I take that to mean that the playlist on the clip is generated from what is copied, not the contents of the itunes playlist. Is that correct, or am I doing something wrong?

Right now I just delete the contents of the clip and run the script to re-copy everything. However, is it possible to have the script re-build the playlist with items already on the clip? This would work very well for smart playlists and podcasts. 

All this talk is making me want to learn applescript again! Last time I wrote one was about 15 years ago :-) 

hotdamn -


The problem you describe is something I intentionally programmed against.

After your message, I first looked at my code and saw that it should not be doing what you are experiencing. I then ran the test case you describe: I first had the script create a new playlist (that contained an entire album from one artist and a single song from another). Twiddled my thumbs as the copies proceeded, then checked the newly created .m3u file on the Clip (with Textedit).  All songs accounted for.

Then I selected the exact same playlist (actually just left iTunes as with the previous run), and ran the script again. No copying (or twiddling of thumbs) this time. I then again viewed the .m3u file and it was exactly as expected, i.e., all playlist songs included.

So, two possibilities (without knowing more from you):

  1. I’ve never used smart playlists. Seems unlikely this is the issue, but perhaps there’s something unusual about them such that I need to create one and repeat the experiement.
  2. When you run this type of playlist transfer with my script, the second time you run the script (say with only the one additional new song added to the original playlist) a .m3u playlist file already exists on your Clip (from the first time you ran it on your playlist). In that case, my script will prompt you (or should) on the second run at the point of asking you about Saving the playlist to the Clip. You must answer that you want to Replace (the other choice is Cancel). I’m wondering if you are answering with Replace.
  3. I tested this on iTunes 8, (because that’s what I like to use), but have a mirror system I can boot from to test on the latest version (which I do when I make any revisions). If #1 or #2 here do not apply (please try your experiment again on regular, i.e., not smart playlist), let me know, and I will then crank up my mirror and confirm that something weird is not going on with iTunes 9.1 and my script on this issue.

So, again, I looked at my code, and just as I had remembered, I’m coding to avoid repeat copying if the songs in the playlist are already on the Clip, and I also ran the experiment myself. On the otherhand, as I was typing this I looked at my code segment:

     if file FileNameOnClip exists then
                    — copy is not necessary, so just add to the M3U playlist file —





and it has me wondering if the problem might be that my conditional is failing on the lastest version of OSX (as I am running Tiger). Applescript, to the frustration of many, is not always consistent with OSX upgrades. So, guess that might be the problem. 

Anyone else out there with later/latest version of OSX having this experience (described by hotdamn)?

BTW, hotdamn, it has not been reported to me previous. Still, I know it’s possible something’s amiss.

Please check for #1 and #2 above and respond, then I’ll know if I need to spend more time with this (getting another user to check it who has a later version of OSX, and trying it myself with a smart playlist on the latest version of iTunes. I’m hoping it’s none of these things, but I will spend the time if I know for certain it’s not something on your end.

I’ve been out of town and haven’t had time to run those checks, but I’ll get on it ASAP! Thanks again :-) 

So, with some more experimentation I’m finding a more general problem with empty/near-empty playlists. The playlists created by the script are coming up empty or containing only one or two items, regardless of whether it’s a first or second run and regardless of whether the files are already copied. 

I tried with smart playlists and regular playlists and got the same result. This may have begun after my most recent automatic system update, but I can’t quite say for sure. How irritating if the update caused a change! 

A couple of things I’d like to contribute to this thread since I had to contact support to sort this out after reading all this:

  1. For the Clip+, there is no hold switch, so the reset works differently (not sure as I didn’t need it).

  2. For the FAT corruption issue, you use the partition option in Disk Utility if you have to reformat:  


  1. The firmware for the Clip+ is different:  http://mp3support.sandisk.com/firmware/clipplus/clipplus01.02.15.zip

  2. The Clip+ firmware doesn’t seem to solve the extra files issue (ouch), so you get all these ._ files which confuses the device (ugh). Run dot_clean from the terminal window: dot_clean /Volumes/(put name of SANSA drive here)/MUSIC

Hope this helps to un-stick someone. This is less than straightforward. 

Thanks for all the help on this topic. Script is very helpful.

Message Edited by swerve on 08-03-2010 06:08 PM

Message Edited by swerve on 08-03-2010 08:47 PM

swerve wrote:

  1. For the Clip+, there is no hold switch, so the reset works differently (not sure as I didn’t need it).


Yes there is. Press & hold the menu/home button.

Thank you so much for this software; I’ve been using it with my Clip for at least a year now, and it works beautifully!

Recently, I encountered a problem with my Clip; it began displaying an error message reading “Not enough space for Music DB, please free 30 mb” whenever I turned it on, and then shutting itself down.  I deleted everything, but it still read as full, and since I couldn’t get into the settings menu, I couldn’t reformat.

I followed the fix instructions here:


I can start up my Clip as normal now, but unfortunately, the iTunes to Clip script can no longer locate my Clip to export playlists.  Is there anything I can do to fix this?