FAQ: Using Your Sansa Clip with Your Mac, Including a Script for Exporting iTunes Playlists

Latrade -

Sorry for the late reply.

I know nothing about the Audible files. However, I just engaged their online Chat help, and the person I interacted with stated that their digital files are in “.aa” format. Since the Clip is strictly limited to the MP3 digital format,  I think that may explain your problem. That is, if, we can accept the response on the  online  "chat " help as  authoritive.

Don’t take my word for it. Just wanted to report my experience in investigating your problem.

Best,

Kwanzan 

Except that, the Clip will in fact play Audible files (as well as other formats:  ogg, flac, wma). 

Can’t Audible’s AudibleManager be used with a Mac to transfer the drm’ed Audible files to the Clip?  (I don’t know if iTunes also has to get involved in this as well.)  I thought that this was the case and that AudibleManager indeed is Mac compatible, but maybe I misunderstood (and I don’t use a Mac). 

Miikerman -

You have brought to my attention something important, and I hope in my past comments I have not led too many people astray.

Quoting directly from the Clip manual, under Features, the Digital Audio Player:

"supports mp3, wav, wma, secure wma and Audiobook files."

Poor assumption on my part. Since they call it an MP3 player, and because it is relatively basic, I wrongly assumed it only played the MP3 digital format. And believe it or not, I’m the type that reads the manual.

Now I will say I did try loading a .ogg file and a .flac file (dragging to the Clip MUSIC folder on my Mac) , and neither showed in the list of songs on the Clip. So are you certain the clip will play those file types? Without some conversions?

And regarding Audible files, I found a Google search on: audiobook formats aa, to suggest playing them on the Clip might be a bit of a trick, at least if you are a Mac user.

But thank you for correcting a long-standing misunderstanding I’ve had regarding the Clip. And I apologize to anyone here who I may have made similar comments/statements in the past regarding MP3 format only.

Message Edited by kwanzan on 10-04-2009 08:57 PM

It’s really an issue with what these things are called:  apart from the fruit company’s players which went by their own name, the rest of the players tended to be called “MP3 players” given the dominance of the MP3 format, and the lack of a short-form name (“digital audio players” just doesn’t roll off the tongue, and DAP isn’t much better). 

Yep, ogg and flac files should play, without any conversion–that capability has been present for the Clip for awhile.  But I’m a PC guy here–I don’t know if there could be a Mac issue there.

And, good to see that there is another manual reader there!

Um stupid question that i cant seem to find an answer for. What/where is this so called m3XXa.bin. I updated my clip to VO2.01.32A but nothing new comes up. I have a macbook pro 10.5.8.

Please help soon, i desperate for music! 

Hi kwanzan,

Thanks for all you have done to make Sansa Clips usable by Mac users like myself. I stopped using my Sansa Clip about a year ago when it displayed the dreaded error message, “Not enough space for music DB. Please free 30 MB.” I know from reading this post that the issue is with a corrupted file. And that the accepted solution is to go to a Windows PC and run a file called Chkdsk or something like this. But is that really the only way to deal with the problem? And what will happen after it gets removed…do we have to start over again somehow to make it Mac-compatible? I’m not sure where to get the file that the thread talks about even if I could easily find a PC to do it on. Thanks for your help. I’m close to giving up on my sansa clip and going to get a new Nano that has the voice recorder, FM radio, and video recorder that nanos have been lacking for so long…

dancedolphin -

I think you can likely remedy your problem by following these steps from my original post, under “if you have a problem”:

(uh, dancedolphin, skip this reset section if your Clip is still showing up on your Mac as a USB drive like always, and jump down to On your Mac…)

You might have a problem doing this. I did. After I copied the upgrade file, m3XXa.bin, the “upgrading firmware” message remained long after 10 seconds. And the device was completely disabled (hung). Fortunately, I found several posts here that saved me. First, to “reset” the device, you must:

  1. Slide the power switch on and hold for 10 seconds.
  2. Slide the power switch into the Hold/Lock position.
  3. Now while pressing the center “select” button, plug back into your USB
  4. You should see the Clip as a disk drive.
  5. You now must format/reformat the drive. This will remove anything you have copied to it!

– On your Mac, open the Disk Utility application (Applications:Utilities)
– Select the SANSA drive
– Click the Erase button/tab
– Choose MS-DOS File System (FAT 16) as the format
– Do it! (erase)

Now, with your newly formatted/reformatted drive, unplug from the USB and make sure you are back to a working Clip, e.g., go through the top level menus on the display. If you are not, try all “reset” steps again. If the device is still not working, I do not have a solution.

Finally, with your newly formatted Clip, repeat the steps for the firmware upgrade (re-install the firmware, see my original post. Be careful about disconnecting too quickly after you copy m3XXa.bin. I think this may be the issue with the hanging. Not certain, though.

*****

If you this does not work or the instructions are confusing, feel free to take this off thread and send an email direct to me (just click my forum icon)

Message Edited by kwanzan on 10-18-2009 09:10 AM

AIV

Here are the instructions directly from Sandisk:

http://forums.sandisk.com/sansa/board/message?board.id=clip&thread.id=15109

If you are still having trouble after reading that post, let us know. 

For those using my iTunes Playlist to Clip script (the main post is here), I have made some major revisions and uploaded the new version to my download site. All revision changes can be reviewed in the Readme file contained in the .dmg download. This version has only been tested under OSX 10.4.11. I’ve received a few recent reports regarding possible problems, and if they are indeed real (not simple usage problems), they may have to do with some issues with my script, iTunes 9.0.1 and later versions of the OSX (Leopard or Snow Leopard). I will only be able to resolve those problems (again, if real), by upgrading my older iMac, which at the moment I’m not in the best position to do. Or find users with new versions of the OS willing to help debug in some “remote” fashion. Just the way it is at the moment.

Thanks, kwanzan. I followed your directions and it looks like I’m back to having a workable player, thank god! It’s nice to know that the posts saying you “HAVE TO” go to a PC and use the Chkdsk program are not necessarily true for Mac users.

I only wonder–how do we know we have the latest version of the firmware? It seems like there are somehow two “latest versions” currently–one that is 1.01.32 and 2.01.32 (as of Oct 22, 2009). But where would we go to know the current version? It looks like the “updating your firmware” first post was written 8 or 9 months ago so I wonder if it’s the most current version. Thanks for any help on that and thanks again for helping to make my Sansa work again!

dancedolphin -

Cool that your Clip is working again.

Regarding your latest version question, I took a look at that main firmware upgrade page, and I too was initially confused. But then, (literally as I was posting to the upgrade poster to inquire) I found this at the very top of the firmware upgrade post:

  • Turn on your Clip
  • Select Settings from the main menu
  • Select System Info
  • Look at the Version #

Revision 1 = 1.XX.XX (example: 1.XX.XX)

Revision 2 = 2.XX.XX (example: 2.XX.XX)

 

If your Clip is Revision 1 proceed to Revision 1 instructions.

If your Clip is Revision 2 proceed to Revision 2 instructions.

*****

My bold on the last two statements. So, you look at the revision on the Clip (as purchased, I would assume) under the Settings Info, and that will tell you what version is your latest upgrade. I also see that acccording to the main post the last “edit” is dated Feb 22, 2009, as you say, 8-9 mths ago. Since this is an admin poster I wonder if the edit history is maintained the same as with other posters?

Regardless, here, someone has tracked the revision history, and as of their post (dated 10-2008), they seem to believe what is posted on the forum upgrade page. A second (and better) confirmation I found is here, directly from Sandisk regarding the latest version.

You may wonder why someone with my knowledge and abilities has the time to be so thorough in this forum? The reason is because I have a graduate degree in Eng, but am without a job. I have a highly specialized background in scientific visualization and because I have gone off the standard path in my career (pursuing non-technical areas), the tech industry is very unforgiving. So, for too long I have had the time to be thorough and complete here in this forum (and to write software scripts, etc.). Boo, hoo, my sad tale… Really, just FYI. No sympathy required. I’ve made the choices I’ve made. But the tech industry is harsh in terms of putting you in a box, a least my experience, and not believing you can do anything else, or not open to letting you learn on the job. Sorry about this off-thread commentary; guess I’m a bit frustrated these days.

 

Message Edited by kwanzan on 10-23-2009 12:27 PM

There’s always accountancy!

Off-topic post

kwanzan,

It did seem (and still is) unusually generous of you to help out us poor Sansa Clip users with such clear and expert help. Your misfortune is our blessing and when I have a little room for it financially I’ll certainly make a donation on your script download site. When you say your background is in “scientific visualization,” do you mean like computer modeling? Or data visualization? Send me a PM with more details and I’ll see if it makes sense to connect you with one or two people I know who might have leads for you (not that I am aware of any). 

Again, thanks for making our Sansa Clips work with iTunes and other Mac issues. I appreciate it!

I just tried setting up my clip with my Mac.

I tried resetting and erasing with Disk utility. Now, it says “FAT corrupted. Connect device to PC and recover FAT.”

I have not idea how to do that. I’ve tried resetting repeatedly and have dowloaded both versions of the firmware and installed them and neither one has fixed the problem. Is there any other way for me to fix this?

liudawg -

Look over here.

" melimel" at the top of the thread seems to have encountered a similar problem/situation. Lots of snarking in the thread, but " sansafix" seems to think you should be able to use disk utility. Personally, I don’t know for certain if those guys are correct, but I 'd suggest running your problem by " sansafix" since he/she seems so adamant that you can use Disk Util to fix this.

Just pure speculation on my part, but perhaps you can format it with disk utiliy as Mac OS Extended (Journaled), and then if that succeeds (in simply formatting it for the Mac), try formatting again in the desired/required MS-DOS format for the Clip.

Personally, I’d bug " sansafix" since the thread indicates “SansaFix is the Man”. You can click on his name and send him a message directly (if he’s has that option on), if you don’t want snark from some of those posters. Be sure to let him/her/us know exactly how you have the settings on your Clip, i.e., what is the USB Mode (under the Setting menu), did you ever use the Format under Settings and say, Yes, what firmware, etc. If you can recall, what were all the Settings (and what if anything had you tried) the very first time you encountered your problem. The more information you can provide, the more likely someone will be able to get this fixed for you.

Let us know how it goes.

Message Edited by kwanzan on 11-19-2009 08:52 PM

Message Edited by kwanzan on 11-19-2009 08:53 PM

Message Edited by kwanzan on 11-19-2009 08:53 PM

The sansa clip was put on MSC (in the USB settings), and had the version 2.01.XX firware (can’t remember now if it was 32 or 28 etc). Either way, now I can’t get to anything on the clip. It doesn’t show any of the menus at all, just the error message (FAT corrupted). I had tried formatting from settings, but since it still hat issues, I used disk utitilities to erase it. I used the MS-Dos setting here. When I connect it now to my Mac, it’s still recognized, and I can place files on it, but the firmware won’t actually install (it’s on the root drive) nothing happens when I disconnect. It just continues to say FAT corrupted. I suppose I can try it on a PC later.

While none of these initial steps worked for me on Mac OS X, I eventually tried to first update the firmware on my PC (for those lucky enough to own both). This worked liked a charm.

Then I went back to the Mac, and tried to hook it up again. Didn’t work. When I tried a different USB port (from the keyboard) I got a low power warning, so at least I knew the Mac was trying to see it. Then I tried just plugging it directly into one of the free USB ports in the back of my iMac (before I was using it via a Belkin USB hub) and presto! The player loaded immediately.

It sucks that I can’t see the clip unless it’s hogging one of the USB ports, but at least I can see it and load music onto it.

FYI: For OS X set the Sansa Clip mode to MSC.

Didn’t need to use the iTunes script…yet; mostly I just dump individual tracks/albums…

(I also own a Sansa e280 and that also had problems with OS X…I sure hope SanDisk gets their act together and does a *little* more work making these players Mac-friendly. We don’t all want iPods…)

poortrecker -

Interesting to hear of your experience. Glad you persisted. I too wish my keyboard usb port provided the DC power level required by devices like the Clip. Would be very convenient, but I’m assuming Apple offered those keyboard ports for relatively low power devices like remote mice (I use one for that), or joysticks, etc.

Regarding your comment, “I sure hope SanDisk gets their act together and does a *little* more work making these players Mac-friendly. We don’t all want iPods”, I’ve expressed my theory here before regarding this oddity.

I’m guessing SanDisk is acutely aware that Apple has some rather daunting intellectual property legal work that would intimidate anyone creating a portable music device that works in certain ways similar to the iPod. Most likely one of those certain ways is that the competing device, works and acts like an iPod, AND, comes with software to make it plug and play with iTunes on an Apple machine. SanDisk, I believe, does not want that trouble, so they specifically state on the packaging, PC compatible (at least mine did), and provide no instructions or software for using it on an Apple machine. Just my own little theory. FYI, these tech companies are in constant court battles over these kinds of things and the legal fees can be substantial. So if you’re SanDisk, kind of easy to choose to avoid them, given their market to PC users relative to Apple users.

Sorry to ramble.

BTW, I’m the author of the iTunes to Clip playlist transfer script. 

Hello.

Thanks for a great guide, it worked like a charm.

I got one problem tho. When I use the playlist script (I got it all right installed) it says the format of the files are not supported (they are all mp3 files, nothing special about them.) on the Sansa.

Wierd…?

Do you know what I could have done wrong?

I run iTunes 9.0.2 and Snow Leopard 10.6.2. and I got a Sansa Clip v2.

Thanks a bunch

Eric

Edit:

I was a bit to hasty there…

I found out that you could convert the mp3 files to create an “ACC-version” of the file? (It said something about that in the debug message)

It still does not work tho, after doing this conversion.

Message Edited by Stahlin on 12-26-2009 06:26 AM

I just bought a refurbished sansa clip 4GB, it is V02.01.32A.  It shows up on my desktop.  I have dragged and dropped music onto it in the music file.  When I click on it, it plays the music file for me as if it is on the device.  But when I disconnect it says there is no music loaded.  I can’t figure out what I am doing wrong as I have the most current firmware.  But maybe that is my problem.  Help me please, as I know very, very little about computers.  Also my brother gave me his old, I have been using it about 1 month.  It is a mac os x version 10.4.11.