FAQ: Using Your Sansa Clip with Your Mac, Including a Script for Exporting iTunes Playlists

Just a few quick comments. 

Interesting about the USB mode under Vista. Apparently it’s happy with MSC.

This last post from you possibly offers a clue. We know it works fine on the PC. We also know you are not seeing the display that indicates communication via USB on your Mac (at least that what you seem to be saying).

Sooo, I’m hoping (for your sake) you have only tried one of your available USB ports on your Mac. Try them all. And if not too much trouble, reboot your machine before you do that. Sounds like a real possibility this is just a USB issue with your Mac.

Finally, regarding support form Sandisk. I am in no way a spokesperson for them or connected to them in any way, but you will see that their product package indicates the Clip is compatible with Windows only (at least it was that way when I purchased mine). So in reality they have no responsibility to those of us using the Clip with our Macs. But obviously it would be nice to not have to resort to a forum like this for support. 

I think I have tried every idea you had.  No luck.  I appreciate all of your help - thanks.

Regarding Sansa support:  on the webpage they give an email support address.  Even if they do not support Mac then at least common curtesy requires a polite reponse saying they cannot support.  I like the device a lot.  It would not take that much to get a loyal customer.  Oh well.

BBaer -

For what it’s worth, I do agree with you completely regarding a simple standard reply from Sandisk to the effect “we do not support Mac”.

Believe it or not, I actually have another idea to address your problem, though I realize you may have decided you no longer want to put time into it. 

I recall I had a very similar problem myself. When I first tried my Clip on my laptop, it was not recognized. Reason: my laptop is old and running OS 9.2.2 which does not have a USB 2.0 driver and the Clip is designed for USB 2.

Given the similarity in behavior of your Clip with your Mac, I have to wonder if you don’t have a USB issue with your Mac. With OS X 10.4.11 (what I’m running, also), everything should be fine. But it’s possible something has happened to your drivers. And I know this is not a crazy speculation because I found an excellent link that offers a long list of things you can try to fix the problem if it exist. Here is the link: http://www.macfixit.com/article.php?story=20070824012114701

One of the suggestion requires an Apple utility call USB prober. If you decide you need that, you can email me direct and I can save you the trouble of installing Developer Tools and just email it to you (zipped).

Again, I realize this may be more technical than you want to get into, or more time than you want to invest, but I did remember my problem with my laptop so thought I would just throw this out.

I followed your directions and all seemed to work except as the post from Feb notes I have a problem with converting to m3u - there is no convert option in my advance menu of iTunes v. 8.

Do you have a suggestion?

thanks! 

flyinggoat1 -

I don’t exactly understand your problem, so you will need to clarify.

The iTunes script translates an iTunes playlist into a file that the Clip understands and then copies that file to the Clip MUSIC directory. The format of that file is M3U. This is what the script does, so no manual conversion to M3U is required.

Perhaps you misunderstand. Are you actually having a problem with converting your playlist songs to MP3?

Again, I will have a better chance of helping if you can clarify.

I tried to use the script to move a playlist from my itunes to my sansa clip and go the error message “File some object wasn’t open”.  When I disconnected the mp3 player from my macbook, the playlist does not work. What am I doing wrong?

Wierd update on my MAC and SansaClip.  Have not found an action for upgrading USB drivers.  I will plug SansaClip in MAC as it charges (even tho MAC does not recognize it).  Now, when I plug in for charging after a bit of time I get a box in the center of the MAC screen and  the following message apears within the box:  you need to restart your computer.  hold down the power button for several seconds or press the restart button.  Within the box there is also a shape - white circle with black circle inside white along with a black horizontal line.

Does this tell you anything?

I have an issue that I hope folks can help with. I am putting this here because I do use this on a Mac and don’t know if that has anything to do with my issue. I have a 1gb that has worked fine for me. I’ve noticed that the free space has gotten smaller. It’s probably been a gradual thing. I use this mostly for podcasts. I add to it daily for my commute and delete what I have heard the next time it is plugged in. I of course use the Music folder. I suspected my space was getting smaller and smaller so I deleted everything in the music folder. I do not have any recordings on the unit. I should hvae over 900MB but show only about 400MB available. I am guessing that there is some sort of stuck file(s). I would like to clean slate the unit or figure out how to find the data that is hidden to delete. I was surprised that I couldn’t find this issue in the forum. Anyone have some help for me?

cleantone -

I am only making a guess at how to remedy your free space problem as I personally do not have experience solving this particular issue. Here is a list of things to try, in increasing order of effort:

  1. Do a basic reset:  Slide up the power on switch and hold for 15 seconds
  2. At the Clip main menu, go to Settings:Format, and choose Yes. (if your Clip is no longer visible on your Mac after this, you will need to repeat the steps in the primary post for this thread)
  3. Re-install the firmware.

To clarify what I am suggesting: try #1, if that does not fix your problem try #2, etc. 

BTW, your problem may have occurred because you must remember that when you delete files when plugged in to your Mac you need to Empty the Trash before unplugging. If you encounter this issue again, you may want to check your Trash when the Clip is on your desktop; old folder/files you thought you deleted may still be there. If so, just empty the trash to fix the problem.

I think I know what’s going on – basically, the problem is that you’re using a Mac.

No, that’s NOT a cheap shot at Macs.  It’s basic reality – it’s fact.

The problem is that Macs have this problem of walking the dog EVERYWHERE they go.   I found this out the hard way – my wife is *forced* to use a Mac at work (your tax dollars at work).  She brought me some files she downloaded at work – on a USB “thumb”  flash drive.

The files were a bunch of ZIP archives.

Oh, the Mac downloaded them alright.  That wasn’t the problem.

The problem was that in *addition* to downloading them, it *also* EXPANDED them – silently, with no warning, with no concern about how much space it would take to hold the zips AND their contents.

But that’s not what’s causing YOUR woes (although it *does* set the stage, by demonstrating the mindset that went into designing Mac behavior).

YOUR problem (which was *my* OTHER problem, when dealing with what was done to that flash drive), is that whether it’s dealing with zips, or any *other* kind of file, the Mac has a *very* interesting habit of creating “shadow” files (which are, ON a Mac, apparently invisible to the user).

Each “shadow” file has the SAME name as the *real* file – but, farted around a bit (long extension, extra undercores, etc.) – and, is about 4KB.

Now, 4KB ain’t a whole lot of space – unless you’re talking about thousands of files – unless you’re in a scenario in which the good ol’ Mac is constantly sticking 'em where they’re not needed – and, never *deleted* (since they’re invisible to the Sansa TOO!).

But wait, there’s more!  Every DISC (such as a flash drive – such as a Sansa) that the Mac touches will have installed onto it a *large* set of directories, subdirectories, indexing files, etc.  I mean a LOT of  crap that serves NO purpose whatsoever in the real world (other than eating up space and getting in the way), but, apparently the Mac NEEDS that crap just to keep track of what IT’S doing.  That’s some FINE operating system, that NEEDS to take a dump every two steps just so that it can find its way out of the woods.

Anyway, I think that if you connect your Sansa to a *real* computer – in MSC (disc) mode – and make sure you tell it to let you see hidden and system files, and NOT hide extentions (because if I recall correctly,some of the Macturds are “extension-ONLY” filenames), you’ll quickly find out where all your storage went.

What you have is essentially a “virtual memory-leak” on your hands.

(Yeah, I dislike Macs.  It’s nothing personal – I dislike ANYTHING that I have to constantly clean-up after.  That thing has been on the market for quite a while now – it’s old enought that it should be toilet-trained by now.  It’s not!)

@pickmorel wrote:

I think I know what’s going on – basically, the problem is that you’re using a Mac.

As usual, Mac bashing… Well as a switcher, I could tell you alot about MS OS incompatibility (vista vs XP), BSOD, Printer inconsistency and so on but this would be off topic.

About the Sansa Clip, I’ve found a very good way to use iTunes to convert “on the fly” your audio files to the format you want and put them dierctly on your Sansa Clip, without modifying your original files. You just have to go there: http://katastrophos.net/andre/blog/software/itunes-encoder-scripts/ 

It uses LAME encoding for MP3 and oggenc for OGG files.

You will see a Terminal window but this is the only “non standard” feature.

Be sure to use your Sansa Clip with the MSC USB mode switched on.

I personnaly use the Ogg encoder, this way I don’t have to install FINK, but this is personnal, so the following only apply to ogg part.  

The script will ask you for the destination each time if it is non standard, but you can change it directly in the script if you wish. It will also ask for the encoding quality, it uses q2 by default I think and you can also change it directly in the script.

All credits go to the writer of this utility.

@nicpaillard wrote:


@pickmorel wrote:

I think I know what’s going on – basically, the problem is that you’re using a Mac.


As usual, Mac bashing… Well as a switcher, I could tell you alot about MS OS incompatibility (vista vs XP), BSOD, Printer inconsistency and so on but this would be off topic.

As usual, typical McNasty crApple fanboy whiney noise.

Nice attempt at misdirection, though. Sorry it didn’t work out for you.  The fact remains that your vaunted toy DOES walk the dog all over everything it touches.  The fact remains that it inserts TONS of garbage files, directory trees, database indexes, and so forth – which are HIDDEN from the users UNLESS they happen to inspect the drive on a REAL computer.

BTW, WTF makes you think I like *Microsoft* either?  Oh, sorry – just more pathetic misdirection ATTEMPT on your part.

Now go cry in your hanky, I must have howt yor feewings somthing TEWWUBBLE!  (by accident)

kwanzan - 

It seems yes, that is the problem I am having if you say so…  When I create a play list to transfer it starts the transfer and then says the songs are not in MP3 format, and I can use the iTunes Advanced menu where there is an option to convert to MP# which there is not.

This is really frustrating as I bought the clip in October and now am back home in the caribbean and cannot get it to work and have no local support option.  I guess I should have gone with the iPod if I have a mac.

thanks

I think I may have figured out my problem… I was looking at the wrong Advanced menu - when I checked the preferences advanced menu the format selected was ACC instead of MP3, but now…  not a solution yet because even though I can select convert to mp3 after the conversion is complete I cannot figure out where itunes puts the converted?

flyinggoat1 -

Uh, if I help you with this will you let me escape the 5 degree (F) weather I am currently enduring and come visit (in the Caribbean)…

You asked the question regarding where iTunes stores songs/files whenever it does a format conversion? It stores them in the location specified by the “iTunes Music folder location” in your iTunes Preferences. To find out this location, go to the iTunes: Preferences: Advanced menu. Click the General button and you should see the location information.

I am running iTunes 7.6, and I just did a quick test. I used the (main) iTunes Advanced menu to convert an M4A formatted file that was on my Desktop, to an MP3 formatted file. I checked, and the converted file was stored in the location specified by my Preferences setting.

Now, the reality is, you do not necessarily need to know where your MP3 files are located to use my script. The script will copy them from wherever they reside. However, here is the problem you are likely having.

When iTunes converts a file to a different format, it does not remove the original (at least by default in 7.6). So, after the conversion, you will have two files with identical names on your computer (and two songs in your library with identical names). They will differ only in their file extension, and of course, will have different formats. Here’s where the problem occurs. If the song/file you decide to convert is a song in an iTunes playlist, the conversion creates a new song/file in your Library with the same name, but it does not change the playlist song. The song in your playlist still corresponds to the file with the format you do not want.

You can verify what I am telling you by using the File: Get Info on any song, and by looking under the Summary info you will find the location (with file name extension) and format information for that song.

So, if you have a playlist where all the songs are in the ACC format, and you want to use the Clip and my script, you must convert each playlist song to MP3, and then replace each playlist song with the MP3 duplicate that is added to your Library by the conversion process. This obviously is a hassle. There might be a script around that will do all of this automatically. A good place to look for such a script would be Doug’s Applescripts for iTunes.

Email me direct if you still have questions.

The Caribbean? Really? Oh, to be in Tortolla right now…

Message Edited by kwanzan on 01-26-2009 06:37 PM

Thanks!  That is all very helpful…  just returned from diving so I will take some time to look for the converted files where you suggested.  Will let you know if there is success…  I am in the Turks and Caicos but yes, Tortola is also beautiful!

SUCCESS!!!  Took me while to focus on it but yes, there were multiple copies in the music library… of course because I had converted three times.  SO now I just have to figure out a way to keep a playlist of the mp3’s but as you noted there will now be multiple copies on the main music list…  this is annoying.  I will check Doug’s applescripts per your request.  But at least there are some tunes on my clip now!

thanks

Sorry to bother again…  I downloaded doug’s quick convert and it worked on one song but replaced the AAC with the mp3 version.  Is there any reason why I should not convert all the music and only have the mp3 versions on my computer?  or is there some reason why I will need them to be AAC?

thanks

I can’t even update the firmware.  Since is not update available for Imac OX system.

I love my Sansa but this incompatibility  is a real joke.     

artermix -

First, I am no apologist for Sandisk, nor do I mean to lecture, but the packaging for the Sansa Clip does not suggest the Clip is compatible with the Mac operating system. People in this forum have fortunately provided information for those of us with Mac’s that explain how to use the Clip with the Mac OS and Apple computers, but Sandisk has never offered that compatibility (at least, not to my knowledge).

Anyway…

We might be able to help you with the problem you are having if you could provide more details. For starters:

  1. What version of the firmware does the Clip you purchased have installed? (read my original post here to find that)
  2. Does the Clip appear on your iMac desktop when you plug it into your USB port?
  3. If yes, to #2, then describe in detail the problem you are  having.

Quite sincerely, we can only help you if you provide details.