FAQ: Using Your Sansa Clip with Your Mac, Including a Script for Exporting iTunes Playlists

Hi there, I have been using my Clip for about a week, after converting my iTunes to mp3, all was going smoothly.  But today when I tried to charge it, nothing happened when I plugged it in to the computer.  It’s not registering as a device on my computer, the Clip itself is totally dead, no sign of charging, screen does not light up.  I tried manually pushing the power on, unplugging, nothing.  Does anyone know what is going on? 

Not sure if you tried holding the power button up for about 10 seconds to reboot it but give it a shot.

Im not sure but I have had mine since Christmas 2007 and today it died. It worked fine up until about 4:30PM today. Now it will not even light up or anything. I have held the power button for several seconds and nothing. I dont think I will buy another sansa product.

Thanks kwanzan, this script worked great!


Always appreciate the nice feedback.


Hi, newbie here.  I’ve followed your instructions to upgrade the firmware, but no update.

First I charged my clip for about 4 hours from my mac.

Then I checked the settings, and found I have version 01.01.18f.

Therefore I followed your link and clicked the appropriate download.

I got a file called m300f.bin appeared in my downloads folder.  I therefore clicked on it to unzip, and a file called m300f.bin.cpgz appeared.  

Odd thing is, the former is 5mb, but the latter only 1.2 mb.  

When I plugged my clip into the mac it recognised it immediately as a disk drive and appeared on the desk top.  Does this mean it is automatically in MSC mode?  I tried putting it on hold and pressing the centre button (as recommended on another thread) but it made no difference.  All I got both times was the charging information - showing it was charging the last bit of battery, even though I’d just fully charged it.

I tried dragging the bin file (then the cpgz file when nothing happened) into the top layer on the clip, but nothing happened.  It just carried on saying it was charging the last bit of battery.  (But when I unplug it, it says the battery is full again.) No upgrading firmware message. What to do?

Hope you can kelp.  KD 

Remove the .cpgz extention.  File should be m300f.bin.

kdorlando -

We should be able to get this to work.

Step 1  

First, I would download both the Americas version and the Europe version (since you stated you “got a file called m300f.bin”, I’m assuming you want the Europe with FM).

Note that the links for upgrade are links to .zip files. From your message it would appear that on your computer, when you click a link to a .zip file to download, your system automatically “unzips”  the file, and in this case the result is a .bin file. So, you do not need the additional step of “unzip”. You want to use the file with the .bin extension. 

After clicking the upgrade links, you should have two files: m300a.bin, and m300f.bin.

Step 2

Plug your Clip into your Mac USB. Wait for it to show up on your Desktop. Then double-click the disk drive icon for the Clip. Look at the folders and files shown. If the .cpgz file you dragged to it previously is shown, Delete it.

Step 3

Because I’ve seen some posts here about problems with the Europe with FM firmware upgrade, let’s first have you try the Americas version, just to verify that an upgrade will work.

So, drag the m300a.bin file to the disk drive icon for the Clip. (be certain is does not get moved to any of the folders within)

Wait a few seconds.

Now unplug from the USB.

Hopefully, you should see something on the display about updating firmware.

If you see the updating firmware message, check the version number in the Settings afterward to confirm. 

If not, try again, only follow these steps from the upgrade post for mounting the Clip:

  1. Turn on the Clip
  2. Put the device in Hold (move Hold button until orange is showing)
  3. Press and hold the Center Button
  4. Plug the mini-USB connector into the device (be sure the USB is plugged into the computer)
  5. Wait for the Clip drive to mount

Step 4 

If all went well with Step 3, repeat it now using the m300f.bin file. If this does not work, then I think we must assume there is some problem with the Europe with FM version and the Clip you’ve purchased. 

I hope this works for you. 

I had a lot of trouble copying across music using Finder. Sometimes the copy process would abort without an error message, at other times only parts of files would be copied. As a result some songs would appear in the Clip database but would’t play, others would play halfway.

My solution is to use rsync in the Terminal shell. Copies first time, every time without errors. Don’t know why the Clip doesn’t function like every other USB device, but it no longer matters.

If you’re not familiar with Terminal, fire it up and navigate to the folder with the music you want to transfer. Say that folder is called Music Transfer in your user Music folder, then the command is:

cd /users/YOURUSERNAME/music/“music transfer”

Then (assing your players is called Sansa Clip, invoke rsync like this:

rsync -vcW *.* /volumes/“sansa clip”/music

My new clip is V02.01.16A. do I still have to update firmware? Also, please excuse me for being an ignoramus (this is my first MP3 player, which I am setting up for my kid), but how come I am not able to insert a CD into my iMac drive, then drag the audio files from the Finder to the Clip? I tried and although they show up in the Clip’s folder, they do not show up on the device itself. thanks!

Given this post, dated Oct 2, I do not think you need to update your firmware.

Regarding your second question:

  1. The Sansa Clip will only play digital files that are in the MP3 format.
  2. Anything you “drag” to the Clip must be dragged to the MUSIC folder of the Clip drive represented on your desktop.

So, first make sure your CD “audio files” are in the MP3 format (iTunes can convert them, if not). And second, make sure you locate the MUSIC folder on the Clip drive as your destination.

Hope that helps. 

Success! thanks for bearing with me. this is why I put off buying an MP3 player so long, I hate fooling with this stuff.  

Can I move the files back into the audiobook folder of the clip since that is what it are? Or do they all have to stay in the music folder? What about podcasts? 

Message Edited by slfountain33 on 11-14-2008 12:40 PM

slfountain33  -

Regarding your audiobook/podcast questions, I’m afraid I cannot offer much. First, I have not yet updated my own Clip to the latest version of firmware (which I think may have restructured the folders into Audiobook and Podcast, as opposed to simply an AUDIBLE folder), and second, I have not used my clip for audiobooks, and only once for an NPR podcast.

You might want to just throw the keywords, audiobook and mac, into the forum search; seems there is a fair amount of discussion. Also, just experiment, i.e., drag some audio books into the Audiobook folder, podcasts into the Podcast folder, etc.

Good luck. If you learn anything useful (not already posted), you might want to consider sharing what you know.

HELP!!! This link doesn’t work!!! Having the same problem–using an iMac, did not subscribe, just dragged and dropped tracks onto Clip–everything works fine except periodically music stops and this message comes on screen! What to do, what to do?

My Mac OS X, v10.4.11 does not recognize my sansa clip when I plug it into USB.  I have tried holding the buttons you suggest when inserting USB with no luck.  Any other suggestions?

Jader -

Just a little friendly advise. You will maximize your chances of getting useful information here if you are careful and explicit with your request. Only in revisiting my original post here (in response to another member’s post) did I discover a typo in my hyperlink to the download post I mention. I did not know what link you were talking about when you exclaimed, “This link doesn’t work!!!”. But I’ve fixed that now and did some re-editing in an attempt to keep my post always current. Remember, we don’t get paid here…

If you are still having problems, I might be able to help, but I would need to know what version of firmware is on your Clip, and I would need as much detail as possible regarding how you have copied songs to the Clip.

BBaer -

First, I can only suggest that you carefully re-read the instructions in my post, particularly the section on “Quick Education”. I just want to be certain your Clip is in the correct USB mode.

Second, I personally have not updated my firmware to the version 2, so if your Clip came with that version installed, I guess it’s possible Sandisk has changed the firmware in a manner that it will no longer work with the Mac USB as it did with all of the version 1 firmwares. I personally don’t have any great need/desire for version 2 to test this possibility, but if nothing else solves your problem (and your Clip came with a version 2 installed), then you might want to try downloading version 1 and try it.

Hopefully someone will read this who already has experience with version 2 and a Mac, and will provide more useful input than I have.

Good luck. 

Thanks.  When I go to settings on the “clip” it shows I am set up on V01.01.29A and my USB mode is set to MSC.  I think I have followed everything on your instructions - tried numerous times.  MAC still does not recognize it.


BBaer -

Frustrating. Guess I should have inquired before, are you at least seeing the display indicate communications (says, Connected, shows data transfer icons)? If not, then you likely have a hardware defect (bad cable, connector, etc.). Also, if you have access to a PC, set the USB mode to MTP and try it, again to confirm the device is working.

Honestly, sometimes you just have to keep trying various scenarios. In the end though, there is the chance you have something not quite working right with your particular device. Here are my suggestions at this point:

  1. Make certain your Clip has a full charge. Initially this will take several hours.
  2. Be certain to reset the device: Hold the power switch in the On position for approx 15 secs.
  3. After the reset, recheck the USB mode (should be set to MSC)
  4. Now just plug it into your USB (do not hold buttons, etc., just plug in the cable)

If you still are not seeing it on the Desktop (it may take a second or two to show up), try the Autodetect mode for the USB mode setting.

Still not working? Try the MTP mode for the USB mode setting (just in case you have some weird USB mode defect).

Still not working? Uh, some choice profanity at this point would be in order. And I’m probably out of ideas, unless you learn something during your trials you want to share. You could try again the “if you have problems” steps in my post.

Good luck.

Thanks for all of your help.

I did try in a vista computer and device showed up and I transferred files, etc.  All worked well.  I did this in MSC mode.

When I plug into Mac the clip shows it is charging, but there is no sign on the Mac that it is connected - no sign of recognition).  It has a full charge so that is not it.

I will follow your suggestions tonight and let you know.  Again, thanks for all the suggestions.  You would think that Sansa would have some support for their product to help solve this.