FAQ: Using Your Sansa Clip with Your Mac, Including a Script for Exporting iTunes Playlists

Off-topic post

kwanzan,

It did seem (and still is) unusually generous of you to help out us poor Sansa Clip users with such clear and expert help. Your misfortune is our blessing and when I have a little room for it financially I’ll certainly make a donation on your script download site. When you say your background is in “scientific visualization,” do you mean like computer modeling? Or data visualization? Send me a PM with more details and I’ll see if it makes sense to connect you with one or two people I know who might have leads for you (not that I am aware of any). 

Again, thanks for making our Sansa Clips work with iTunes and other Mac issues. I appreciate it!

I just tried setting up my clip with my Mac.

I tried resetting and erasing with Disk utility. Now, it says “FAT corrupted. Connect device to PC and recover FAT.”

I have not idea how to do that. I’ve tried resetting repeatedly and have dowloaded both versions of the firmware and installed them and neither one has fixed the problem. Is there any other way for me to fix this?

liudawg -

Look over here.

" melimel" at the top of the thread seems to have encountered a similar problem/situation. Lots of snarking in the thread, but " sansafix" seems to think you should be able to use disk utility. Personally, I don’t know for certain if those guys are correct, but I 'd suggest running your problem by " sansafix" since he/she seems so adamant that you can use Disk Util to fix this.

Just pure speculation on my part, but perhaps you can format it with disk utiliy as Mac OS Extended (Journaled), and then if that succeeds (in simply formatting it for the Mac), try formatting again in the desired/required MS-DOS format for the Clip.

Personally, I’d bug " sansafix" since the thread indicates “SansaFix is the Man”. You can click on his name and send him a message directly (if he’s has that option on), if you don’t want snark from some of those posters. Be sure to let him/her/us know exactly how you have the settings on your Clip, i.e., what is the USB Mode (under the Setting menu), did you ever use the Format under Settings and say, Yes, what firmware, etc. If you can recall, what were all the Settings (and what if anything had you tried) the very first time you encountered your problem. The more information you can provide, the more likely someone will be able to get this fixed for you.

Let us know how it goes.

Message Edited by kwanzan on 11-19-2009 08:52 PM

Message Edited by kwanzan on 11-19-2009 08:53 PM

Message Edited by kwanzan on 11-19-2009 08:53 PM

The sansa clip was put on MSC (in the USB settings), and had the version 2.01.XX firware (can’t remember now if it was 32 or 28 etc). Either way, now I can’t get to anything on the clip. It doesn’t show any of the menus at all, just the error message (FAT corrupted). I had tried formatting from settings, but since it still hat issues, I used disk utitilities to erase it. I used the MS-Dos setting here. When I connect it now to my Mac, it’s still recognized, and I can place files on it, but the firmware won’t actually install (it’s on the root drive) nothing happens when I disconnect. It just continues to say FAT corrupted. I suppose I can try it on a PC later.

While none of these initial steps worked for me on Mac OS X, I eventually tried to first update the firmware on my PC (for those lucky enough to own both). This worked liked a charm.

Then I went back to the Mac, and tried to hook it up again. Didn’t work. When I tried a different USB port (from the keyboard) I got a low power warning, so at least I knew the Mac was trying to see it. Then I tried just plugging it directly into one of the free USB ports in the back of my iMac (before I was using it via a Belkin USB hub) and presto! The player loaded immediately.

It sucks that I can’t see the clip unless it’s hogging one of the USB ports, but at least I can see it and load music onto it.

FYI: For OS X set the Sansa Clip mode to MSC.

Didn’t need to use the iTunes script…yet; mostly I just dump individual tracks/albums…

(I also own a Sansa e280 and that also had problems with OS X…I sure hope SanDisk gets their act together and does a *little* more work making these players Mac-friendly. We don’t all want iPods…)

poortrecker -

Interesting to hear of your experience. Glad you persisted. I too wish my keyboard usb port provided the DC power level required by devices like the Clip. Would be very convenient, but I’m assuming Apple offered those keyboard ports for relatively low power devices like remote mice (I use one for that), or joysticks, etc.

Regarding your comment, “I sure hope SanDisk gets their act together and does a *little* more work making these players Mac-friendly. We don’t all want iPods”, I’ve expressed my theory here before regarding this oddity.

I’m guessing SanDisk is acutely aware that Apple has some rather daunting intellectual property legal work that would intimidate anyone creating a portable music device that works in certain ways similar to the iPod. Most likely one of those certain ways is that the competing device, works and acts like an iPod, AND, comes with software to make it plug and play with iTunes on an Apple machine. SanDisk, I believe, does not want that trouble, so they specifically state on the packaging, PC compatible (at least mine did), and provide no instructions or software for using it on an Apple machine. Just my own little theory. FYI, these tech companies are in constant court battles over these kinds of things and the legal fees can be substantial. So if you’re SanDisk, kind of easy to choose to avoid them, given their market to PC users relative to Apple users.

Sorry to ramble.

BTW, I’m the author of the iTunes to Clip playlist transfer script. 

Hello.

Thanks for a great guide, it worked like a charm.

I got one problem tho. When I use the playlist script (I got it all right installed) it says the format of the files are not supported (they are all mp3 files, nothing special about them.) on the Sansa.

Wierd…?

Do you know what I could have done wrong?

I run iTunes 9.0.2 and Snow Leopard 10.6.2. and I got a Sansa Clip v2.

Thanks a bunch

Eric

Edit:

I was a bit to hasty there…

I found out that you could convert the mp3 files to create an “ACC-version” of the file? (It said something about that in the debug message)

It still does not work tho, after doing this conversion.

Message Edited by Stahlin on 12-26-2009 06:26 AM

I just bought a refurbished sansa clip 4GB, it is V02.01.32A.  It shows up on my desktop.  I have dragged and dropped music onto it in the music file.  When I click on it, it plays the music file for me as if it is on the device.  But when I disconnect it says there is no music loaded.  I can’t figure out what I am doing wrong as I have the most current firmware.  But maybe that is my problem.  Help me please, as I know very, very little about computers.  Also my brother gave me his old, I have been using it about 1 month.  It is a mac os x version 10.4.11.

Stahlin -

Sorry you are having problems with my script.

I have not tested it on iTunes 9.0.2, but it has been tested on 9.0.1. I have not tested it under Snow Leopard.

Also, I am running the clip firmware v10.10.20, not “v2” as you are.

However, with all those differences, I still wonder about the format of the files in your playlist. Currently the firmware v2 supports MP3, WAV, OGG-Vorbis, FLAC, and possibly others of which I’m not aware; I have not exhaustively researched what formats the latest firmware supports. 

To cause my script to prompt you with the 'format not supported" message, it should be detecting a format not supported by the Clip.

So, two things:

  1. I recently (dec 16) uploaded a new version of my script. If you don’t have that version, you should probably start there.
  2. How are you determining the format of the files in your playlist? Just by the extension you see in the actual folders of song files? If so, double-check the format by using iTunes Get Info on the songs. Under the Summary tab, look at Kind. Are they a “Kind” the Clip supports?

It’s unlikely my new version will make a difference, because I have changed the format detection code minimally since the previous versions.

So, I apologize for questioning what exactly is going on with your case, but we need to start with my suggestions 1 and 2 above. I recently emailed previous users (donaters whose email I know) about the latest version, and no complaints.

If I do have a problem, I want to know about it so that I can correct it, so hopefully you will get back to me. It’s best at this point to move off the forum and email me directly at the email I provide in my download Readme file.

I’ll wait to hear from you. 

knownothing -

Kind of a tough one given the device is refurbished.

First, are you definitely dragging your music files into the MUSIC folder on the Clip drive? They must be in the MUSIC folder.

If so, I would definitely do two things (in this order) and resign yourself to likely losing all music currently loaded.

Update/reload the firmware, and be certain you have the firmware for the 4GB version (might be the same as for the 2GB version; that’s something I don’t know, but you should be certain). Try the drag and drop again with just a few songs. After you Eject the Clip, and remove from the USB port the screen should indicate, “refreshing database”. If so, likely all is good, and you’re done.

If the first idea does not fix your problem, Go to the Clip Settings menu, then to Format, and choose, Yes. Repeat the simple test from idea one.

Now, important qualifiers here. I am not using a 4GB Clip. I am not running firmware version 2. I have personally used the Format idea to fix a memory available error with my Clip, so I know it can be useful, with no unwanted consequences. However, that was on a 2GB Clip, with v1 firmware.

Finally, if your results are unsuccessful, and you want to keep trying, you can find the variety of firmware versions here.

Let us know how it goes. Good luck.

Hello, I havent had a chance to go through all the replies on the post so maybe this has been covered already, but i just got a sansa clip and am trying to use it with my iBook G4 thats running 10.3.9. when i connect the clip to my computer it says connected on the clip ( can’t do anything on it while its connected it just keeps going between saying its connected and then showing the sandisk logo) but it never shows up on my computer so i cant do anything with it. is my OS too old for this or should this not be happening. thanks for any information

thedreamscene -

I cannot say for certain that your 10.3.9 OSX version is an issue, but it seems unlikely.

As a start, read carefully post number 1 in this thread. You will find complete how-to instructions there (a full page).

Report back if you are still having trouble, but I think you are simply not doing some basic things discussed in those instructions.

Hope it goes well.

For those using my iTunes Playlist to Clip script (the main post is here), I’ve made a single but important (and overdue) change, and uploaded the new version to my download site.

I have not kept my script current with the updates to the Clip firmware regarding supported digital audio formats. The previous version would prompt you that certain formats that are now supported, would not be processed by my script if they were in your playlist. This has been fixed.

Because the Clip now supports most commonly available digital audio formats, I am now only prompting the user of an unsupported format if the format is one of Apple’s propriety formats. This new format checking also allows me to eliminate the need for an “international version”.

This new version has been tested on iTunes version 9.0.3.

Thanks for the great program.  But, is there ANYTHING out there that will allow me to convert my iTunes MP4 files to the Clip MP3 format, or am I dreaming?  It totally sucks that I can’t put my iTunes purchases on my Clip.

Gorynel wrote:
Thanks for the great program.  But, is there ANYTHING out there that will allow me to convert my iTunes MP4 files to the Clip MP3 format, or am I dreaming?  It totally sucks that I can’t put my iTunes purchases on my Clip.

Dont use it myself, but from what I’ve read here, there’s a setting within iTunes itself that may do that. Otherwise, other programs like Media Monkey, Winamp, dbPoweramp, etc. may be able to.

Gorynel -

This is a touchy subject for any public forum. Here is what I can suggest, where you might find something useful. 

In your favorite search engine, use these keywords:  mp4 apple protected

You might want to carefully read the Wiki entry on this subject. Bottomline, Apple is very protective of their technology, whether it be software or hardware.

Regarding specific suggestions, I personally do not have experience since I rarely have songs in MP4 format, but from my result of my 'net search with the keywords above, it does appear there may be some solutions.

Good luck. 

THanks very much for the thoughtful reply, I appreciate it and will have a quiet look around.  Cheers!

Thanks for the script and many updates! 

To your knowledge, is there any way to run the script without having the copy window steal the foreground? I’ve searched system prefs, but to no avail. It’d be great to run this script in the background while still using my computer, but typing is almost impossible for me while it’s running. And with 16gb, it runs for a little while :slight_smile:

hotdamn -

First the qualifiers (of the software developer, me). There are 100’s of things a person will try to do with my script and I have tried to anticipate them all and provide the most satisfying and useful result. However… It’s users like you that help me catch things that can be improved.

I ran a quick test scenario (after looking at my suspicious coding), and yes, you are correct, my script Copy action will assume the foreground each time, taking it away from whatever the user has moved to the foreground, requiring the annoying re-touch to get your app/process back to the foreground. Not good.

I’ve fixed that. Now only the first copy will be in the foreground (I want the user to know where the copy window is on the screen, just in case they want to bring it back to the foreground later on).

But wait. The packaging and getting the new version up on my download site always is a bit time consuming. So I will post here and let you know personally (via the forum private message) when the revision is ready.

Thanks for bringing this to my attention. A much needed fix. 

For those using my iTunes to Clip script (the main post is here), I have made a minor revision based on the previous post here by hotdamn.

Hotdamn brought to my attention the
fact that the Copy window of my script will assume the foreground
during execution and will repeat this for every track copied from a
playlist. Even though the user might regain the foreground by working
with another application or process during the execution of my script,
the Copy will then take it back, requiring the user to constantly
re-touch their app. Very annoying if you want to interact with another
app or process while my script is executing/running.



Fortunately, an easy fix. I now show the Copy window only on the first
copied track, just so the user will know where it is should they want
to return to it for any reason. The new revision is at the usual download site.

Message Edited by kwanzan on 05-18-2010 03:52 PM