FAQ - How do I remove the U3 LaunchPad?

Directions for Uninstalling / Removing the U3 LaunchPad




There are two ways to remove the U3 LaunchPad from your Cruzer.

First Method 

The first way is to use the uninstall option in the LaunchPad itself.  To access this, simply plug the Cruzer in and follow these steps:

  • Click on the red square on your Desktop that says Cruzer, or click on the yellow and white U3 icon in the system try by the clock.
  • Click on Settings
  • Click on U3 LaunchPad Settings
  • Click on Uninstall on the left side menu
  • Follow the onscreen instructions.  You may choose the option to back up and restore your data, but you should also have already done this manually, just in case something happens during the uninstall.

Second Method
Download the U3 Remover tool. Once download run the application. 

I have tried all metheds to remove launchpad to no avail. What do I try now?

Nothing works!!!

make sure you ahve administrative rights on the computer. 

Yes, I agree with you Drlucky,you must see the administrative rights on the computer to make sure you can fo the following methods. 

Can anybody help us?We want to know the correct way to remove the U3 LaunchPad?

@mikecorleone90 wrote:

Can anybody help us?We want to know the correct way to remove the U3 LaunchPad?

What’s wrong with either of the 2 methods in the top post of this thread?

I have over 50 units of the Cruzer Enterprise FIPS edition 2GB and I cannot get any of them to format into a single NON-partitioned flash drive.  I am using a Windows 7 Machine and none of the software I’ve downloaded and tried (regardless if it’s made by Sandisk or not) has worked as I need them to.

When I run the launchpadremoval.exe program I get a critial error:

“The program has encountered a critical error and must exit. Please try again. It the problem persists, contact SanDisk’s support center.”

All I want to do is remove the Launchpad software and use these like regular flash drives.

You need to remove the software by plugging the USB devices into an XP machine, real or virtual doesn’t matter.  They are obviously old, since SanDisk stopped making U3 devices 2 years ago, and were never updated with the Windows 7 version of Launchpad.

Depending on how old a version of U3 your devices have the Launchpad menu itself may contain the option to remove U3 from the device.  Nothing to download, nothing to install.

On Windows 7 machines you may need to run U3 in Vista SP2 Compatibility mode. 

And if it does run, why delete it?

it is because i had reformat  my sandisk cruzer blade 8gb already i can’t seem to find the lauchpad setting orwhen i run the launchpad removal nothing happen.

i just can’t see access the folders on my macbook pro…all my folders ends with .EXE, when click to open all i see is strange wordings

Yeeeee, it works :smiley:

Where did you find the old U3 drive?  Personally I love my U3 Launchpad.

Follow these steps to remove the U3 LaunchPad:

  1. Open the Launchpad menu, and click “Settings”. You need to select the “U3 Launchpad settings” 
  2. Select  “Uninstall” option in the left-hand navigation and click “Uninstall U3 Launchpad”
  3. Select restore files option (unless you want to completely wipe the drive)
  4. Click “Next”
  5. Uninstaller begins the format process
  6. Your Sandisk will now be free of Launchpad

Now your U3 LaunchPad has removed. If you lost SD Card data and want to recover it. Visit: https://www.dataretainers.com