Failure Readind The filesystems file (err=1)

I recently (today) got a 32GB Cruzer Glide. When setting it up, i had typed in the password and only had to confirm it to have it be completed. I had gotten sidetracked, and thought that i had already set it up (which i hadnt), and took it out. After realizing that the password setup was still open, i plugged it back in. It now acts like its set up and asks me to log in, but uppon logging in i get the error “Failure Readind The filesystems file (err=1)”. Anyone know a fix, or is it just doomed and i have to buy another?

Delete all the files and folders on the drive.  Download SecureAccess from the SanDisk Support site.  Move it to the SanDisk drive and execute it.  That should give you a fresh start.

I am getting this same error message.  I have been trying to backup files off my laptop and ran out of space on the thumbdrive.  Ever since then I have been getting error messages.  I have tried to delete all of the SecureAccess files (left the original vault) and reinstall.  It did ask me to enter in the password for the original vault, but I still get the error.  

Any ideas?


Try running a CHKDSK command on the drive.  If that doesn’t resolve the problem delete the vault and starting over is the only option I’m aware of.

I am on a Mac, so I ran “First Aid”.  That didnt work.  I guess my files are lost at this point?

Unfortunately at this point I suspect so.  If the files are very important and you have no backup you could try taking the drive to a pro shop for help.

did you find solution. I am in same boat. Trying to rebuild my DRIVE, first I had archive path issues, past that now I am having Failure Reading Errors. I need elementary instructions too. All help appreciated. Thanks-Brandy