Failed to connect to iXpand Drive iPhone 7 and iPad Air 1,iOS 11


I have iPhone 7 and iPad Air 1 OS is iOS 11

After install apps the devices show message “Failed to connect to iXpand Drive. Please remove and reattach.”

I try remove and reattach but has the same error.

But it’s work on iPad Air 2 iOS 11.

Please help.

Have you reset the iPhone 7?  There are two know issues with iOS 11. These are not isolated to the iXpand product and affect all devices from all manufacturers in this product class. We have opened a ticket with Apple regarding both if these issues. 

  1. In iOS 11 it may take up to 30 seconds for the iXpand to be recognized by the iOS 11 device. this issue is somewhat intermittent in nature but may occur up to 50% of connections. The work around is to wait 30 seconds after connecting the iXPand Drive to an iOS 11 device. 

  2. Drives will not be detected are after an iOS 11 device has been reset. the work around for this issue is do not reset the iOS 11 device after updating to iOS 11. 

If you have reset the iPhone 7 and are now facing this issue you may need to downgrade to iOS 10.3.3 test the iXpand device to ensure it is working then perform the upgrade to iOS 11 again and ensure the iOS device is not reset after upgrading to iOS 11. 

1 Like

Hello slotmonsta

My iPhone 7 reset after upgrade.

In my case iPhone 7 (iOS 11+Reset after upgrade) can detect iXpand but can’t connect.

Thank you

you may be able to downgrade to iOS 10.3.3 and then re-upgrade. See instructions below. 

Thank you drlucky.

I purchased this product for a few week, firstly I used with iOS 10.3.3. Few days later, Apple release iOS11, then I upgrade.

I have the same problem after upgrading to iOS11. Even now, I upgraded to iOS11.0.1, still doesn’t work. I check firmware, it is up to date. I did try uninstall & reinstall, do power-cycle (turn-off and turn-on), close the app by swiping up. Still doesn’t work.

the link to downgrade iOS to 10.3.3 is not available now. 

I have contact tech support, they said just wait for Apple to release the fix, which has no confirmed date yet. In fact, Apple just release iOS11.0.1. It may take quite long time to have a new release of iOS.

Can Sandisk Developer fix it by Firmware, or iOS app rather than waiting for apple, which is out of your control.

I want to have a refund if not possible.


I have a similar issue, but the suggested solution will no longer work for me as Apple already stopped signing iOS 10.3.3 therefore downgrade is no longer possible. Any other possible workaround for this issue?

I’m hoping you could help me. Thank you.

badly needed solution for reset iPhone 7+ on iOS 11.1.2

that is an iOS issue. from what i have read on some other forums the issue is resolved in the iOS 11.2 beta.