External Memory: Showing as empty

The external memory is on MSC mode, and I can drag and drop files across with no problems.

However after the Sansa Fuze does the ‘refreshing your media’ and I navigate to the external card folder it shows as empty.

I have tried taking the card out, putting it back in, turning off/on etc with no luck

Any ideas would be appreciated, thanks. 

With the Fuze still connected, can you play the music through your computer from the card after you transfer it?

Have you tested the card to make sure it is not a fake?

http://sosfakeflash.wordpress.com/2008/09/02/h2testw-14-gold-standard-in-detecting-usb-counterfeit-drives/

Message Edited by Black-Rectangle on 08-14-2010 08:38 AM

Hello, yep I can plays songs via the card after I transfer it and the card is not a fake.

Offhand, I can think of four possibilities:

  1. You did a firmware update after transferring the files. Updating the firmware resets the USB mode to “Auto-detect”, which defaults to MTP mode when possible. Files transferred in MSC mode can’t be seen by your PC when in MTP mode, and vice versa.

  2. You need to change your Windows settings to “show hidden files and folders”.

  3. You’re looking in the wrong folder.

  4. If by “I navigate to the external card folder it shows as empty.” you mean the Fuze (not your PC) can’t find them in “folder” mode, they may be in an unsupported format.

No none of those.

It suddenly started to work againe after I added a couple more MP3’s, it seems to be a problem with indexing the files after something new has been added, seems odd why it would work sometimes but not othertimes though and is a quite irratating bug.

Are you sure the files are .mp3, .wma, .aa., .flac or .ogg? It’s not going to read .aac or mp4 from the iTunes store.

Indexing problems can also be caused by ID3 tags, the electronic labels in your files. The Fuze is (too) picky about them: It likes ID3v2.3 ISO-8859-1. 

You can fix tags fast with the free mp3tag from http://www.mp3tag.de/en/

Install mp3tag.  When you install, let it add itself to context menus (an option while installing).

Open mp3tag and in Tools/Options/Tags/Mpeg make the Write option ID3v2.3 ISO-8859-1.

Right-click an album folder before you send it over, and highlight all the files. I suggest under Tools you use the Auto-Numbering Wizard with Leading Zeroes, which will number the files from top to bottom (make sure they are in the right order) as 01, 02, 03 rather than 1/12, 2/12, etc., as some ripping programs (hello iTunes) do. With track numbers like that, the Fuze will play 1, 11, 12, 2, 3, 4, etc. because it reads the first digit. 

Run the wizard, or just Save the highlighted files if for some reason you don’t want to fix the track numbers, and since you have set the default they will be ID3v2.3 ISO-8859-1. No more tag troubles.