Express doen't start. [edit] IT'S ALIVE! IT'S ALIVE!

Hi! Surprise, surprise, my express doesn’t work :stuck_out_tongue:

Ok, step by step of what happened:

  1. battery ran out and the device turned off

  2. when pressing the on/off button didn’t do a thing instead of showing the empty battery pic

  3. when connected to PC the loading animation on the express would lag and display incorrectly

  4. internal memory showed as completely empty through windows explorer. Formatted it. Didn’t help any.

  5. when turning the device on, it went past “bulding database” ant the logo, then simply turned itself off in a few secs (while refreshing SD)

  6. with SD removed the express turned itself off right after the logo

  7. during the 4 previous points the battery indicator was offset to the side and partly offscreen

  8. tried upgrading the firmware, everything went as should until this happened:

  1. now the device won’t start at all. tried running the updater again, gave the same error every time.

Any ideas as what to do would be greatly appreciated.

P.S. Sorry for my english, I know it’s not terribly good.

EDIT: I did it on XP 32bit with the device in MSC mode as “player recovery class” or something using the updater from this forum with 01.01.12a firmware

Message Edited by johnyo on 04-29-2010 02:43 PM

Message Edited by johnyo on 05-21-2010 07:56 PM

Message Edited by johnyo on 05-21-2010 10:22 PM


I’ve gone and done it! I’ve debricked my Express!!!

Long story short (or not so short):

I tried updating using the older 01.01.05a firmware and it worked, but the Express still didn’t show up in My computer (In Device manager it showed up as MTP device, but it kept refreshing constatly) and the screen of the Express remained blank (and black).

So I gave up and went home (as I did all this on my friends computer, since my XP SP2 simply refused to install the STPM3600 driver no matter what I tried).

I was pleasantly surprised to find my Express worked perfecly well on my PC now, I could even install the recovery class thingy (was it ‘device’ or ‘player’?), so I ran the updater using the 01.01.12a firmware and it worked.

I’ll add that I did have to format my SD (Sandisk 8Gb MicroSD HC) via a card reader, because it crashed my Express while it ‘refreshed SD’ (by crashing I meant to say the Express turned off) when I first inserted it back (I had taken it out, since my Express stopped working and hadn’t used it since)

Bottom line: if something doesn’t work on your PC, go try it on another, if it doesn’t work there, try another… (my guess would be it is like that because of other removable device drivers (flash drive, mobile phone, bt adapter drivers) which may or may not interfere with the Express while it is bricked)

P.S. I read somewhere on these forums, that holding the (-) button all the time while running the updater works. It certainly didn’t help in my case.

Message Edited by johnyo on 05-21-2010 10:20 PM