Error 18 with firmware update

SanDisk SSD dashboard, unable to update firmware error 18. What does this mean and how do I fix?

Trying to go from X41200RL to X41310RL. When trying to update it says; This operation failed with error code:18.


1 Like

Same here on Supermicro Desktopwith a Ultra II 240GB.   This is not on a raid, but on Sata controller…

Interesting to note that I have already upated Ultra II  560Gb drives in a raid array on same controller… so…  . 

Laptop with 960Gb went fine, so…

As a follow-up to my prior post about the Error 18 report on the firmware update:

System here is a Supermicro X7DA8+ motherboard, with Intel ESB2 Sata Raid Controller (SATA II Speed) Running W7-64

Drive in question is a Ultra II 240Gb on the controller as Disk 3 (Not in a Raid) with X4110RL firmware…

Have fun SanDisk…     

Now if my prior request (For Release Notes) had been granted, I might now be saying that since the Intel controller is only a SATA II speed device… That I don’t need to worrry about the upgrade…   But I wasn’t told that, so I request that you fix the problem…

Tick Tock!

I replied to the answer to Support stating that there would be no release notes forthcoming that my 2nd system had the Error 18, and requested a fix for it.

I’d suggest you do the same… You might post your system info here so others can read it…

Please provide the following information for us to research on the firmware update error: 

  1. Is the SATA mode in BIOS set to legacy (IDE)/AHCI/RAID?
  2. What is the host – Intel/AMD?
  3. What is the driver? Intel/MSFT? Driver version?
  4. Is this a primary drive or a secondary drive?
  5. Drive model string?

W7-64 24GB Ram

  1. Is the SATA mode in BIOS set to legacy (IDE)/AHCI/RAID? IDE mode (only Raids get AHCI on this controller (Intel ESB2 Sata II)

  2. What is the host – Intel/AMD?   2x Quad Core Xeons (Supermicro X7DA8+ Motherboard – Latest Bios)   

  3. What is the driver? Intel/MSFT? Driver version? Intel ESB2 Sata II dated 8/6/2010 Ver

  4. Is this a primary drive or a secondary drive?  Secondary  (Boots of 15K 320Mc SCSI, SATA II has: 2 Raid0’s (Once Spinning Drive, one SSD [2x SanDisk Ultra II 480GB that have current firmeware]), 1x 1TB spinning drive, The 240GB SSD in question) 

  5. Drive model string? According to Dashboard:  SanDisk Ultra II 240GB  (serial number on request)

I am in correspondance with SanDisk Support over my Error 18 isse…

I suggest that others do too.

I’ll post responses…

Thank You

Aparantly Dashboard won’t firmware update unless controller is AHCI…

Kinda defeats people upgrading their old laptops, doesn’t it?

Let me see if I can understand this answer correctly…

SanDisk Is either: Turning a blind eye to hundreds of thousands of potential sales to older systems with NON AHCI controllers…


SanDisk is intentionally alienating hundreds of thousands  of customers after they purchase a SanDisk Ultra II drive and Dashboard tells them there is a firmware update needed, but fails in the attempt to upgrade it… Due to short-sided-ness by the company’s own Software Writers???   



So, your either ignoring lots of sales, or you’re ignoring lots of end users, OR BOTH, and neither are good for your bottom line or Your Reptutation…

Wouldn’t the prudent approach be to kick the Dashboard Software Writer’s in the butt and get them going on an update to Dashboard that will increase your bottom line, AND Your Reputation???

It seems far too obvious, to this end user, Who prefer’s SanDisk Ultra II drives over other MFG types, and has said so in multiple forums!!!


P.S. to this post:    Are you aware— That Ultra II Drives on AHCI Raid controllers DOES Successfully work with Dashboard Software???  Please don’t break that!!!

Please Respond!

Was hoping that SanDisk would respond to the comments in prior post…

Are you listening to us end users, or ???

Currently our firmware update feature only works under AHCI or RAID, I think that is the reason you are seeing code 18

Hopefully you will address this in the near future… As this will alenate a lot of people with older laptops who are looking to breathe life into them with this update!

Just want SanDisk folks to know that in  2 weeks I’ve updated 2 laptops without AHCI Interfaces!!! 

And one with AHCI interface…

Please work on update so that Dashboard supports legacy controllers… (for future firmware updates!)

Thank You…

I have tried to update my firmware using both AHCI and RAID but i still get error 18.

I’ve tried to use the boot from CD Live Image feature and this also failed.

I even booted my old cloned drive and try to flash the SSD but still wont work.

Is there any news on a fix for this?