Erratic Behaviour

I’ve had my Fuze about 2 years. It has just started behaving erratically.

Sometimes when I switch it on it freezes with the blue light  the windows-like logo.

Sometimes it’ll come on ok but when I try to play a song the scroll bar moves, the seconds tick but nothing comes out of the headphones & nothing happens when you try to skip to the next track or a different album. Then all of a sudden it’ll scroll quickly through each song on the album without playing any of them & freeze when it reaches the end of the album.

Sometimes this happens randomly after several songs.

Usually when it plays up it won’t switch off via the switch.

Occasionally it plays as it should!

I’ve tried updating from version 02.02.26A to 02.03 but that hasn’t made any difference.

Anybody any ideas or is it time for the bin?

Look at the files.Something is tripping up the Fuze.

Skipping through the files may mean that the album was ripped on a Mac, which adds an extra folder called MACOSX to the album folder. In that folder are Mac finder files–with names like ._01-Track01.mp3–that are 0kb in size. The Fuze sees .mp3 and tries to play them but there is nothing there.

If you look into the album folder, you can delete MACOSX from the folder. Also look in the remaining folder and you can delete DS_Store if it is there. That’s just for the Mac itself.

Albums ripped on a Mac can also use a different kind of encoding for the characters in the tags, hard for the Fuze to read. Could stall it while starting.

Get mp3tag at

When you install it, allow it to add itself to context menus.

Under Tools/Options/Tags/Mpeg set Write to ID3v2.3 ISO-8859-1. That’s the Windows encoding the Fuze likes.

Right click on the album folder, highlight them all and Save them. That will fix the encoding.

If you want to make it even more Fuze-friendly, make sure the tracks are listed in playing order, and highlight them all top to bottom.  Under Tools, use the Auto-Numbering Wizard with Leading Zeros, which will change the track numbers from Apple’s 1/12, 2/12, to 01, 02, etc.

I have the same problem.  But only with music on the Sansa itself. Files on micro SD card play just fine.

My music didn’t come from Mac. Looks like Sansa flash memory is failing (?) as the problem started after playing all the files for couple of times and then suddently, it couldn’t play music anymore.

The files have been ripped on a mix of Windows 7 and Windows XP using the Media player. No Macs involved!

Well, the default behavior of Windows Media Player is to rip tracks as protected (meaning they have DRM restrictions) WMA files. Normally, this isn’t a problem, as Sansas (most of them, et least) support that filetype. But if something goes wonky with the player’s “secure clock”, the player will just skip past them, as you describe. You need to either fix the clock issue or change WMP’s rip settings and re-rip your tracks in an un-DRM-crippled format. Doing both would be even better.

Sometimes things can get discombobulated over time. You could try formatting your player, which will erase all content and optimize the memory clusters. Of course, this means you’ll have to re-load everything, but formatting has been known to correct un-explained erratic and irrational behavior before, so it’s worth a shot.

How do I fix the “clock issue” and also change the settings for ripping?

Would formatting the whole thing be easier?

@jules100 wrote:

How do I fix the “clock issue” and also change the settings for ripping?


Would formatting the whole thing be easier?

I’ve never had to do it myself, but I’ve read that simply transferring any file to the player with WMP will set the clock, as long as you have an active internet connection.

To change WMP’s rip settings, go to Tools>Options>Rip Music.

Assuming that reformatting would reset the clock (I don’t know that it would), yes, it would be easier. But that wouldn’t prevent the problem from recurring if the clock should glitch again. Avoiding using protected files would.