Entry Point Not Found

When I ran my SanDisk Cruzer 16GB it asked me to update. However now I am unable to open secure access but it does give me an error window, hopefully someone could tell me what this error is. Entry Point Not Found The procedure entry point dmAPP_isUnlockedVIDPID could not be located in the dynamic link library dmBackup.dll. Thanks.

Same issue with mine mate,  I’ve got alot of data locked up so I hope I haven’t lost it…

Sorry to hear that man, but seems like no solution yet. I been thinking about this error and I’m going to try a fix tomorrow I’ll let you know if it my guess works.

Yikes, I came here hoping for a solution, as well!  I guess maker does not have any suggestions?

I have the same problem… and SanDisk no have solution for us.

Good news all! I think I solved this issue. 1) Back up all you data. 2)In your root folder there should be a RunSanDiskSecureAccess-Win.exe <<< the one we select to access the Vault. 3)Go to SanDisk homepage and download a new SanDiskSecureAccess.exe (Here is the link http://kb.sandisk.com/app/answers/detail/a_id/2399)) 4)Delete your old RunSanDisk…exe (the one that gives us the error message. 5)Drop the new RunSanDisk…exe that we download at step 3) 6)Now all should be good. My password was the same and all the file in the vault are still there too.


  When I click your link to reinstall " Sandisk Secure Access", the link says:

"Permission Denied

Illegal parameter"

Is there any other way to restore the .dll file without instaling any other .dll restoring Softwares?

P.S~ This only happens to me after I update the Software. However if I restart my Computer, the updated version gets replaced by the old one again!

Reply soon

Great News guys, i found a way to recover everything without any issues.

Follow these steps and it will be back like new:

  1. Backup all your data (Including sandisk secure access application and backup data ie.everything) to your Pc,Mac etc.

2)Format the device to NTFS and set allocation size to default.

3)After format is complete,copy the backup and secure access application back onto your pendrive.

  1. Start the application and it will open without any problem

NOTE: it may take some time to open depending upon the system

The password for the login is the same that you had kept before.No changes will be there and even all the data in the vault will be present without any data formatted or erased!!!

ENJOY!!! :slight_smile: