e280 acting up: no disk in drive, no songs, no nothing

My e280 started acting up more than two weeks ago, and after rummaging through this and other forums, I give up. I need help to solve this. I have a V 01.02.24A.

Things my player has been doing:

»The computer does not recognize the two drives. They show up but when I try to  open them it gives me the “Please insert disk into removable drive F:” and same for G: . “Open as portable device” brings up an empty folder, but I can’t copy onto or alter it in any way.

»The MTP driver software never succeeds to install. Not a single drive even shows up in this mode.

»Memory= 0MB, Free= 0MB and it tells me to “not enough space for Music DB. please free 6mb”

»sansaupdater.exe tells me No Disk: "There is no disk in drive. Please insert a disk into drive \Device\Harddisk1\Dr12 " then repeats with “DR13”. Though I think the numbers in front of “DR” keep changing. Also the updater is incredibly annoying since it keeps trying to find the drives every 30 secs! I had to TM end process.

I formated the drives after uninstalling and reinstalling them at least a couple times through device manager.

chkdsk does not identify any problems.

I tried defragmenting it but I can’t figure out a way to defrag just the drives. But defrag seems to be doing nothing even with C: when I promt it.

I used recovery mode at least 3 times to put the firmware in the player (e200v101.02.24a with files PP5022.mi4 and BL_SD_boardSupportSD.rom). I get no errors when I do this. Yet  the player still doesn’t work, and next time I go into the mode the files have evaported!

I’ve also held the power button for more than 20secs hoping to reset it, but that seems to get nowhere as well.

I first got these problems after I tried removing some old music files that were not showing up on either MTP or MSC mode, but would still play (and therefore take up a lot of space).

From the forums I got the impression I might have more than one problem going on, since the solutions only led me a little bit until I ran into a problem somebody else had run into, but not the original poster.

So if anyone can help me revive this player I’d much appreciate it. The player played fine before, and except for not letting me delete the older files it even let me add some more files on there.