e200v1 01.02.24 Firmware Download & Instructions

Thank you sooooooooooooo very much it worked out well:)

Does this firmware support  sdhc or not.  I love my player and it works for all it’s intended uses.  but i’d like to add 8gb of memory or more and this only comes on sdhc cards…pls advise before I buy one.

@bpp456 wrote:

Does this firmware support  sdhc or not.  I love my player and it works for all it’s intended uses.  but i’d like to add 8gb of memory or more and this only comes on sdhc cards…pls advise before I buy one.

 

 

No.  None of the firmwares for v1 players support sdhc cards.  You are limited to a 2 GB card with v1 players, unless Rockbox firmware is used.  Only the v2 players can use sdhc cards natively.

Tapeworm, don’t you remember it was electronic techs that invented the word: Gremlins.

Hi, I cant get the updated firmware to update my sansa e260v1 I dont know where the root file is to put the unzipped file into.

Any help would be greatly appreciated im not too pc literate thats why Im having problems with it.

Thanks in advance

Brian

Hi

 

I have an e280, which has been great except for the upgrading thing. I don’t know if there’s any real need but it’s frustrating that it won’t do what it’s supposed to. Whether I use the updater or the direct copy method as per your excellent instructions, the thing refuses to update. It’s stuck on 01.0.07E and won’t accept anything else. I’ve used 3 different PCs, XP and Vista and all fail in the same way. The screen on the e280 says “Writing” then changes to “Connected” after the transfer but when I disconnect (either correctly from USB or by brute force) it sits there saying “Disconnected” and nothing happens. Eventually I give in and hold the menu button down and start again. It reloads the database but the version is still at 07E. Does anyone have any suggestions please? At least the damned thing still plays music but I’m losing patience.

 

Many thanks

N

Me again, just realised I put the version incorrectly. It’s actually 01.02.07E. And it doesn’t have a v1 at the front, I’m guessing that isn’t the significant element.

 

Thanks

N

After the upgrade to v1 24, my FM radio vanished from the menu. I need that radio. what can I do.

@gideon wrote:
After the upgrade to v1 24, my FM radio vanished from the menu. I need that radio. what can I do.

Did you install the correct firmware version for you geographical location? There are 6 different versions.

Is this firmware update a Good Thing?  There were a couple of negative comments but not much other discussion about whether people found the changes, good or bad.

Most of the shall we say ‘more experienced’ users with v1 models here either reverted back to the previous .18 f/w version, or never updated to the .24 in the 1st place.

Does that tell you anything?

@gideon wrote:
After the upgrade to v1 24, my FM radio vanished from the menu. I need that radio. what can I do.

I think there is an F version with FM for European users.  The E version doesn’t have the FM tuner support as a means of Sandisk avoiding some sort of European tax or tariff or some such on imported radio tuners.

I am a happy user of e280 V1 with version 01.02.15A.

The only nick is that I have some song titles that are in Hebrew, which are looking ok on MS Media Player but spelled backwards on the player i.e. Sansa does not support the right-to-left direction.

I have resrearched this forum and found a lot of info (- Thanks !!!) :

-I understand there will be no fix to that on any official Sansa firmware (since there will not be any), I can choose to move to RockBox firmware. I second all the proposed features in the wishlist thread.

  • I do not agree with the comment made of treating the player as as-is. I certainly decided on Sansa versus iPOD for new features support. Whenever you make a decision to buy a gadget you know you are already been left “behind” on the newest trends. I did not expect Apple to try to update older players but I certainly expected Sansa to.

  • I understand the popular version is 01.02.18A (I saw a lot of issues posted with version 24A).

  • Nice trick with half plugging the USB to get power but not “connected” so the player plays while recharging. Thanks it bothered me to.

  • Stupid language support: why would one want to move firmware for other languages ? didn’t anyone in Sansa heard about globalization ? lots of people listen to musics in other not-supported languages (Asians and Hebrew) while in the US (do not wish to change the menus language or fm support).

I have several remaining questions:

  1. What is the diff from 15A to 18A? - I’m trying to determine is it worth the upgrade hassle.

  2. RockBox has nice options for V1s. Can you list them all? - Will that have the additional languages support i was looking for ?

  3. I saw some guru comments that there are “issues” with it.  Can you be more specific on what these are ?  i.e. I’m trying to understand the “price” for the move. I saw the comment about forgoing warranty when switch to RockBox - but what warranty you have on V1 anyhow ?

  4. How easy is it to move from RockBox back to Sansa firmware ? I saw a comment that both can reside on the player and can be toggled between. Can you detail how to set that up ?

  5. Whom are behind the RockBox version ?  Is there any posted plans for the next versions ? Hoe serious this open firmware project is ?

Thanks,

   Regular User

Anyone know when they are going to release another ver. ?

Or are they abandoning it?

Abandoned.  Orphaned, even.

Message Edited by 1shado1 on 06-03-2009 10:07 PM

The e200 series is discontinued, but that’s from a production standpoint.  The Sansa Fuze has taken its place in the current model lineup.  There’s nothing wrong with the e200 as it is, in fact, it’s a solid machine.

For the version 1 devices, firmware versions “18” and “24” are the stable releases of choice.  Some have had issues with the “24” release, opting instead to stay with 18.  Both firmware versions are available here.

Next door, in the Sansa Rhapsody forum, the latest firmware for the R series is available.

For the version 2 devices (“03” as the first two digits of the firmware) with the AMS processor, the 03.01.16 version binary is the choice.

Bob  :smileyvery-happy:

I got a message on the screen when I turned it back on: “Load main image failed.  Switch to recovery mode”

How do you switch to recovery mode?

thx 

Recovery Mode is a special mode allowing direct access to the reserved partition of the Sansa’s memory, for repair of the firmware.  The “main image” referred to in the error message is the firmware.

Be very careful that you DO NOT ATTEMPT USING THE WINDOWS FORMAT COMAND ON THIS PARTITION.

Download the two firmware files in the beginning of this thread, unzip them, and place the pp5022.mi4 and BL_SD files on the desktop.

On the Sansa, start with the device OFF.  Slide the HOLD switch atop the device to the right (orange showing).  Press and hold the REC button on the side, keeping it depressed while plugging in the Sansa to the USB port.

Open a Windows Explorer window by going to My Computer or use the shortcut [Windows Key] + E.  You’ll se a new icon labeled 16MB FORMAT.  Again, DO NOT attempt formatting this with Windows, as it will remove critical data.  Double click on the icon to open the partition.

Drag and drop the two unzipped firmware files into the partition.  Now, right click, and select eject.

Slide the switch back to the left (Hold OFF), and unplug the cable.  Your Sansa will announce “firmware upgrade in progress”, and you will have a happy restored machine!

Bob  :smileyvery-happy:

I was able to restore a working firmware using 1.02.165 using the recovery information posted elsewhere here.

Message Edited by modeltom on 07-20-2009 12:51 PM

Hi everybody,

from one day to another my Sansa doesn’t play the music anymore (videos play). I get a start screen saying that there is not enough space for the Music-DB and that I should clear 6 MB (according to my PC I have approx. 160 MB free space). Sansa also claims that the music folder is empty. But when I connect it to the computer I can see that the songs are still there. But some folders (music, pictures, playlist, system) are marked as “hidden” whereas the video folder isn’t hidden. So I marked all those folders as not hidden and then disconnected and re-started the player but it’s still the same. After connecting it to the PC again the previous folders are back again to “hidden”.

I already downloaded the firmware but it didn’t change anything. I’d be really glad if anybody had an idea. Thanks a lot!