drive will no longer mount on mac

I just got a Extreme portable ssd and I put some files on it from my imac and plugged it into my macbook pro and I was using a file on it and the drive unmounted and I couldnt get it to remount. Opened disk utility and it faintly showed the drive but I couldnt do anything with it, Anyone know what to do?

1 Like

I have exactly the same problem. It wont mount on mac and pc.Have you found a solution?

Plugged into different PC and it worked…and then back into same Mac and it worked. Also saw there were chats on Apple support community and even videos on youtube talking about exFAT working / not working with MACs. If the issue replicates I will update. 

Have you tried flipping the cable? Just flip one end on the computer side.

It’s supposed to be reversible but in my case, sometimes it does not work.

Or try another cable.

facing the same problem here

I have found if I keep it connected it will show up again, but for me eventually the same thing happens and again I stop working and wait for it to remount. I have the same problem with a Samsung t5 drive

Same problem here. The SanDisk Extreme SSD just unmounted and cannot remount. Only 1 week of use! I’m about to loose a ton of data if I have to format it! I’m desperate!

Same problem here… Drive appears in Disk Utility but doesnt mount. Fails to repair too.
Bought about a week ago.

For me two days later it started working again. I don’t understand but I’m good now


I have the problem - all of a sudden my SSD won’t mount and has lots of data on. Did anyone find a solution to this? Is there anything I can try?