Drive will no longer mount on mac

Now I finally found a solution (only on ExFAT format):

  1. Connect your SSD to your computer;
  2. Run Disk Utility
  3. You will see greyed Extreme SSD there and with two-finger click, choose Mount.
  4. Now you must open Terminal.
  5. Type exactly this: sudo pkill -f fsck
  6. Type your login password

After that, you will be entered in a read only mode. Try to back up all your files, then format it and try another brand’s SSD. At least, your files will be safe.


Yep, after running the above workaround, I’m returning my SanDisk. I can recommend Samsung’s T7 - it has fingerprint pass too works great with my Mac. Shame SanDisk can’t even be bothered to reply and address this issue.

@bmamukashvili solution worked for me as well.

I recently got this issue. Please give me the way to solve this issue.

Mine at the step 3, there was no ssd drive show.

What should I do then?

Got the same issue. Did you find a solution?

Hi 2022 comment and solution here (for me)

I basically had the same problem with mine.
It showed up in Disk Utility with a name (eventually) but it stated it was not mounted, so I could not perform any actions.
I have a macbook that has a windows 10 bootcamp option.
I booted it up and connected the drive.
Windows stated there was an issue with the drive and it needed scanning and repairs.
I let it execute it… it took a bit (2TB drive about 12 min containing a relative small file)
After it was done I connected it back to my mac and it worked again.

Dunno what it was eventually but it worked …

Yes I did, see my comment :wink:

Our SanDisk SSD stopped working all of a sudden on our Mac as well. We couldn’t see the drive in Finder and it didn’t work anywhere. We checked Disk Utility on the Mac and it showed a faded SSD name and reported as “Not Mounted”. However, when we connected the same drive to a Windows PC, all the files were intact. I think we could have scanned the drive and been able to Restore it to its default way but we opted to copy the files out, format it and get it to work again.

I have exactly the same problem. Did you happen to resolve it in the end

Just wanted to say THANK YOU, it worked! My 1 TB Sandisk SSD stopped working (maybe that’s the cable? no idea so far). Installing the Disk Drill helped! Thanks!!!

@ bmamukashvili it also worked for me. Thanks. :slightly_smiling_face:

Worked for me as well. I had to remove the password on the drive as well, then it formatted and all was good.

I could safe all my files with Disk Drill, but could´t mount the ssd. Not via Disk Drill, not via Terminal, not via Disk Utility…nothing worked.

The only solution that worked was:
I connected the ssd to my phone, formatted it.
First it did not format, tried a second time it succeeded.

Then plugged back to my mac m1 and erased again to APFS and all is good now.
Let´s see how long!

Everyone! Go to Activity Monitor, under Disk tab search for “fsck_****” where **** is whatever your drive type is. Anyways force quit it and you’ll be gucci💋

The firmware update tool is now available.

1 Like

Connect the Extreme portable SSD to a different USB port on your MacBook Pro. This can help determine if the issue is specific to a particular port.

1.As someone who has experienced a similar issue, I understand how frustrating it can be to face data loss due to a broken SanDisk Extreme SSD. However, there are solutions available to help recover your lost data.

2.To learn more about official solutions to this issue, I recommend visiting the SanDisk website or reaching out to their customer support team for assistance. They may be able to provide you with specific steps to recover your data or recommend a professional data recovery service.

3.Additionally, you can visit the following guide page to learn more about how to recover your data on broken SanDisk Extreme SSDs: SanDisk Extreme SSD Failure: Tips to Prevent from Further Damage This page provides detailed instructions and tips that can help you recover your lost data. I hope this information helps you to resolve the issue and recover your important files.

I purchased a San Disk Extreme Pro Portable SSD Model Number SDSSDE61-1T00, from Costco, November 2022. I have used it multiple times every week since then now it will not mount. I have tried different cables and 3 different MACs. Is there a solution to this problem? Or should I send it to SanDisk for a replacement?

Thanks for the advice but I have tried to connect it to 3 different computers and it will not mount on any of them.