drive constantly loses formatting

I have a SanDisk Cruzer Glide 8Gib 2.0(high speed) pendrive that keeps lossing the formatting (FAT 32). Tried to rebuild MBR, but that hasn’t helped. Any idea what’s going on and how-to repair it? Also, when original, drive showed 7.45 Gib available, after recent formats it shows 7.43 Gib. When queried, it shows “nothing” on drive??? Ran sector check and all came out 100%.

:manfrustrated: Rick

What are you using to format it?


    I’ve used GParted, Window 8, and a program by AOMEI. So, it’s not the programs.


Do each of the apps formatting it finish to completion?  And indicate the drive is formatted?  When you remove the drive to use it someplace else do you use the Windows’ Safe to Remove function?  Is Windows configured to use the USB drive Safely or for Performance? 

Or there’s always this solution. :wink:

RE: _ Ed_P _

To answer the questions you posed, YES to all. Have you or anyone else had or heard of such an 'issue"? I’ve went about many forums/help sites and haven’t seen the sort of problem this drive is experiencing. SanDisk contacted me and didn’t offer a “solution”, but rather said I could go through the replacement procedure if I choose. I’m certain they will not replace it for I’ve tried to do so before and they reneged. And, yes, I’ve went through Sandisk’s “programs” and really, they don’t have anything to offer, in fact, most the 'their" repair programs are from other competitors…i.e…HP and subsequent third party apps/progams.Back to the pendrive’s issue…at this point it seems doubtful I’ll be repairing it, for no one seems to know what the problem is and thus how to repair it…if possible. As most suggest when it comes to repairing a pendrive, “ditch it and go get another”. YES, our 'throwaway" society.

Thanx for Responding.

:wink: Rick

It’s not a “throwaway” society solution, it’s a “how much is my time worth” solution.  You can spend 25 hrs looking for a fix or spend $5 and have a solution.  $5.00 / 25 hr = $0.20 hr.  The more time you spend the less your time is worth.  You decide how much your time is worth.

1 Like

Yeah, but you don’t bother telling people the whole story, from those other forums. You neglect to mention that you’ve had this drive for YEARS, and have been running a full-bore Linux distro from it. Including home, swap, and boot. What you HAVE been told (repeatedly) is that the number of read/write cycles it’s been through, along with DOZENS of formats, has led it to have problems. 

THIS is why your drive is failing and having errors, because you trashed it by being stupid. If I drive my car into a tree, I shouldn’t complain to Chevy that it’s not working right and has dents. 

The real “problem” is you and how you’re using the equipment. And SanDisk can’t help with that.

Re: jrustler (jerk 56)

 I don’t know where you came up with your accusations, but you haven’t a clue as to what your saying! You don’t know how “old” this stick and/or how it’s been used. What kinda idiot comes on a forum and babbles such incoherent drivile?   Oh…you do “jerk56”!!!  This idiot is a cyber-stalker and hasn’t a clue as to what he’s talking about. What an immature clown!!! The 'real problem" is you, the pathetic excuse for a human

RE: Ed_P

    Thanx for replying. I still don’t know what’s causing this drive to lose formatting. Makes one wonder, doesn’ it. I’d never heard/experienced this “issue” previously. Yup, probably time to give this drive a proper burial. But, for my own , I’d love to have an answer to this. Take It Easy!

If I wanted to accept anything you had to say, I’d call your theapist for consultation. You are an ill-informed, immature, unhinged adolescent. One who follows someone around on the “net” and never offers any coherent advice or help is a fool…at best. You are extremely sick and in need a psychiatric evaluation. Better yet, do us all a favor and take your toys into the nearest busy traffic inersection or major highway. 

BTW…we all wish you WOULD drive your car into a tree…at a very high rate of speed!!! BTW **bleep**…this is a completley different drive…the one w/ linux STill has linux on it and is working…gawd…has anybody told you want a complete ass you are…oh, yes…on a daily basis!!!

Hi Rick,

Your format problem is strange to say the least.  It could be a bad area on the drive where the MBR must be located, a worn contact point on the drive or on your pc’s USB port, malware on your pc attacking USB drives, low power from your power supply, etc, etc.

Try formating it on a friend’s or neighbor’s pc and see what happens.

As for arguing with people that like arguing, ignore them.  They’re looking for attention and ignoring them is the best reponse.