Dried wet Fuze, now it won't charge.

Misplaced my beloved Fuze for months and had to drive with the radio. (Ick!) I eventually found it - at the bottom of the washer. It had been in a pair of my jeans in a pocket I didn’t check before washing them. I was smart enough not to try turning it on and dried it out for about two weeks first. The computer (Win 7 64-bit Enterprise) sees it, installed the driver, can access the music, everything, but it says there’s no charge on the battery. Tried a reset and the forced-MSC mode, tried the back ports and a wall charger - nothing.

I really REALLY don’t want to have to replace it. The Clip is a cute alternative, but I love the navigation wheel on the Fuze. I’m hoping somebody has an idea I haven’t tried yet.

I neglected to mention that the screen is black, too.

Well…you may have killed the battery when it was wet for that long. All I can suggest is leaving it on the USB to charge slowly (as opposed to the faster wall charger) and hope for the best. But you may have to give up and get the Clip+. It’s not as good but it’s adequate. 

The Fuze is an old unit, rechargeable batteries do give out, and who knows how the battery was reacting to being repeatedly washed.

Ditto for the backlight. 

That’s what I’m afraid of, too. I only washed it once and tried to dry it thoroughly with mild warm air (exhaust from my computer, since the furnace isn’t running, and I’ve always been skeptical about rice). I saw a post online about replacing the battery. I know it’s not really a serviceable unit, but I’m a decent hand with tools.

Have you tried resetting it?

You mean holding the power switch on for 15-20 seconds? Yes, several times.

I assume you have found this, which has info on the replacement battery name: 


Or this, with more pics:


All I can say is, you’d have to get the replacement battery and try it. The fact that your computer connects is promising–at least that connection is working fine. But from what I’ve read, you’re going to have to have a very delicate touch with the ribbon cable.  

And be good with a soldering iron. 

The Fuze really wasn’t built for any kind of servicing. If it were, I’d get my headphone jacks resoldered…that’s what gave out on mine. 

I don’t know how much the replacement Fuze battery would cost.

Lately I have gotten a couple of refurbished Clip+ for $20 or so each, from reputable-looking sellers on eBay or Amazon, and they have worked fine out of the box. I have only been using one of them longterm, but it’s going strong.

There is a slight downgrade from the Fuze to the Clip+ in sound quality, because while they have the same digital-to-analog chip the headphone amp is less powerful. And you don’t get to see album art on the Clip, just text.  But for $20, it’s not the worst alternative. 

Then again, if you get yours fixed…maybe you can fix my Fuze headphone jacks :) 

Hi Zeke, did you ever get this fixed? Would be nice if you can update the thread. 

No, I still haven’t. I did find another one in good shape, but I’m fixated on fixing “mine”. It talks to the computer and occasionally shows some charge on the Windows interface (that then dissipates the instant I slide the power switch). However, the screen (or at least the backlight) is inoperative and so is the light around the wheel, which should light when charging from the wall, unless the dead battery prohibits that. This seems to suggest that there’s a problem with the power, though there may be other issues too.

I’m trying to scratch up a parts unit and will crack the case open as illustrated one of the previous replies. I’m slow, so this may take awhile.

Another post inspired me to try the SD card. It can’t see that either. I’ll keep experimenting some. Eventually, I’ll have to crack the case open, I’m sure.

OK, this is weird. I used the new Fuze to help me navigate the menus on the old one, and it got it to play. It plays, it has some charge on the battery, and the navigation wheel works. I used a flashlight to force some light onto the display, and I can tell that it works, except for the backlight.

So, it seems that the backlight and wheel light don’t work, and the computer doesn’t see the SD card when I insert one. I guess that’s progress, at least in narrowing the problem.

Bulbs do burn out.  But I would try reinstalling the firmware, just in case whatever controls the backlight has gotten glitchy.

Remember, Google & eBay are your friends, also Craigs list. I also got a deal on one at, of all places, ToysRUs.

Just an update on my washed Fuze…

I popped the cover, and everything looks clean and uncorroded inside. The display and the wheel lights are connected to the motherboard through different ribbons (as shown in nice pix on a link from a previous reply), so it seems unlikely that those out by a common root cause, if it’s a physical failure.

Since I can’t see the display, I tried the second method of updating the firmware. The instructions are a little fuzzy, but I interpreted them as extracting the files in the ZIP file from the Sandisk site and put them into the root directory of the player. I did that, but it didn’t seem to do anything, possibly because I was doing it wrong.

It still works, and I still use it more than my fully operational replacement. (How’s that for sentimentality?)

Yes, Unzip and drag the unzipped firmware onto the Fuze driveletter.

But there are two versions of the Fuze with different firmware–v1 and v2–and the update will only run if it’s the correct version.  If your display worked you could see which version…but it doesn’t.

When you disconnect after the update the Fuze should show that it’s updating. If it didn’t do that, then try the other version.

It’s a V2. I could verify that. The file names didn’t match anything in the root directory. I had expected to be over-writing something. It must have something on-board that looks for those files and makes the update when it sees them.