don't understand tag editing - someone please explain

I have been advised to get tracks in order by editing tags, but cannot understand what this means.  I installed MP3Tag and navigated to the folder with my podcasts in it, then clicked “select folder.”  The “tag” column says the same thing for everything in the folder, and nothing I do changes that except “remove tag.”  I can’t understand the instructions - they assume I already know something about tags.  What do I do so that the files in this folder will appear in alphabetical/numerical order on my Clip instead of randomly? 

Have mp3tag display the folder with songs in the desired order. Clicking a column header will cause that column to sort. To set track numbering, use Ctrl-A to select all the files, then tools/auto track numbering and respond to the dialog. You can set album in same way by selecting everything and filling in Album block on right. You can make song title correspond to file name. Play with mp3tag a while.

The easiest way to learn how MP3Tag works is by giving the utility a group of files to work with.

How do we do this?  Let’s use a wee bit of Sansa magic.

Plug in your Sansa.  Open a Windows Explorer Window by pressing the [Windows Key] + E.  Locate your Sansa, (MTP) under Other, or (MSC) as a flash drive.

Grab a few music files by highlighting them, then drag-and-drop them to the Desktop.

Now open MP3Tag, giving it the folder location as your Desktop.  The music files will all load into MP3Tag (But the original copies, either in your Library or on the Sansa, will not be altered.)

Have a blast playing with the functions!

Bob  :smileyvery-happy:

To help you out:

MP3Tag Help page, which goes through the software and its options:  http://help.mp3tag.de/

MP3Tag FAQ:   http://forums.mp3tag.de/index.php?showforum=12

MP3Tag General Support page:  http://www.mp3tag.de/en/support.html

If you ever get a newbie again with this problem, tell him to check properties\details#.  I had never assigned track numbers to my podcasts, and various ones had 0 or 1, giving me random order when I copied them to my Clip.  I feel dumb, but it’s good to have learned this.  Thanks for mentioning track order.