Does not work no matter what!

I had ordered my express player in June. It did not want to fast forward so I returned it to the place where I got it from.  Then in October it just craped out (bricked up, froze up, etc).  I tryed to return it again but it was too long already.  So I finally logged on to the forum & found what I thought would help me (downloading firmware & other stuffs).  I got fustrated after 20 trys of pluginng it into my computer & holding the (-) volume.  So I tried restarting my computer & it said that it is connected but I could not find the icon in my computer. HELP!!!

One thing that you might see is that the icon doesn’t appear in My Computer, but you will see an icon in Device Manager (this is mentioned once or twice if you read through the above thread.)  If you follow the rest of the instructions exactly, it should work fine anyway as long as you see Device Recovery appear somewhere in Device Manager.

Ok, I have tried all of the suggestions and nothing is working, when I turn it on mine is doing the showing Sansa and then building database, then it goes off.  I plug it in to the USB and it says reading and then shuts off, it goes off and on while it is plugged in to the computer every couple seconds, the battery is fully charged.  It does not register at all on my computer.  The soft reset and hard reset did not work nor did updating the firmware.  I think I need to send it back for a new one.  Help!