Does not turn on but not dead either HELP

Ok, i have read the forum and understand the reset 20 sec press/release/press to turn on.

Mine does not turn on.

I  have let the battery run all the way down and six mo later (patience is  virtue) tried ot charge it and repeated  the reset procedure.

Stilli does not work.

HOWEVER:  when i plug it in to the PC to charge, the PC recognizes the device and does a “ring in” tone.  I can unplug it and the PC does the “ring out” tone" sothe PC is recognizing it.

ALSO, when i do the 20 sec reset procedure, i get the “ring out”  tone from the PC and when i release the on buttone and press it again, i get the the “ring in tone”  so the PC is recognizing some sort o activity on the unit.

Better yet, when first plugged in, autoplay starts up and i can tell it to display the contents of the player.  It is empty.  I can see the SANSA in  the windows browser.  I can copy music to it.  I can play the music back from the SANSA memory on the PC.

When i browse the SANSA, there is no directory STRUCTURE–no directories=–just the root folder.

But nothing i can do will make the unit come alive to play.  i have tried to blindly start it playing by pressing the select and play buttons…but no response through the earbuds.

Oh, i also opened the device up (brave soul am I–hey, once an engineer, always and engineer!) and measured the battery terminal voltage as 3.75V.  With the unit plugged into the computer, the voltage remains the same.  I tried to operate the on switch with the case open…nothing happened.

SO: my conclusion is that the basic nit is working but the Human Machine Interface portion (the standalone unit vs the PC connection) is not.

Any ideas as to how to get the display on?

If it works fine when connected to the pc, and the battery measures okay, are you sure the battery is connected properly to the player? Sometimes a battery wire can come loose. You could try formatting the player with your pc(as FAT32), and see if it will turn on after that. If so, then format it again using the player’s menu. i assume there is no card in the player. If there is, then remove it.

Thank you for the quick reply.

Yes, i had removed the external flash memory so that i has only its native internal memory.

I believe that it’s unlikely tht the unit is not getting battery power as the battery connections to the system circuit board is in tact–otherwise the battery would not have charged up.  Also, i believe that the charger (There has to be a voltage regulator since it appears that there is only 3.75 V on the battery with and without the unit being plugged into the computer and the USB puts 5 V on the connector).    Additionally, i don’t think the unit would present the internal flash memory to the PC and allow me to access it.  Yes, the USB is supplying power during that but my other Sansa lights the display for a while when i plug it in…and t his broken one does not.

I will try reformatting the Sansa internal memory from the PC.

BTW: i tried to run the SANSA flash upgrade to reflash it…but the app does not seem to run with it:  I get a flash screen when i run it that is on the PC for about 1/2 second–gone so fast that i could not even read it.  It did have some sort of big picture on it but was gone in a flash (pun intended) with no obvious execution.

Thanks again.  IF the reformatting does something, i will post it here.

Well, tried another volley of attacks on the Sansa.  I fear it is a rock.

I did a PC reformat of he internal memory and tried all the usual tests as before (20 sec reset [did not work], accessing it from the PC [i can se the file system–empty], opied files to the internal memory [success but will not play from the Sansa but i can play it from the Sansa memory with the PC.]

I then tried the flash updater…it did not work at all…

Then i tried the manual update, dragging the clppa.bin fine to the Sansa.  still cannot make te Sansa do anything.  Right now as i plug it into the PC, it “rings in” but the folder is not displayed.  Not sure what that means to this puzzle.

SO, unless someone has another idea, i will unplug and let the battery die one more time and pick this up in a few months and if there is no change, i will consider it to be a rock.

Any last ideas would be appreciated.

Just a last-ditch thought:  how long are you leaving it to charge for?

You might try, let the battery die down and then leave the player alone and charging for a few days.  Sometimes this trickle-charging has kicked the player’s mechnics into action, getting matters back to normal.

I mean, at this point, it couldn’t hurt . . . .     :wink:

Thanks for the idea but I had already left it on charge for several days.  I’ll hang onto the unit for spare parts assuing that the battery is still good and i have had earphone jacks break loose before.  I t hink it is toast unless i hear from someone else.  As a former engineer used to trying to diagnose things, i cannot think of anything we have not tried. I will mark the thread closed but wil personally remain open should some post again. 



A last thought–try it again in a few weeks.  The gremlins have been known to bring a player thought dead back to life.  Really.    :slight_smile:

Did you try giving it a long charge with a 5 volt cell phone charger? Make sure the charger says 5 volts on it, which is the USB standard. Most are, but a small percentage of chargers might be a slightly different voltage.