Diskpart error on Sandisk ssd u100 252GB

Dear Ladys and Gentlemen

I am facing some Problems with my OEM Drive Sandisk U100 SSD

As somebody already said that i have to run diskpart on my drive to get it back into life. 

This is what happend

  1. Insert the windows 7 DVD into the DVD drive.

2.On the disk selection screen, press SHIFT+F10. A Command Prompt window opens.

3.Type diskpart, and then press ENTER to open the diskpart tool.

4.Type list disk, and then press ENTER. A list of available hard disks is displayed.

5.Type sel disk #number, and then press ENTER. number is the number of the hard disk that you want to clean. The hard disk is now selected.

6.Type det disk, and then press ENTER. A list of partitions on the hard disk is displayed. Use this information to verify that the correct disk is selected.

7.Make sure that the disk does not contain required data, type clean all, and then press ENTER to clean the disk. All the partitions and all the data on the disk is permanently removed.

8.Type exit, and then press ENTER to close

9 Proceed with the installation of the Windows

At point 7 i get this message 

Microsoft DiskPart-Version 6.1.7601
Copyright © 1999-2008 Microsoft Corporation.
Auf Computer: PAPA-PC

DISKPART> sel disk 2

Datenträger 2 ist jetzt der gewählte Datenträger.

DISKPART> clean all

Fehler in DiskPart: Die Anforderung konnte wegen eines E/A-Gerätefehlers nicht a
usgeführt werden.
Weitere Informationen finden Sie im Systemereignisprotokoll.

DISKPART>

It pretty much says E/A Error Cant proceed with command

The Drive is connected to my Main Computer over a USB Adapter.

I managed to wipe all data on the drive with a partition manager. 
But i am still not able to initiate the drive. looks like there is a chip the still contain old data.

any way to to reset this data?

Didnt really worked  

FUUU