Disk activity is slowing down computer to a halt

Hello all,

I’m new and really do not know how things work here but I’m willing to give it a shot.

Anyway, I just built a brand new PC and I am getting my SSD Plus 120gb disk activity up to 100% when there is no process that is demanding open. Basiclally what happens is that my active time goes all the way up to max, causing windows to slow down and even restart windows explorer. Also, I received a BSOD message twice but at random. They were both NPC_WATCHDOG_VIOLATION errors if that means anything. It’s making running this new computer miserable and I would like to fix it quickly. I have tried many solutions including SFC \STARTNOW to see if there are any errors with windows and they were aparently fixed. This seems to happen mostly after I do a cold startup meaning that I have not been using it and have turned it on from nothing (no sleep mode or restart). 

To clarify a few things, this is a brand new SSD. I bought it no longer than two weeks. I am running on windows 10 pro 64 bit (a genuine one might I add). I upgraded windows from windows 8.1because it was cheaper just to upgrade from that. I am running with two hard drives, an SSD (the drive in question) in which I am trying my best to get it to remain for OS and drivers only. I also have a 1tb toshiba HDD for storing everything else (programs, files, ect.). I am running on an AMD a10 7870IK and 8gb of DDR3 ram.

Nothing is overheating and windows should be fine. if anyone has a suggestion or has experience with a problem like this. Can you please let me know as soon as possible so I can start truely enjoying this brand new computer.



Can you install SSD Dashboard and generate a SMART report for us ?

I will send you an private mail requesting your contact information and have one of our agent contact you.


Would be nice to see the results here… as people come to solve problems… your resolution might help the rest of us.

I’m sorry for the lack of my resolution, i solved it not too long ago and forgot about this post. Anyway,I found that this was a mixture of many problems. The first problem is that the build of windows 10 that I had at the time(and still does if I am not mistaken) has a problem with the SATA controller drivers. Which would make sense as this problem occured whenever any process was done on the SSD. Another thing that was causing my problem was AMD display drivers. I have no clue why this was a problem but using the previous version of the current version fixed that issue. And finally, there were all sorts of drivers for the motherboard that were aparently out of date that windows was not recognizing. I used driver toolkit to install everything that I needed.

Once again, I apologize for not posting sooner but I hope this helps other peoples situations.

1 Like

Thanks, Good to know you got it all sorted out!