Disconnected message when it is connected

I have been using this to listen to audio books with no problem.  This time when I have deleted the past book to transfer a new book I get a Disconnected message on the screen.  I have tried different USB ports on my computer and different USB cords (Both my husband and I have this).  I can’t get it to recognize anything.  Any advise would be appreciated!

Hi, I just experienced the same thing for my sansa clip just a few minutes ago. I had no problems with it in transferring music from the same desktop for almost 4 months already. Please help!!

Try a different USB cable and different USB ports.  Lots of times it’s the cable.

Try holding the power button “UP” for 15 seconds, wait a few moments, try turning on and off then reconnect to computer.  This resets the unit.

Force MSC mode - power button “DOWN” in hold (orange showing), press and hold CENTER button while connecting USB cable (& don’t release CENTER button until unit is recognized).  You won’t be able to transfer DRM-protected content but it might just fix what’s ailing you.

Hope this helps.

Thanks, this worked. I just received my 1GB Sansa, plugged via USB, my PC loaded the info, did the restart.

Up and running the screen on the Sansa: Disconnected  (plus a battery icon with almost no charge.

Unplugged the USB cable; held the power button “UP” for 15 seconds & turned off Sansa, when turned

back on all is working…Screen shows “Connected”, battery charging…Etc.