device not start code 10

hey there  i am having this problem  now.  had an older computer and everthing worked good  just got a new emachine and  cannot get my sansaclip going  does not aknowledge it presence on this computer any help would be  appreciated

There are several things you can try.

this has worked for some clip users:

-Make sure you are logged in as an administrator
-Open your command prompt (Start->Run->“cmd”->press Enter)
-Type the following:

Net localgroup Administrators localservice /add   -edit: localservice has no space for this command -  µsansa

-Close the command prompt and reconnect the Clip

you can also make sure you have wmp 11 installed , as it installs MTP drivers


you can can try switching the clip’s USB mode to MSC  (change under settings - usb mode)    and then connect to the computer


some clip users have tryed installing Microsofts MTP porting kit with success

Report back if one of these methods worked for you,  Good luck :slight_smile:

Message Edited by microsansa on 02-04-2009 10:26 AM

Hi all,

Tried each of the suggestions from niko_sama’s post to get rid of my ‘device cannot start’ error code 10 (XP SP2, WM11).  After each attempt, it still saw the clip as a USB mass storage device, but it couldn’t start.

I uninstalled the clip in Device Manager and then changed the clip’s USB mode to MSC and it installed cleanly, and is working fine.  Wish I would’ve tried that first.

Good luck.

Indeed, using the device manager, and uninstalling the mounted device, then cycling it via unplugging, works fastest.

You can try a simple switch to MTP (manually select MTP on the Sansa), and do the same thing in this mode.

MTP is a virtual mode supported by Windows Media Player 10 and 11.

Bob  :stuck_out_tongue:

Hello all,

Don’t know if there’s one solution to this problem.  I tried  uninstalling the device from the Device Manager.  It seems to have worked for some.  Did not work for me.

I tried downloading the MTP (?) file “extra” from the Sansa website.  That did not work for me either.

Finally, I downloaded Windows Media 10  and the Clip is now readable on my computer.

Something fishy?  Who knows.  Good luck to everyone with this problem.


Windows Media Player 10 and 11 have the required drivers for MTP mode.

Windows XP was shipped with WMP 9 originally.  If you have issues with device communication in MTP mode, Microsoft’s error and status messages can be confusing.  For example, if you plug in to a WMP 9 environment, you will get two messages, “device found”, and “MTP device”, yet the Sansa will often not show up in Windows Explorer.

Open Windows Media Player, then at the top of the screen, click on Help > Check For Updates to upgrade your media player.  After updating, reboot the PC, and see if the Sansa is now seen in MTP mode.

You also have the option of changing the communications mode of the Sansa to talk in MSC mode, where it will be recognized as a flash drive.  On the device, Settings > System Settings > USB Mode > MSC.