device malfunction

i copied a song from my laptop to the sansa express (1gb) and then turned the laptop off .
now i m unable to switch on the sansa express from  that time. and when i try to connect the player to the laptop through the usb drive
it shows a message unknown device and no driver installled for this device . how do i solve the problem plzz help me out…

I have this problem too. Pls. help urgently. Tried all options. :frowning:

Do you try holding center button (enter) and pressing + ?  or manually flash FW 01.01.05A ?

Thank you, I had this same problem and it fixed it (holding center button and + at same time); device was reset with all my music files still there!  i think my problem was caused by powering down the laptop without properly shutting down and removing the USB device (sansa player) first.

please am having the same problem of device malfunction.what do you mean by flashing Fw 01.01.05A and how do i go about it.This problem is causing me alot of pain.

 Please i have the same problem who do i go about it. Thank you

@kafui wrote:
 Please i have the same problem who do i go about it. Thank you


The first thing to try is to do a hard reset of your player. Here are the instructions from the manual.

“To perform hardware reset on the Sansa Express™ device, press and hold the Select
button while pressing the Volume Up (+) buttons simultaneously.”


Then, turn your player back on to test it out.