Deleted files still show up on Sansa Clip+ but not computer

I transfer audiobook files ripped from CDs onto my Sansa Clip+ using Windows Media Player. I delete them using Windows Explorer. Some files never seem to delete from the player, though I can’t see them in Explorer, even when I use the “show hidden files” view. I also can’t play these phantom files, either, and don’t want to – I just want them gone.  How can I get rid of them?

Go to Settings/System Settings/USB Mode. Try both MTP and MSC. Your computer can only see one mode at a time.

Thanks, Black-Rectangle. I tried that before posting. It didn’t work. Other ideas?

How about hooking up to WMP and deleting them from there instead of trying to find them in Windows Explorer?  Also, make sure you empty the Recycle Bin on your computer before disconnecting.

You can very tediously delete them one by one from the player.  Go to the song, maybe play it, push the button at the 6 o’clock position (with the menu-looking icon) and scroll down to Delete Song.

Also, one other trick. You may not be seeing files. You may be seeing listings that weren’t deleted. In MSC mode, connect and look for MTABLE.SYS . That is the database that lists the files–essentially an index. Delete MTABLE.SYS (ignore the warning that it is a System file if you get it), disconnect, and with Refreshing Your Media  the Sansa will build a new index from the files actually on the player. Your phantoms may disappear.

You can also go nuclear and completely clear off the player by going to Settings/System Settings/Format. That removes all user content and leaves just the software.  Obviously you should be sure you have copies of your files elsewhere.

1 Like

No go, unfortunately.

At one point they showed up in WMP but wouldn’t let me delete them from there. Now I don’t see them in WMP any longer, but I still do on my player.

I tried deleting them directly on the player but nothing happened.

I deleted the MTABLE.SYS in MSC mode and then refreshed, but that did nothing.  They still show up.

I think you’re right that they are just listings, rather than files, because there are literally hundreds of them and they’re not taking up space and won’t play. (They’re tracks of audiobooks ripped from CDs.)

I know the reformatting is an option, but don’t want to do that to fix an annoyance, rather than a real problem.

Is there anything else that might work?


Were the audiobooks ripped on a Mac? Mac adds a subfolder in the album folder called MACOSX with finder files that are named with a dot underscore:  ._01-Track01.mp3. The Sansa lists them because they have the .mp3 extension. You could connect and search for MACOSX and delete all MACOSX folders . You can also delete all DS_Store files, which are also Mac junk.

Otherwise, I have no idea what they are. WMP does its own funny indexing things, but I don’t use it.

MTABLE.SYS is actually just a text file. You could copy it onto your desktop, change the name to MTABLE.txt and take a look at it–maybe it will give you an idea of what’s going on.

If you scroll down Music to Folders, you’ll get a better idea of where the files actually are. Are they in the same folder with each audiobook?

It might be best to just Format/nuke it and transfer things over directly with MSC mode. You only need MTP mode if you are using library audiobook systems like Overdrive, which need MTP to transmit hidden DRM (digital rights misery) codes. Audiobooks ripped from CDs don’t have those codes.

Was any solve found?  I am having the same problem.

I uploaded to my Sansa Clip+ Christmas music and podcasts via Windows Explorer.  After Christmas I went and deleted them all using Windows Explorer.  Windows Explorer shows them deleted.  WMP shows them deleted.  But the Sansa Clip shows them still listed.

If I try to play them with the Sansa Clip+ they do not play, obviously because the music files are deleted but the listings are not.

I have tried deleting the listing with my Sansa Clip+ and it does not work.

How do I remove these listings from my player when the digital files are already deleted?

Have you tried deleting MTABLE.SYS ?

I reformatted the player and all is good.  I needed to reload my music, but that was only eight albums, so it was no big whoop for me.

I hate to imagine what it would be like if I, or someone else, had hundreds of albums.