Deinstitutionalized player w/ lost track numbers

I got my player back after de-institutionalization.  They reloaded all the files but now the files show up in the albums in alphabetical order not track number order.  My player doesn’t show track numbers in the info screen.  Is there a way I can edit or put the files in the proper track number order for all the albums.  It is driving me crazy that the songs are not playing in the proper order. 


A highly-regarded freeware ID3 tag editor:  MP3Tag.

Miikerman’s suggestion is a good one !

Try creating 2-digit track numbers for one album on your player. (starting with 01, 02, etc)

This should allow proper ordering of album tracks in “Music mode”.

Let us know your progress !

I’ve got the mp3 tag editor and copied all the files off my mp3 into a thumb drive and then sorted the files by artist album and track number.  The songs are now in the proper order.  So now what do I copy to my mp3 player to get the songs in the proper order on it?  Do I need to delete all the files off the mp3 player?  I appreciate all of your help.  Thank you and Merry Christmas

You are making excellent progress !!  Always best to avoid having confusing duplicates on your player.

I like to test out my Clip Sport experiments using a few albums at a time.

2-digit track numbers should produce your desired play sequence in Music Mode. 

The order you sort folders & files in Win Explorer and then copy to your player will be best for Folder Mode. 

Let us us know your progress 

So, just to make sure, for each of your albums, you imported the album into MP3Tag and then edited the track no. ID3 tag for each song so that the track nos. now order the album’s songs correctly, and then you saved your edits?  And I assume that you did all of this on your PC/thumbdrive and that your PC/thumbdrive now has a copy of all the music on your player, the only difference being that the PC/thumbdrive’s copy of your music has edited ID3 tags?  

If that’s the case, you would want to delete all the music on your player and then copy the music that you edited, on your PC/thumbdrive, to your player.  When you then detach the player from your PC, your player will take some time creating its database from the ID3 tags, and then you should be set to go for a music-filled holiday!

Do me a favor first, though:  assuming that you have some extra space on your PC or have an extra storage media around, before you delete the music off your player, put a copy of it on your PC or extra storage media, just in case you need to go back to it.  Better safe than sorry.

Hope this all works smoothly–keep us advised!    :)   And a very happy holiday to you!  

OK yes this is a big help.  But first let me say that after I copied all of the files off of my mp3 player to the usb drive then opened it with the tag editor the songs were not in the right order.  So I used the tag editor to sort the songs by artist, album, and song number.  After doing this the songs were in the correct order.  One of the song errors was that the album had more than one disk and the song in incorrect order didn’t have an album number so the songs off of it were by song number and those were duplicates of another disk, (so I had two #9 songs and #10 songs etc.)  which was why the song order was bad.  I gave each song that didn’t have an album number an album number so the songs were then in the right order. 

Basically I guess my main question is how do I save these changes? 

Plus that is a great idea to backup my mp3 player to a separate directory  so if something were to go wrong I could go back to the original files. 

When I open the files on the usb drive they are not in the correct order but I use the tag editor to sort by artist and album and track number then they are in the right order so I’m guessing that this is when I need to save my work.  But I have never edited anything other than using the program to sort the files. 

Thanks again and yes this is a good holiday and would be even better if I had my songs in order.

Merry Christmas  

By putting the songs “in the right order” in the album, you need to actually edit/change the track numbers shown in MP3Tag under the Track column–that is what the player will use, in its database, to determine which song is the first, the second, etc.  Once you have edited the Track column numbers, you select/highlight all the songs in the album (an easy way:  ctrl + a), and then choose the save icon at the very left of the MP3 toolbar (or choose Save under the File list).  If there is any question if this worked, you can exit MP3Tag, bring it up again, and then load your album–it should show your edited Track nos. under the Track column (if it doesn’t, your edits did not get saved).

Hope this helps!

Ok this is a big help.  The track numbers are actually in the track number column.  So for some reason the firmware on the MP3 player is putting the tracks in alphabetical order.  So if I go in tag editor and get the tracks for the whole MP3 player in the correct order and save this in the tag editor what do I do with the saved file to get this on the MP3 player?   

You have been a great help and sorry I have been so much trouble it’s been some time since I’ve had to work on a computer but it is coming back to me — Slowly!  

Yep, that’s it.  The explanation:  most modern players have an internal database using metadata–the ID3 tags–embedded in the song files.  The major metadata/ID3 tags are for album, song, artist, year, and genre.  When you select a song to play on your player,  you are selecting the ID3 tag info. that is in the database.  The problem then is, sometimes this info. isn’t already filled in when you get a song, or is incorrect.  That causes issues for the player.

Nicely, the Clip also has a separate way to select a song to play, under its Folder option at the bottom of the Music listing.  With the Folder option, you select music to play just like on your computer, with the songs ordered by filename in alpha/number order.  A good option when the database method won’t work because the ID3 tags had not been filled in, or are incorrect and you haven’t had a chance to edit them yet.

And so:  you use MP3Tag to fill in/correct the Track numbers under the Track column, and then you save your editing work.  (Of course, you also can edit/correct the other info. for a song:  the filename, the album name, song name, the artist name, etc.)  At that point, you simply use your PC and its regular File Folder viewer and copy the songs or the entire Album folder that they are in, and  then paste that into the Clip folder–many people use the Music folder on the Clip, to help keep things organized.  And then you disconnect.  At that point, the player will spend a little bit of time “building” its database from the ID3 tag info. in your songs–if you have alot, this could take many minutes.  And then it will be done and show you the regular screen, and you can enjoy your music in the correct order, just like on a CD or record!

I hope this helps–let us know if it works out for you.

OK I think I understand what you are trying to say.   I’m going to copy all of the corrected songs from my usb drive back onto the MP3 player in the music folder.  I’ll keep you posted.  Thanks again 

Well I don’t know what I have done wrong but I copied all of the songs to the usb then used the tag editor to put them in track order.  I saved this then closed everything and then went back and it was in track number order.  So I erased everything off the MP3 player and copied the edited songs to the MP3 player.  When this was all done and the MP3 player updated believe it or not the songs were still in alphabetical order.  

So I still need help.   What did I do wrong?   

Everyone have  a Happy New Year!

And so, just a blind leap:  how are you viewing and playing the songs–under what menu on the player are you doing this?  Are you playing the songs under the albums selection under Music?  Or are you playing the songs under the folders selection under Muisc?  If the former, it should be playing the songs in track order; if the latter, in alpha/no. order. 

And when you wrote that you put the songs in track order under MP3Tag, you mean that you actually edited/changed the numbers under the Track no. column, right? 

Ok no even under Artist and album selection the songs are still in alphabetical order.  

When I import the songs off of the MP3 player into tag editor the track numbers are there and are correct so I have never edited them just used the tag editor to arrange them in track number order.  But the track numbers were already there so my question is why doesn’t the MP3 player use this info to put them in the correct order.

To me it seems that the MP3 player is set for alphabetical order not track number order.  I have had no luck in finding a way to select a way to change this in the MP3 player itself.  

Ok, I have found all of the  song files that I copied over to the MP3 player under the folder screen then under the internal memory then under music.  These song files are all in the correct order and are by track number,  so why when I go into the music screen and then under the artist or album screen are they not in track number order.

So now that I’ve found the folder selection I can listen to my songs in the correct order so I appreciate that but am still curious why they are not in the track number order under artist or album.  

Thank you for all of your help.   

After following all your messages in this topic, I think Miikerman is providing you excellent advice !!!

One suggestion I can add is to make sure each album is identified uniquely in the album field of the ID3 tag.

     --> Try to establish each unique album title within the first 14 characters !!  (FW 1.36)

           (Don’t waste these 14 characters repeating a long artist name at the start of the album field.)

           (I use artist initials. Like “ABC-Greatest Hits”)

I like to experiment with my ID3 tags by working on one album at a time while seeking my desired results.  

       Of course there are likely many persons who will think all this effort should not be necessary ??

       For me, this is part of the challenge & satisfying enjoyment using my Clip Sport(s).


I like to use 2-digit track numbers in my ID3 tags like this: 01  02  03

  This style does not work for me:  1/12  2/12.    Also this does not work for me:  01/12  02/12 etc

And I use  ID3v2.3 ISO-8859-1 tag style.  I delete all other tag metadata from my MP3 files. (v2.1, Ape, etc)