Dead sansa fuze+, only ROM recovery mode

I didn’t use my sansa from a long time. Last week i want to use it agian, so I pluged it for charging and everything was fine. When player was almost full charged I unpluged it and turn off like usual. Few hours later I want to turn it on, but nothing happens. ofc I push combination of buttons, and still nothing happen. It looks like sansa is realy dead, computer dont rezgonize it. But one thing still works -  ROM recovery mode. I search whole forums about that, but noone can anwser what I schoud do. Is there any solution ? Maybe an aplication that i can flash new ROM or something by this recovery mode ?
Sorry for my low english level, but I’m realy depresed.


i have a sansa fuze plus and tried to install rockbox. Unfortunately during the installation via rockbox utility I had a sd card in the PC cardreader and all files was written on that card not to the sansa player. Now the fuze plus is dead and I cannot even put it in recovery mode using: * Push the volume up button * While holding the volume up button down, plug in the USB cable * 

I connect it to Windows and Linux PC without success.

Any ideas how to fix it?

Thank you

Probably better to search the Rockbox site or ask on thier forums.

I tried wirh the Rockbox forum annd there is not much progress. The fuze stays in ROM recovery mode and I’m not able to upload any software. The device is not visible as a hard drive. Does anyone has an idea how to recover it?
Thank you